summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-05-02 15:25:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-05-02 15:26:00 +0200
commit8f4ac410147427762f2883998f48366c140d81db (patch)
tree7e6fe5a9942d7fdc65eed66a916ecf4fc83253e9 /media-libs
parentapp-admin/keepassx: Removed old. (diff)
downloadgentoo-8f4ac410147427762f2883998f48366c140d81db.tar.gz
gentoo-8f4ac410147427762f2883998f48366c140d81db.tar.bz2
gentoo-8f4ac410147427762f2883998f48366c140d81db.zip
media-libs/harfbuzz: Bump to version 1.2.7
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/harfbuzz/Manifest1
-rw-r--r--media-libs/harfbuzz/harfbuzz-1.2.7.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/harfbuzz/Manifest b/media-libs/harfbuzz/Manifest
index e50daf74001b..6ed9c38a936d 100644
--- a/media-libs/harfbuzz/Manifest
+++ b/media-libs/harfbuzz/Manifest
@@ -3,3 +3,4 @@ DIST harfbuzz-1.1.3.tar.bz2 1294579 SHA256 d93d7cb7979c32672e902fdfa884599e63f07
DIST harfbuzz-1.2.4.tar.bz2 1320609 SHA256 449dbdf12a8f94aedbdefaac831d8b1bf45e7decaa9192eaa4f74104ef9de491 SHA512 fd721f172b329cb39ae053da77fc4ef9675d9578bf1043647dcdc06d6dd92f43cf39a75a780899364b82363f8271269c6eae71169f5c160c726d65fe3fafd16e WHIRLPOOL 0b751f988eb88bf958a7a7ab7783b9c83952f1b2324434630f43e12e7618afebd045b1499bd5605ebf35ce4f4ed15c12761a2a84a3412248bbd17476e6885b95
DIST harfbuzz-1.2.5.tar.bz2 1334740 SHA256 cfca0b6ba42c36a1f7b03fffb926dc4d137be2aa2a2ad8930259072e43a347d5 SHA512 a94b032895490215fdace430f04db02caf79c4ab705edea26844f31a79f4e213558550be216a14fd406cb2aecfab1ae8e1503f7f90b4a38ad498b78554495eb9 WHIRLPOOL 84a41974547eedd8f0306a70092fc06f9d643fcc89eaf2d04fba74f1e0005c36328b44a574723fde2287109813feb314fbbe74d0e8587850751fb0b8458e3d1f
DIST harfbuzz-1.2.6.tar.bz2 1336078 SHA256 7537bacccb3524df0cd2a4d5bc7e168bcc10e8171e0324f3cd522583868192c1 SHA512 00963674f41d12fb231c59813693f7b665924a1b57d9410a7a00de533aa6c5693b3852fbf03b8ed07183fb2e648b9250d949df59830e38c6adc0360ae8580edc WHIRLPOOL ae575709ff48c7c4b06417ecdd2712c5e8ce4c6ed789a64fdf50e884ce35258e5d3d35138ee81a232e852694bba96e4f4455827a74aec97d1143979a638cf5ef
+DIST harfbuzz-1.2.7.tar.bz2 1345389 SHA256 bba0600ae08b84384e6d2d7175bea10b5fc246c4583dc841498d01894d479026 SHA512 e1edfa0bf4936f7d47e5622547429b7f573710ac0c4fc023a7b00e1dceca8aa7f02800166eea0c883ae44d2886c50416d61791a8a8240ddaab9f4e389dadfff2 WHIRLPOOL 2ffcdb29b2a0506afb99e337c426c2e71cbc9ebf75add0ad25367fef6162984109260d6434fd1bf4fa9a8faba520eab1d5b1059286cd0d6d8a602dbf13d9181e
diff --git a/media-libs/harfbuzz/harfbuzz-1.2.7.ebuild b/media-libs/harfbuzz/harfbuzz-1.2.7.ebuild
new file mode 100644
index 000000000000..03f88f153249
--- /dev/null
+++ b/media-libs/harfbuzz/harfbuzz-1.2.7.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/harfbuzz"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils libtool multilib-minimal python-any-r1 xdg-utils
+
+DESCRIPTION="An OpenType text shaping engine"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://www.freedesktop.org/software/${PN}/release/${P}.tar.bz2"
+
+LICENSE="Old-MIT ISC icu"
+SLOT="0/0.9.18" # 0.9.18 introduced the harfbuzz-icu split; bug #472416
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+
+IUSE="+cairo fontconfig +glib +graphite icu +introspection static-libs test +truetype"
+REQUIRED_USE="introspection? ( glib )"
+
+RDEPEND="
+ cairo? ( x11-libs/cairo:= )
+ fontconfig? ( media-libs/fontconfig:1.0[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ graphite? ( >=media-gfx/graphite2-1.2.1:=[${MULTILIB_USEDEP}] )
+ icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34:= )
+ truetype? ( >=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ test? ( ${PYTHON_DEPS} )
+"
+# eautoreconf requires gobject-introspection-common
+# ragel needed if regenerating *.hh files from *.rl
+[[ ${PV} = 9999 ]] && DEPEND="${DEPEND}
+ >=dev-libs/gobject-introspection-common-1.34
+ dev-util/ragel
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ if [[ ${CHOST} == *-darwin* || ${CHOST} == *-solaris* ]] ; then
+ # on Darwin/Solaris we need to link with g++, like automake defaults
+ # to, but overridden by upstream because on Linux this is not
+ # necessary, bug #449126
+ sed -i \
+ -e 's/\<LINK\>/CXXLINK/' \
+ src/Makefile.am || die
+ sed -i \
+ -e '/libharfbuzz_la_LINK = /s/\<LINK\>/CXXLINK/' \
+ src/Makefile.in || die
+ sed -i \
+ -e '/AM_V_CCLD/s/\<LINK\>/CXXLINK/' \
+ test/api/Makefile.in || die
+ fi
+
+ [[ ${PV} == 9999 ]] && eautoreconf
+ elibtoolize # for Solaris
+
+ # failing test, https://bugs.freedesktop.org/show_bug.cgi?id=89190
+ sed -e 's#tests/arabic-fallback-shaping.tests##' -i test/shaping/Makefile.in || die "sed failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ # harfbuzz-gobject only used for instrospection, bug #535852
+ econf \
+ --without-coretext \
+ --without-uniscribe \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with cairo) \
+ $(use_with fontconfig) \
+ $(use_with glib) \
+ $(use_with introspection gobject) \
+ $(use_with graphite graphite2) \
+ $(use_with icu) \
+ $(multilib_native_use_enable introspection) \
+ $(use_with truetype freetype)
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/html docs/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}