summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-12-22 09:30:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2025-01-02 01:12:05 +0100
commit5bfccbe0d250369a25c0cc4341d5f89e25248f98 (patch)
tree0d4c98434782a559d5f01bd65e7b4b6bc72a32b7 /media-libs
parentapp-doc/zsh-lovers: add 0.11.0 (diff)
downloadgentoo-5bfccbe0d250369a25c0cc4341d5f89e25248f98.tar.gz
gentoo-5bfccbe0d250369a25c0cc4341d5f89e25248f98.tar.bz2
gentoo-5bfccbe0d250369a25c0cc4341d5f89e25248f98.zip
media-libs/exiftool: add 13.10
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/39819 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/exiftool/Manifest1
-rw-r--r--media-libs/exiftool/exiftool-13.10.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/media-libs/exiftool/Manifest b/media-libs/exiftool/Manifest
index 0c43151014cb..cefa7cda9593 100644
--- a/media-libs/exiftool/Manifest
+++ b/media-libs/exiftool/Manifest
@@ -1 +1,2 @@
DIST Image-ExifTool-12.76.tar.gz 5320564 BLAKE2B caaacf4e04246c42ea12f0f491c60a95ed0c55a6e68b5007c2b265ba3b04da661bea53f374f3f66903bd9c086bab7526be63145544d3763c41c3437b4a504654 SHA512 3e00718663cf1eb8f9b93ad2bdcaf7beb31d20d40ad7b131cb70155c660795afc8ba430610ece5e2949773667ea27d57eb417b8bf64a108409b336daffa99db7
+DIST Image-ExifTool-13.10.tar.gz 7230651 BLAKE2B 7d4ed8c97719093661485ce375a3e21edbae6d6abadefb9b6ee684941d8b4339ad89ec074bdec7db1d82b36be7f521837936006721120ee1b7dab21977764cc8 SHA512 6364459939e99d76850207f04428d07ec83173c90917f039a5fe6f4029aff03acb370393404b2a5276b89eba4e49eefe7659bff868d9304e69286f80311f2714
diff --git a/media-libs/exiftool/exiftool-13.10.ebuild b/media-libs/exiftool/exiftool-13.10.ebuild
new file mode 100644
index 000000000000..52c077e9bd6b
--- /dev/null
+++ b/media-libs/exiftool/exiftool-13.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check https://exiftool.org/history.html for whether a release is 'production'
+# Ideally don't bump to non-production at all, but certainly don't stable.
+#
+# We fetch from CPAN because it only has production releases and the tarballs
+# are kept around for longer (see bug #924106).
+
+DIST_AUTHOR=EXIFTOOL
+DIST_NAME=Image-ExifTool
+inherit perl-module
+
+DESCRIPTION="Read and write meta information in image, audio and video files"
+HOMEPAGE="https://exiftool.org/ https://exiftool.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="doc"
+
+src_install() {
+ perl-module_src_install
+ use doc && dodoc -r html/
+
+ insinto /usr/share/${PN}
+ doins -r fmt_files config_files arg_files
+}