summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-21 11:45:54 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-21 15:32:59 -0700
commit086532c75d58efb96f785e6363ad9506681819cc (patch)
tree33f938bda87dbc3c0c60a02df0a840a25ae8c4f8 /media-libs
parentsys-kernel/gentoo-kernel-bin: Bump to 5.13.4 (diff)
downloadgentoo-086532c75d58efb96f785e6363ad9506681819cc.tar.gz
gentoo-086532c75d58efb96f785e6363ad9506681819cc.tar.bz2
gentoo-086532c75d58efb96f785e6363ad9506681819cc.zip
media-libs/mesa: Remove IUSE=dri3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/mesa-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index b3ab8d6070d6..dcb48a7d1ae5 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -33,17 +33,16 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 +gles2 +llvm
+ +classic d3d9 debug +egl +gallium +gbm gles1 +gles2 +llvm
lm-sensors opencl osmesa selinux test unwind vaapi valgrind vdpau vulkan
vulkan-overlay wayland +X xa xvmc zink +zstd"
REQUIRED_USE="
- d3d9? ( dri3 || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
+ d3d9? ( || ( video_cards_iris video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
gles1? ( egl )
gles2? ( egl )
osmesa? ( gallium )
- vulkan? ( dri3
- video_cards_radeonsi? ( llvm ) )
+ vulkan? ( video_cards_radeonsi? ( llvm ) )
vulkan-overlay? ( vulkan )
wayland? ( egl gbm )
video_cards_freedreno? ( gallium )
@@ -507,7 +506,7 @@ multilib_src_configure() {
$(meson_use test build-tests)
-Dglx=$(usex X dri disabled)
-Dshared-glapi=enabled
- $(meson_feature dri3)
+ -Ddri3=enabled
$(meson_feature egl)
$(meson_feature gbm)
$(meson_feature gles1)