summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/vamp-plugin-sdk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/vamp-plugin-sdk')
-rw-r--r--media-libs/vamp-plugin-sdk/Manifest2
-rw-r--r--media-libs/vamp-plugin-sdk/metadata.xml5
-rw-r--r--media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild46
-rw-r--r--media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.6.ebuild46
4 files changed, 99 insertions, 0 deletions
diff --git a/media-libs/vamp-plugin-sdk/Manifest b/media-libs/vamp-plugin-sdk/Manifest
new file mode 100644
index 000000000000..22fb99678720
--- /dev/null
+++ b/media-libs/vamp-plugin-sdk/Manifest
@@ -0,0 +1,2 @@
+DIST vamp-plugin-sdk-2.5.tar.gz 168486 SHA256 7b719f9e4575624b30b335c64c00469d3745aef4bca177f66faf3204f073139d SHA512 1b556bc034c4827704ba177819dbf630c9aa6390539767cc447a05f201dadee706b6d58aac9cef6fb21900f3d45f702f13fafbf290e9a737b595b3ecaaa8f3c3 WHIRLPOOL 6196b249b5790bc37c2d0a0286d59b8f60cb483a28939ac7e0b9c45a425d7843540490241dc1f4ef274bd872e51febfcac71020f115838e937780d6878562005
+DIST vamp-plugin-sdk-2.6.tar.gz 174908 SHA256 aa533266e35f866292c30eeac126d2d4abdf2028f1340c0e02354057013728e9 SHA512 0de0eee37629b86c664d42837eb4dbac8bb311af71082b3d0a880c6b475a8de1ab7ac42daf7c1a234dc29690e5788b70011fa01a956941cf414347011e9c27d3 WHIRLPOOL 566afe1c020515325f3641f3dc053fcbe7d6a444c74987484e30677e5df288e7abbc0b6630b9c93425b6463bc0705325be783a39c203760277662aeaf05bb03b
diff --git a/media-libs/vamp-plugin-sdk/metadata.xml b/media-libs/vamp-plugin-sdk/metadata.xml
new file mode 100644
index 000000000000..0dc3775f83d7
--- /dev/null
+++ b/media-libs/vamp-plugin-sdk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proaudio</herd>
+</pkgmetadata>
diff --git a/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild
new file mode 100644
index 000000000000..8a4b6787deeb
--- /dev/null
+++ b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Audio processing plugin system for plugins that extract descriptive information from audio data"
+HOMEPAGE="http://www.vamp-plugins.org"
+SRC_URI="http://code.soundsoftware.ac.uk/attachments/download/690/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 x86"
+IUSE="doc"
+
+RDEPEND="media-libs/libsndfile"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # multilib for default search paths
+ sed -i -e "s:/usr/lib/vamp:/usr/$(get_libdir)/vamp:" src/vamp-hostsdk/PluginHostAdapter.cpp || die "sed failed"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+ if use doc; then
+ cd build
+ doxygen || die "creating doxygen doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_SDK_LIBS="/usr/$(get_libdir)" INSTALL_PKGCONFIG="/usr/$(get_libdir)/pkgconfig" INSTALL_PLUGINS="/usr/$(get_libdir)/vamp" install
+ dodoc README* CHANGELOG
+ use doc && dohtml -r build/doc/html/*
+}
+
+pkg_postinst() {
+ elog ""
+ elog "You might also want to install some Vamp plugins."
+ elog "See media-plugins/vamp-*"
+ elog ""
+}
diff --git a/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.6.ebuild b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.6.ebuild
new file mode 100644
index 000000000000..61a43adfeda1
--- /dev/null
+++ b/media-libs/vamp-plugin-sdk/vamp-plugin-sdk-2.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs eutils multilib
+
+DESCRIPTION="Audio processing plugin system for plugins that extract descriptive information from audio data"
+HOMEPAGE="http://www.vamp-plugins.org"
+SRC_URI="https://code.soundsoftware.ac.uk/attachments/download/1514/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="media-libs/libsndfile"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # multilib for default search paths
+ sed -i -e "s:/usr/lib/vamp:/usr/$(get_libdir)/vamp:" src/vamp-hostsdk/PluginHostAdapter.cpp || die "sed failed"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
+ if use doc; then
+ cd build
+ doxygen || die "creating doxygen doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_SDK_LIBS="/usr/$(get_libdir)" INSTALL_PKGCONFIG="/usr/$(get_libdir)/pkgconfig" INSTALL_PLUGINS="/usr/$(get_libdir)/vamp" install
+ dodoc README* CHANGELOG
+ use doc && dohtml -r build/doc/html/*
+}
+
+pkg_postinst() {
+ elog ""
+ elog "You might also want to install some Vamp plugins."
+ elog "See media-plugins/vamp-*"
+ elog ""
+}