summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-10-25 09:41:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-10-25 09:47:05 +0200
commitd695cf1063fcbea735a021cc83547c1f3240ef98 (patch)
tree4badc0527af9964739e2704c736d64ce16e277f3 /media-libs/sdl2-image
parentmedia-libs/faac: Bump to version 1.29.8.3 (diff)
downloadgentoo-d695cf1063fcbea735a021cc83547c1f3240ef98.tar.gz
gentoo-d695cf1063fcbea735a021cc83547c1f3240ef98.tar.bz2
gentoo-d695cf1063fcbea735a021cc83547c1f3240ef98.zip
media-libs/sdl2-image: Bump to version 2.0.2
Package-Manager: Portage-2.3.12, Repoman-2.3.3
Diffstat (limited to 'media-libs/sdl2-image')
-rw-r--r--media-libs/sdl2-image/Manifest1
-rw-r--r--media-libs/sdl2-image/sdl2-image-2.0.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-libs/sdl2-image/Manifest b/media-libs/sdl2-image/Manifest
index 3fe572f69cac..d27a71d230f9 100644
--- a/media-libs/sdl2-image/Manifest
+++ b/media-libs/sdl2-image/Manifest
@@ -1 +1,2 @@
DIST SDL2_image-2.0.1.tar.gz 7797848 SHA256 3a3eafbceea5125c04be585373bfd8b3a18f259bd7eae3efc4e6d8e60e0d7f64 SHA512 99ed5f7b69966cea5fcf9173e7270167c24b55ab459774f10dbf90f26dcb9d5f118971ffd4e583a83148976f44ca166474669398a561169d24ffba80f852306f WHIRLPOOL ba4a78ae19ba1921b0d11208f93390cc0ec31aed86f302c2b8d4ac8c55a8e783c29a3180d8557309b2874d74a081734256e9cb0d8215b369090abddf64bd0a7c
+DIST SDL2_image-2.0.2.tar.gz 8680980 SHA256 72df075aef91fc4585098ea7e0b072d416ec7599aa10473719fbe51e9b8f6ce8 SHA512 468f1a5aaee0b6920adb80df21aaaa41bfc5c642b4a00ac60244a90c5e9f27b092b73bcdd2c5520aa1de2759e8b174686b186a51f2d07e7e188ce2cd10519724 WHIRLPOOL 7ff628bd65b70663c42537d31877f8929ca317a8ab71c64c72522a92b86906a7774dcdc60e57ca4f5e67204fe4bf134c64fd9006366ea32c0ab481b0f9e5b9d7
diff --git a/media-libs/sdl2-image/sdl2-image-2.0.2.ebuild b/media-libs/sdl2-image/sdl2-image-2.0.2.ebuild
new file mode 100644
index 000000000000..c3b1db990775
--- /dev/null
+++ b/media-libs/sdl2-image/sdl2-image-2.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit ltprune multilib multilib-minimal
+
+MY_P="SDL2_image-${PV}"
+DESCRIPTION="Image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ >=media-libs/libsdl2-2.0.1-r1[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ png? ( >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}] )
+ jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+ tiff? ( >=media-libs/tiff-3.9.7-r1:0[${MULTILIB_USEDEP}] )
+ webp? ( >=media-libs/libwebp-0.3.0[${MULTILIB_USEDEP}] )"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/${MY_P}"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ --disable-sdltest
+ --enable-bmp
+ $(use_enable gif)
+ $(use_enable jpeg jpg)
+ --disable-jpg-shared
+ --enable-lbm
+ --enable-pcx
+ $(use_enable png)
+ --disable-png-shared
+ --enable-pnm
+ --enable-tga
+ $(use_enable tiff tif)
+ --disable-tif-shared
+ --enable-xcf
+ --enable-xpm
+ --enable-xv
+ $(use_enable webp)
+ --disable-webp-shared
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ multilib_is_native_abi && newbin .libs/showimage$(get_exeext) showimage2$(get_exeext)
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ prune_libtool_files
+}