summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2016-09-22 18:08:23 +0100
committerAmy Winston <amynka@gentoo.org>2016-09-27 16:22:31 +0200
commit366480ac81d84673ffbbfcfff277a91d6c6041df (patch)
treecbded2125dd94440900341c653047ac2586b5b87 /media-libs/opencv
parentmedia-gfx/imagemagick: Stable for HPPA PPC64 (bug #595200). (diff)
downloadgentoo-366480ac81d84673ffbbfcfff277a91d6c6041df.tar.gz
gentoo-366480ac81d84673ffbbfcfff277a91d6c6041df.tar.bz2
gentoo-366480ac81d84673ffbbfcfff277a91d6c6041df.zip
media-libs/opencv: revision bump to 3.1.0-r5
- Feature: added in support for installing the Python module for each implementation selected Gentoo-Bug: 593504 - Bug fix: under certain conditions the HDF5 library isn't found Gentoo-Bug: 588850 - Bug fix: OpenGL needs Qt or Gtk+ otherwise it's disabled - Misc: cleaned up usex expressions added qtwidgets depend moved openmp detection to pkg_pretend as per Gentoo style guidelines Signed off by Jonathan Scruggs (j.scruggs@gmail.com, irc: Dracwyrm)
Diffstat (limited to 'media-libs/opencv')
-rw-r--r--media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch392
-rw-r--r--media-libs/opencv/opencv-3.1.0-r5.ebuild300
2 files changed, 692 insertions, 0 deletions
diff --git a/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch b/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch
new file mode 100644
index 000000000000..af86cf98084b
--- /dev/null
+++ b/media-libs/opencv/files/opencv-contrib-find-hdf5-fix.patch
@@ -0,0 +1,392 @@
+diff -purN a/modules/hdf/cmake/FindHDF5.cmake b/modules/hdf/cmake/FindHDF5.cmake
+--- a/modules/hdf/cmake/FindHDF5.cmake 1970-01-01 01:00:00.000000000 +0100
++++ b/modules/hdf/cmake/FindHDF5.cmake 2015-09-16 17:53:05.000000000 +0100
+@@ -0,0 +1,379 @@
++#.rst:
++# FindHDF5
++# --------
++#
++# Find HDF5, a library for reading and writing self describing array data.
++#
++#
++#
++# This module invokes the HDF5 wrapper compiler that should be installed
++# alongside HDF5. Depending upon the HDF5 Configuration, the wrapper
++# compiler is called either h5cc or h5pcc. If this succeeds, the module
++# will then call the compiler with the -show argument to see what flags
++# are used when compiling an HDF5 client application.
++#
++# The module will optionally accept the COMPONENTS argument. If no
++# COMPONENTS are specified, then the find module will default to finding
++# only the HDF5 C library. If one or more COMPONENTS are specified, the
++# module will attempt to find the language bindings for the specified
++# components. The only valid components are C, CXX, Fortran, HL, and
++# Fortran_HL. If the COMPONENTS argument is not given, the module will
++# attempt to find only the C bindings.
++#
++# On UNIX systems, this module will read the variable
++# HDF5_USE_STATIC_LIBRARIES to determine whether or not to prefer a
++# static link to a dynamic link for HDF5 and all of it's dependencies.
++# To use this feature, make sure that the HDF5_USE_STATIC_LIBRARIES
++# variable is set before the call to find_package.
++#
++# To provide the module with a hint about where to find your HDF5
++# installation, you can set the environment variable HDF5_ROOT. The
++# Find module will then look in this path when searching for HDF5
++# executables, paths, and libraries.
++#
++# In addition to finding the includes and libraries required to compile
++# an HDF5 client application, this module also makes an effort to find
++# tools that come with the HDF5 distribution that may be useful for
++# regression testing.
++#
++# This module will define the following variables:
++#
++# ::
++#
++# HDF5_INCLUDE_DIRS - Location of the hdf5 includes
++# HDF5_INCLUDE_DIR - Location of the hdf5 includes (deprecated)
++# HDF5_DEFINITIONS - Required compiler definitions for HDF5
++# HDF5_C_LIBRARIES - Required libraries for the HDF5 C bindings.
++# HDF5_CXX_LIBRARIES - Required libraries for the HDF5 C++ bindings
++# HDF5_Fortran_LIBRARIES - Required libraries for the HDF5 Fortran bindings
++# HDF5_HL_LIBRARIES - Required libraries for the HDF5 high level API
++# HDF5_Fortran_HL_LIBRARIES - Required libraries for the high level Fortran
++# bindings.
++# HDF5_LIBRARIES - Required libraries for all requested bindings
++# HDF5_FOUND - true if HDF5 was found on the system
++# HDF5_VERSION - HDF5 version in format Major.Minor.Release
++# HDF5_LIBRARY_DIRS - the full set of library directories
++# HDF5_IS_PARALLEL - Whether or not HDF5 was found with parallel IO support
++# HDF5_C_COMPILER_EXECUTABLE - the path to the HDF5 C wrapper compiler
++# HDF5_CXX_COMPILER_EXECUTABLE - the path to the HDF5 C++ wrapper compiler
++# HDF5_Fortran_COMPILER_EXECUTABLE - the path to the HDF5 Fortran wrapper compiler
++# HDF5_DIFF_EXECUTABLE - the path to the HDF5 dataset comparison tool
++
++#=============================================================================
++# Copyright 2015 Axel Huebl, Helmholtz-Zentrum Dresden - Rossendorf
++# Copyright 2009 Kitware, Inc.
++#
++# Distributed under the OSI-approved BSD License (the "License");
++# see accompanying file Copyright.txt for details.
++#
++# This software is distributed WITHOUT ANY WARRANTY; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++# See the License for more information.
++#=============================================================================
++# (To distribute this file outside of CMake, substitute the full
++# License text for the above reference.)
++
++# This module is maintained by Will Dicharry <wdicharry@stellarscience.com>.
++
++include(SelectLibraryConfigurations)
++include(FindPackageHandleStandardArgs)
++
++# List of the valid HDF5 components
++set( HDF5_VALID_COMPONENTS
++ C
++ CXX
++ Fortran
++ HL
++ Fortran_HL
++)
++
++# Validate the list of find components.
++if( NOT HDF5_FIND_COMPONENTS )
++ set( HDF5_LANGUAGE_BINDINGS "C" )
++else()
++ # add the extra specified components, ensuring that they are valid.
++ foreach( component ${HDF5_FIND_COMPONENTS} )
++ list( FIND HDF5_VALID_COMPONENTS ${component} component_location )
++ if( ${component_location} EQUAL -1 )
++ message( FATAL_ERROR
++ "\"${component}\" is not a valid HDF5 component." )
++ else()
++ list( APPEND HDF5_LANGUAGE_BINDINGS ${component} )
++ endif()
++ endforeach()
++endif()
++
++# try to find the HDF5 wrapper compilers
++find_program( HDF5_C_COMPILER_EXECUTABLE
++ NAMES h5cc h5pcc
++ HINTS ENV HDF5_ROOT
++ PATH_SUFFIXES bin Bin
++ DOC "HDF5 Wrapper compiler. Used only to detect HDF5 compile flags." )
++mark_as_advanced( HDF5_C_COMPILER_EXECUTABLE )
++
++find_program( HDF5_CXX_COMPILER_EXECUTABLE
++ NAMES h5c++ h5pc++
++ HINTS ENV HDF5_ROOT
++ PATH_SUFFIXES bin Bin
++ DOC "HDF5 C++ Wrapper compiler. Used only to detect HDF5 compile flags." )
++mark_as_advanced( HDF5_CXX_COMPILER_EXECUTABLE )
++
++find_program( HDF5_Fortran_COMPILER_EXECUTABLE
++ NAMES h5fc h5pfc
++ HINTS ENV HDF5_ROOT
++ PATH_SUFFIXES bin Bin
++ DOC "HDF5 Fortran Wrapper compiler. Used only to detect HDF5 compile flags." )
++mark_as_advanced( HDF5_Fortran_COMPILER_EXECUTABLE )
++
++find_program( HDF5_DIFF_EXECUTABLE
++ NAMES h5diff
++ HINTS ENV HDF5_ROOT
++ PATH_SUFFIXES bin Bin
++ DOC "HDF5 file differencing tool." )
++mark_as_advanced( HDF5_DIFF_EXECUTABLE )
++
++# Invoke the HDF5 wrapper compiler. The compiler return value is stored to the
++# return_value argument, the text output is stored to the output variable.
++macro( _HDF5_invoke_compiler language output return_value )
++ if( HDF5_${language}_COMPILER_EXECUTABLE )
++ exec_program( ${HDF5_${language}_COMPILER_EXECUTABLE}
++ ARGS -show
++ OUTPUT_VARIABLE ${output}
++ RETURN_VALUE ${return_value}
++ )
++ if( ${${return_value}} EQUAL 0 )
++ # do nothing
++ else()
++ message( STATUS
++ "Unable to determine HDF5 ${language} flags from HDF5 wrapper." )
++ endif()
++ endif()
++endmacro()
++
++# Parse a compile line for definitions, includes, library paths, and libraries.
++macro( _HDF5_parse_compile_line
++ compile_line_var
++ include_paths
++ definitions
++ library_paths
++ libraries )
++
++ # Match the include paths
++ string( REGEX MATCHALL "-I([^\" ]+)" include_path_flags
++ "${${compile_line_var}}"
++ )
++ foreach( IPATH ${include_path_flags} )
++ string( REGEX REPLACE "^-I" "" IPATH ${IPATH} )
++ string( REPLACE "//" "/" IPATH ${IPATH} )
++ list( APPEND ${include_paths} ${IPATH} )
++ endforeach()
++
++ # Match the definitions
++ string( REGEX MATCHALL "-D[^ ]*" definition_flags "${${compile_line_var}}" )
++ foreach( DEF ${definition_flags} )
++ list( APPEND ${definitions} ${DEF} )
++ endforeach()
++
++ # Match the library paths
++ string( REGEX MATCHALL "-L([^\" ]+|\"[^\"]+\")" library_path_flags
++ "${${compile_line_var}}"
++ )
++
++ foreach( LPATH ${library_path_flags} )
++ string( REGEX REPLACE "^-L" "" LPATH ${LPATH} )
++ string( REPLACE "//" "/" LPATH ${LPATH} )
++ list( APPEND ${library_paths} ${LPATH} )
++ endforeach()
++
++ # now search for the library names specified in the compile line (match -l...)
++ # match only -l's preceded by a space or comma
++ # this is to exclude directory names like xxx-linux/
++ string( REGEX MATCHALL "[, ]-l([^\", ]+)" library_name_flags
++ "${${compile_line_var}}" )
++ # strip the -l from all of the library flags and add to the search list
++ foreach( LIB ${library_name_flags} )
++ string( REGEX REPLACE "^[, ]-l" "" LIB ${LIB} )
++ list( APPEND ${libraries} ${LIB} )
++ endforeach()
++endmacro()
++
++# Try to find HDF5 using an installed hdf5-config.cmake
++if( NOT HDF5_FOUND )
++ find_package( HDF5 QUIET NO_MODULE )
++ if( HDF5_FOUND )
++ set( HDF5_INCLUDE_DIRS ${HDF5_INCLUDE_DIR} )
++ set( HDF5_LIBRARIES )
++ set( HDF5_C_TARGET hdf5 )
++ set( HDF5_CXX_TARGET hdf5_cpp )
++ set( HDF5_HL_TARGET hdf5_hl )
++ set( HDF5_Fortran_TARGET hdf5_fortran )
++ set( HDF5_Fortran_HL_TARGET hdf5_hl_fortran )
++ foreach( _component ${HDF5_LANGUAGE_BINDINGS} )
++ list( FIND HDF5_VALID_COMPONENTS ${_component} _component_location )
++ get_target_property( _comp_location ${HDF5_${_component}_TARGET} LOCATION )
++ if( _comp_location )
++ set( HDF5_${_component}_LIBRARY ${_comp_location} CACHE PATH
++ "HDF5 ${_component} library" )
++ mark_as_advanced( HDF5_${_component}_LIBRARY )
++ list( APPEND HDF5_LIBRARIES ${HDF5_${_component}_LIBRARY} )
++ endif()
++ endforeach()
++ endif()
++endif()
++
++if( NOT HDF5_FOUND )
++ _HDF5_invoke_compiler( C HDF5_C_COMPILE_LINE HDF5_C_RETURN_VALUE )
++ _HDF5_invoke_compiler( CXX HDF5_CXX_COMPILE_LINE HDF5_CXX_RETURN_VALUE )
++ _HDF5_invoke_compiler( Fortran HDF5_Fortran_COMPILE_LINE HDF5_Fortran_RETURN_VALUE )
++
++ # seed the initial lists of libraries to find with items we know we need
++ set( HDF5_C_LIBRARY_NAMES_INIT hdf5 )
++ set( HDF5_HL_LIBRARY_NAMES_INIT hdf5_hl ${HDF5_C_LIBRARY_NAMES_INIT} )
++ set( HDF5_CXX_LIBRARY_NAMES_INIT hdf5_cpp ${HDF5_C_LIBRARY_NAMES_INIT} )
++ set( HDF5_Fortran_LIBRARY_NAMES_INIT hdf5_fortran
++ ${HDF5_C_LIBRARY_NAMES_INIT} )
++ set( HDF5_Fortran_HL_LIBRARY_NAMES_INIT hdf5hl_fortran
++ ${HDF5_Fortran_LIBRARY_NAMES_INIT} )
++
++ foreach( LANGUAGE ${HDF5_LANGUAGE_BINDINGS} )
++ if( HDF5_${LANGUAGE}_COMPILE_LINE )
++ _HDF5_parse_compile_line( HDF5_${LANGUAGE}_COMPILE_LINE
++ HDF5_${LANGUAGE}_INCLUDE_FLAGS
++ HDF5_${LANGUAGE}_DEFINITIONS
++ HDF5_${LANGUAGE}_LIBRARY_DIRS
++ HDF5_${LANGUAGE}_LIBRARY_NAMES
++ )
++
++ # take a guess that the includes may be in the 'include' sibling
++ # directory of a library directory.
++ foreach( dir ${HDF5_${LANGUAGE}_LIBRARY_DIRS} )
++ list( APPEND HDF5_${LANGUAGE}_INCLUDE_FLAGS ${dir}/../include )
++ endforeach()
++ endif()
++
++ # set the definitions for the language bindings.
++ list( APPEND HDF5_DEFINITIONS ${HDF5_${LANGUAGE}_DEFINITIONS} )
++
++ # find the HDF5 include directories
++ if(${LANGUAGE} MATCHES "Fortran")
++ set(HDF5_INCLUDE_FILENAME hdf5.mod)
++ else()
++ set(HDF5_INCLUDE_FILENAME hdf5.h)
++ endif()
++
++ find_path( HDF5_${LANGUAGE}_INCLUDE_DIR ${HDF5_INCLUDE_FILENAME}
++ HINTS
++ ${HDF5_${LANGUAGE}_INCLUDE_FLAGS}
++ ENV
++ HDF5_ROOT
++ PATHS
++ $ENV{HOME}/.local/include
++ PATH_SUFFIXES
++ include
++ Include
++ )
++ mark_as_advanced( HDF5_${LANGUAGE}_INCLUDE_DIR )
++ list( APPEND HDF5_INCLUDE_DIRS ${HDF5_${LANGUAGE}_INCLUDE_DIR} )
++
++ set( HDF5_${LANGUAGE}_LIBRARY_NAMES
++ ${HDF5_${LANGUAGE}_LIBRARY_NAMES_INIT}
++ ${HDF5_${LANGUAGE}_LIBRARY_NAMES} )
++
++ # find the HDF5 libraries
++ foreach( LIB ${HDF5_${LANGUAGE}_LIBRARY_NAMES} )
++ if( UNIX AND HDF5_USE_STATIC_LIBRARIES )
++ # According to bug 1643 on the CMake bug tracker, this is the
++ # preferred method for searching for a static library.
++ # See http://www.cmake.org/Bug/view.php?id=1643. We search
++ # first for the full static library name, but fall back to a
++ # generic search on the name if the static search fails.
++ set( THIS_LIBRARY_SEARCH_DEBUG lib${LIB}d.a ${LIB}d )
++ set( THIS_LIBRARY_SEARCH_RELEASE lib${LIB}.a ${LIB} )
++ else()
++ set( THIS_LIBRARY_SEARCH_DEBUG ${LIB}d )
++ set( THIS_LIBRARY_SEARCH_RELEASE ${LIB} )
++ endif()
++ find_library( HDF5_${LIB}_LIBRARY_DEBUG
++ NAMES ${THIS_LIBRARY_SEARCH_DEBUG}
++ HINTS ${HDF5_${LANGUAGE}_LIBRARY_DIRS}
++ ENV HDF5_ROOT
++ PATH_SUFFIXES lib Lib )
++ find_library( HDF5_${LIB}_LIBRARY_RELEASE
++ NAMES ${THIS_LIBRARY_SEARCH_RELEASE}
++ HINTS ${HDF5_${LANGUAGE}_LIBRARY_DIRS}
++ ENV HDF5_ROOT
++ PATH_SUFFIXES lib Lib )
++ select_library_configurations( HDF5_${LIB} )
++ list(APPEND HDF5_${LANGUAGE}_LIBRARIES ${HDF5_${LIB}_LIBRARY})
++ endforeach()
++ list( APPEND HDF5_LIBRARY_DIRS ${HDF5_${LANGUAGE}_LIBRARY_DIRS} )
++
++ # Append the libraries for this language binding to the list of all
++ # required libraries.
++ list(APPEND HDF5_LIBRARIES ${HDF5_${LANGUAGE}_LIBRARIES})
++ endforeach()
++
++ # We may have picked up some duplicates in various lists during the above
++ # process for the language bindings (both the C and C++ bindings depend on
++ # libz for example). Remove the duplicates. It appears that the default
++ # CMake behavior is to remove duplicates from the end of a list. However,
++ # for link lines, this is incorrect since unresolved symbols are searched
++ # for down the link line. Therefore, we reverse the list, remove the
++ # duplicates, and then reverse it again to get the duplicates removed from
++ # the beginning.
++ macro( _remove_duplicates_from_beginning _list_name )
++ list( REVERSE ${_list_name} )
++ list( REMOVE_DUPLICATES ${_list_name} )
++ list( REVERSE ${_list_name} )
++ endmacro()
++
++ if( HDF5_INCLUDE_DIRS )
++ _remove_duplicates_from_beginning( HDF5_INCLUDE_DIRS )
++ endif()
++ if( HDF5_LIBRARY_DIRS )
++ _remove_duplicates_from_beginning( HDF5_LIBRARY_DIRS )
++ endif()
++
++ # If the HDF5 include directory was found, open H5pubconf.h to determine if
++ # HDF5 was compiled with parallel IO support
++ set( HDF5_IS_PARALLEL FALSE )
++ set( HDF5_VERSION "" )
++ foreach( _dir IN LISTS HDF5_INCLUDE_DIRS )
++ foreach(_hdr "${_dir}/H5pubconf.h" "${_dir}/H5pubconf-64.h" "${_dir}/H5pubconf-32.h")
++ if( EXISTS "${_hdr}" )
++ file( STRINGS "${_hdr}"
++ HDF5_HAVE_PARALLEL_DEFINE
++ REGEX "HAVE_PARALLEL 1" )
++ if( HDF5_HAVE_PARALLEL_DEFINE )
++ set( HDF5_IS_PARALLEL TRUE )
++ endif()
++ unset(HDF5_HAVE_PARALLEL_DEFINE)
++
++ file( STRINGS "${_hdr}"
++ HDF5_VERSION_DEFINE
++ REGEX "^[ \t]*#[ \t]*define[ \t]+H5_VERSION[ \t]+" )
++ if( "${HDF5_VERSION_DEFINE}" MATCHES
++ "H5_VERSION[ \t]+\"([0-9]+\\.[0-9]+\\.[0-9]+).*\"" )
++ set( HDF5_VERSION "${CMAKE_MATCH_1}" )
++ endif()
++ unset(HDF5_VERSION_DEFINE)
++ endif()
++ endforeach()
++ endforeach()
++ set( HDF5_IS_PARALLEL ${HDF5_IS_PARALLEL} CACHE BOOL
++ "HDF5 library compiled with parallel IO support" )
++ mark_as_advanced( HDF5_IS_PARALLEL )
++
++ # For backwards compatibility we set HDF5_INCLUDE_DIR to the value of
++ # HDF5_INCLUDE_DIRS
++ if( HDF5_INCLUDE_DIRS )
++ set( HDF5_INCLUDE_DIR "${HDF5_INCLUDE_DIRS}" )
++ endif()
++
++endif()
++
++find_package_handle_standard_args( HDF5
++ REQUIRED_VARS HDF5_LIBRARIES HDF5_INCLUDE_DIRS
++ VERSION_VAR HDF5_VERSION
++)
++
+diff -purN a/modules/hdf/CMakeLists.txt b/modules/hdf/CMakeLists.txt
+--- a/modules/hdf/CMakeLists.txt 2015-12-17 17:11:31.000000000 +0000
++++ b/modules/hdf/CMakeLists.txt 2016-09-19 15:24:47.958650311 +0100
+@@ -1,4 +1,4 @@
+-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR})
++set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_LIST_DIR}/cmake)
+
+ find_package(HDF5)
+ if(HDF5_FOUND)
diff --git a/media-libs/opencv/opencv-3.1.0-r5.ebuild b/media-libs/opencv/opencv-3.1.0-r5.ebuild
new file mode 100644
index 000000000000..581b725ab677
--- /dev/null
+++ b/media-libs/opencv/opencv-3.1.0-r5.ebuild
@@ -0,0 +1,300 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit toolchain-funcs cmake-utils python-r1 java-pkg-opt-2 java-ant-2
+
+DESCRIPTION="A collection of algorithms and sample code for
+ various computer vision problems"
+HOMEPAGE="http://opencv.org"
+
+SRC_URI="
+ mirror://sourceforge/opencvlibrary/opencv-unix/${PV}/${P}.zip
+ https://github.com/Itseez/${PN}/archive/${PV}.zip -> ${P}.zip
+ contrib? (
+ https://github.com/Itseez/${PN}_contrib/archive/cd5993c6576267875adac300b9ddd1f881bb1766.zip -> ${P}_contrib.zip )" #commit from Sun, 27 Mar 2016 17:31:51
+
+LICENSE="BSD"
+SLOT="0/3.1" # subslot = libopencv* soname version
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE="contrib cuda +eigen examples ffmpeg gdal gphoto2 gstreamer gtk \
+ ieee1394 ipp jpeg jpeg2k libav opencl openexr opengl openmp pch png \
+ +python qt4 qt5 testprograms threads tiff vaapi v4l vtk webp xine"
+
+# OpenGL needs gtk or Qt installed to activate, otherwise build system
+# will silently disable it without the user knowing, which defeats the
+# purpose of the opengl use flag.
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ ?? ( qt4 qt5 )
+ opengl? ( || ( gtk qt4 qt5 ) )"
+
+# The following logic is intrinsic in the build system, but we do not enforce
+# it on the useflags since this just blocks emerging pointlessly:
+# gtk? ( !qt4 )
+# openmp? ( !threads )
+
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ cuda? ( dev-util/nvidia-cuda-toolkit:0= )
+ ffmpeg? (
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ gdal? ( sci-libs/gdal )
+ gphoto2? ( media-libs/libgphoto2 )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ opengl? ( x11-libs/gtkglext )
+ )
+ java? ( >=virtual/jre-1.6:* )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/jasper )
+ ieee1394? (
+ media-libs/libdc1394
+ sys-libs/libraw1394
+ )
+ ipp? ( sci-libs/ipp )
+ opencl? ( virtual/opencl )
+ openexr? ( media-libs/openexr )
+ opengl? ( virtual/opengl virtual/glu )
+ png? ( media-libs/libpng:0= )
+ python? ( ${PYTHON_DEPS} dev-python/numpy[${PYTHON_USEDEP}] )
+ qt4? (
+ dev-qt/qtgui:4
+ dev-qt/qttest:4
+ opengl? ( dev-qt/qtopengl:4 )
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qttest:5
+ dev-qt/qtconcurrent:5
+ opengl? ( dev-qt/qtopengl:5 )
+ )
+ threads? ( dev-cpp/tbb )
+ tiff? ( media-libs/tiff:0 )
+ v4l? ( >=media-libs/libv4l-0.8.3 )
+ vtk? ( sci-libs/vtk[rendering] )
+ webp? ( media-libs/libwebp )
+ xine? ( media-libs/xine-lib )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ eigen? ( dev-cpp/eigen:3 )
+ java? ( >=virtual/jdk-1.6 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-gles.patch
+ "${FILESDIR}"/${PN}-3.1.0-cmake-no-opengl.patch
+ "${FILESDIR}"/${P}-git-autodetect.patch
+ "${FILESDIR}"/${P}-java-magic.patch
+ "${FILESDIR}"/${P}-gentooify-python.patch
+)
+
+GLOBALCMAKEARGS=()
+
+pkg_pretend() {
+ if use openmp; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # remove bundled stuff
+ rm -rf 3rdparty || die "Removing 3rd party components failed"
+ sed -i \
+ -e '/add_subdirectory(.*3rdparty.*)/ d' \
+ CMakeLists.txt cmake/*cmake || die
+
+ java-pkg-opt-2_src_prepare
+
+ # Out-of-$S patching
+ if use contrib; then
+ cd "${WORKDIR}"/opencv_contrib-${PV} || die "cd failed"
+ epatch "${FILESDIR}"/${PN}-contrib-find-hdf5-fix.patch
+ fi
+}
+
+src_configure() {
+ JAVA_ANT_ENCODING="iso-8859-1"
+ # set encoding so even this cmake build will pick it up.
+ export ANT_OPTS+=" -Dfile.encoding=iso-8859-1"
+ java-ant-2_src_configure
+
+ # please dont sort here, order is the same as in CMakeLists.txt
+ GLOBALCMAKEARGS=(
+ # Optional 3rd party components
+ # ===================================================
+ -DWITH_1394=$(usex ieee1394)
+ -DWITH_AVFOUNDATION=OFF # IOS
+ -DWITH_VTK=$(usex vtk)
+ -DWITH_EIGEN=$(usex eigen)
+ -DWITH_VFW=OFF # Video windows support
+ -DWITH_FFMPEG=$(usex ffmpeg)
+ -DWITH_GSTREAMER=$(usex gstreamer)
+ -DWITH_GSTREAMER_0_10=OFF # Don't want this
+ -DWITH_GTK=$(usex gtk)
+ -DWITH_GTK_2_X=OFF
+ -DWITH_IPP=$(usex ipp)
+ -DWITH_JASPER=$(usex jpeg2k)
+ -DWITH_JPEG=$(usex jpeg)
+ -DWITH_WEBP=$(usex webp)
+ -DWITH_OPENEXR=$(usex openexr)
+ -DWITH_OPENGL=$(usex opengl)
+ -DWITH_OPENNI=OFF # Not packaged
+ -DWITH_OPENNI2=OFF # Not packaged
+ -DWITH_PNG=$(usex png)
+ -DWITH_PVAPI=OFF # Not packaged
+ -DWITH_GIGEAPI=OFF
+ # Qt in CMakeList.txt here: See below
+ -DWITH_WIN32UI=OFF # Windows only
+ -DWITH_QUICKTIME=OFF
+ -DWITH_TBB=$(usex threads)
+ -DWITH_OPENMP=$(usex openmp)
+ -DWITH_CSTRIPES=OFF
+ -DWITH_PTHREADS_PF=ON
+ -DWITH_TIFF=$(usex tiff)
+ -DWITH_UNICAP=OFF # Not packaged
+ -DWITH_V4L=$(usex v4l)
+ -DWITH_LIBV4L=$(usex v4l)
+ -DWITH_DSHOW=ON # direct show supp
+ -DWITH_MSMF=OFF
+ -DWITH_XIMEA=OFF # Windows only
+ -DWITH_XINE=$(usex xine)
+ -DWITH_CLP=OFF
+ -DWITH_OPENCL=$(usex opencl)
+ -DWITH_OPENCL_SVM=OFF
+ -DWITH_OPENCLAMDFFT=$(usex opencl)
+ -DWITH_OPENCLAMDBLAS=$(usex opencl)
+ -DWITH_DIRECTX=OFF
+ -DWITH_INTELPERC=OFF
+ -DWITH_JAVA=$(usex java) # Ant needed, no compile flag
+ -DWITH_IPP_A=OFF
+ -DWITH_MATLAB=ON
+ -DWITH_VA=$(usex vaapi)
+ -DWITH_VA_INTEL=$(usex vaapi)
+ -DWITH_GDAL=$(usex gdal)
+ -DWITH_GPHOTO2=$(usex gphoto2)
+ # ===================================================
+ # CUDA build components: nvidia-cuda-toolkit takes care of GCC version
+ # ===================================================
+ -DWITH_CUDA=$(usex cuda)
+ -DWITH_CUBLAS=$(usex cuda)
+ -DWITH_CUFFT=$(usex cuda)
+ -DCUDA_NPP_LIBRARY_ROOT_DIR=$(usex cuda "${EPREFIX}/opt/cuda" "")
+ # ===================================================
+ # OpenCV build components
+ # ===================================================
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_ANDROID_EXAMPLES=OFF
+ -DBUILD_DOCS=OFF # Doesn't install anyways.
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DBUILD_PERF_TESTS=OFF
+ -DBUILD_TESTS=$(usex testprograms)
+ # ===================================================
+ # OpenCV installation options
+ # ===================================================
+ -DINSTALL_C_EXAMPLES=$(usex examples)
+ -DINSTALL_TESTS=$(usex testprograms)
+ # ===================================================
+ # OpenCV build options
+ # ===================================================
+ -DENABLE_PRECOMPILED_HEADERS=$(usex pch)
+ -DHAVE_opencv_java=$(usex java YES NO)
+ # ===================================================
+ # things we want to be hard off or not yet figured out
+ # ===================================================
+ -DBUILD_PACKAGE=OFF
+ -DENABLE_PROFILING=OFF
+ # ===================================================
+ # things we want to be hard enabled not worth useflag
+ # ===================================================
+ -DCMAKE_SKIP_RPATH=ON
+ -DOPENCV_DOC_INSTALL_PATH=
+ )
+
+ if use qt4; then
+ GLOBALCMAKEARGS+=( -DWITH_QT=4 )
+ elif use qt5; then
+ GLOBALCMAKEARGS+=( -DWITH_QT=5 )
+ else
+ GLOBALCMAKEARGS+=( -DWITH_QT=OFF )
+ fi
+
+ use contrib && GLOBALCMAKEARGS+=(
+ -DOPENCV_EXTRA_MODULES_PATH="${WORKDIR}/opencv_contrib-${PV}/modules"
+ )
+
+ # workaround for bug 413429
+ tc-export CC CXX
+
+ local mycmakeargs=( ${GLOBALCMAKEARGS[@]}
+ -DWITH_PYTHON=OFF
+ -DINSTALL_PYTHON_EXAMPLES=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+python_module_compile() {
+ local mycmakeargs=( ${GLOBALCMAKEARGS[@]} )
+
+ # Set all python variables to load the correct Gentoo paths
+ mycmakeargs+=(
+ -DWITH_PYTHON=ON
+ -DGENTOO_PYTHON_EXECUTABLE=${EPYTHON}
+ -DGENTOO_PYTHON_INCLUDE_PATH="$(python_get_includedir)"
+ -DGENTOO_PYTHON_LIBRARIES="$(python_get_library_path)"
+ -DGENTOO_PYTHON_PACKAGES_PATH="$(python_get_sitedir)"
+ -DGENTOO_PYTHON_MAJOR=${EPYTHON:6:1}
+ -DGENTOO_PYTHON_MINOR=${EPYTHON:8:1}
+ -DGENTOO_PYTHON_DEBUG_LIBRARIES="" # Absolutely no clue what this is
+ )
+
+ if use examples; then
+ mycmakeargs+=( -DINSTALL_PYTHON_EXAMPLES=ON )
+ else
+ mycmakeargs+=( -DINSTALL_PYTHON_EXAMPLES=OFF )
+ fi
+
+ # Compile and install all at once because configuration will be wiped
+ # for each impl of Python
+ BUILD_DIR="${WORKDIR}"/${P}_build
+ cd "${BUILD_DIR}" || die "cd failed"
+
+ # Regenerate cache file. Can't use rebuild_cache as it won't
+ # have the Gentoo specific options.
+ rm -rf CMakeCache.txt || die "rm failed"
+ cmake-utils_src_configure
+ cmake-utils_src_compile opencv_${EPYTHON:0:7}
+ cmake-utils_src_install install/fast
+
+ # Remove compiled binary so new version compiles
+ # Avoid conflicts with new module builds as build system doesn't
+ # really support it.
+ emake -C modules/${EPYTHON:0:7} clean
+ rm -rf modules/${EPYTHON:0:7} || die "rm failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Build and install the python modules for all targets
+ use python && python_foreach_impl python_module_compile
+}