summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libpagemaker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libpagemaker')
-rw-r--r--media-libs/libpagemaker/Manifest1
-rw-r--r--media-libs/libpagemaker/libpagemaker-0.0.2.ebuild47
-rw-r--r--media-libs/libpagemaker/libpagemaker-9999.ebuild38
-rw-r--r--media-libs/libpagemaker/metadata.xml11
4 files changed, 97 insertions, 0 deletions
diff --git a/media-libs/libpagemaker/Manifest b/media-libs/libpagemaker/Manifest
new file mode 100644
index 000000000000..7380d5533a96
--- /dev/null
+++ b/media-libs/libpagemaker/Manifest
@@ -0,0 +1 @@
+DIST libpagemaker-0.0.2.tar.xz 279396 SHA256 cdbdf86605773339caab6477ff694a95a90aaa4d45bb6cdb59e4a7f76c91ef17 SHA512 70dcac28c862b0d713a356cc27f1da4ab08e91886942e0c2d2265acf9ce1d596266aadd49d5e23f9da4a4d1b3e1a97272aadcc5721af4daa84e38bc499752ac7 WHIRLPOOL 5f6dcb92e8322414c57873a8bbbef4771531cd2135e269afff4478d38f9cf6522dded71ff81928cb3e3ec675aca6fc3b3cdad61c43ed0da5ee2bc1308bf38f38
diff --git a/media-libs/libpagemaker/libpagemaker-0.0.2.ebuild b/media-libs/libpagemaker/libpagemaker-0.0.2.ebuild
new file mode 100644
index 000000000000..f127028c2164
--- /dev/null
+++ b/media-libs/libpagemaker/libpagemaker-0.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc tools static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ "
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.47
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ # fix Oops (commit 585b795c1431fd42d29391d1932bb6745edc2eb1)
+ # remove in >=0.0.3
+ sed \
+ -e "s:no-undefines:no-undefined:g" \
+ -i src/lib/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --disable-werror
+ $(use_enable tools)
+ $(use_with doc docs)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-libs/libpagemaker/libpagemaker-9999.ebuild b/media-libs/libpagemaker/libpagemaker-9999.ebuild
new file mode 100644
index 000000000000..7dc3320b06f8
--- /dev/null
+++ b/media-libs/libpagemaker/libpagemaker-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils git-r3
+
+DESCRIPTION="C++ Library that parses the file format of Aldus/Adobe PageMaker documents."
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI=""
+EGIT_REPO_URI="git://gerrit.libreoffice.org/${PN}.git"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug doc tools static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ "
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.47
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --disable-werror
+ $(use_enable tools)
+ $(use_with doc docs)
+ )
+ autotools-utils_src_configure
+}
diff --git a/media-libs/libpagemaker/metadata.xml b/media-libs/libpagemaker/metadata.xml
new file mode 100644
index 000000000000..7aa0d0b7ef6a
--- /dev/null
+++ b/media-libs/libpagemaker/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <use>
+ <flag name="tools">Build build tools</flag>
+ </use>
+</pkgmetadata>