summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois-Xavier Carton <fx.carton91@gmail.com>2017-12-26 04:55:53 +0100
committerJames Le Cuirot <chewi@gentoo.org>2017-12-26 12:01:01 +0000
commit49c50fdb50e1be08b2e46516af6e175bbc56fba2 (patch)
tree1f30ecf4b463d83c31dc25df33ea89200e63a7af /media-libs/libopenglrecorder
parentapp-shells/dsh: Drop old (diff)
downloadgentoo-49c50fdb50e1be08b2e46516af6e175bbc56fba2.tar.gz
gentoo-49c50fdb50e1be08b2e46516af6e175bbc56fba2.tar.bz2
gentoo-49c50fdb50e1be08b2e46516af6e175bbc56fba2.zip
media-libs/libopenglrecorder: new package
This library is an optional dependency for >=games-action/supertuxkart-0.9.3
Diffstat (limited to 'media-libs/libopenglrecorder')
-rw-r--r--media-libs/libopenglrecorder/Manifest1
-rw-r--r--media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/libopenglrecorder/Manifest b/media-libs/libopenglrecorder/Manifest
new file mode 100644
index 000000000000..c29dbac200ff
--- /dev/null
+++ b/media-libs/libopenglrecorder/Manifest
@@ -0,0 +1 @@
+DIST libopenglrecorder-0.1.0.tar.gz 101788 BLAKE2B 9fbd9e5acb51c033f533166cf4f55863d97331ca0d506ada7f0e2ffaf790a20b74521668d80dfe4ef230a6bf44466b5f5eda9ab6d4a248db730b0596ce441f6f SHA512 2264b5999870d89ab10366bbbbccfce8ef7c2674bb054005f4e182af2cb10c7553f97402feadc528da94608a47db030a07987b11470044965d70cd69fe47bacd
diff --git a/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
new file mode 100644
index 000000000000..55cfad2dd759
--- /dev/null
+++ b/media-libs/libopenglrecorder/libopenglrecorder-0.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A library allowing optional async readback OpenGL frame buffer with optional audio recording"
+HOMEPAGE="https://github.com/Benau/libopenglrecorder"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vpx openh264 -pulseaudio"
+
+DEPEND="media-libs/libjpeg-turbo vpx? ( media-libs/libvpx ) openh264? ( media-libs/openh264 ) pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_WITH_VPX=$(usex vpx)
+ -DBUILD_WITH_H264=$(usex openh264)
+ -DBUILD_RECORDER_WITH_SOUND=$(usex pulseaudio)
+ -DCMAKE_INSTALL_PREFIX=${EPREFIX}/usr
+ -DCMAKE_BUILD_TYPE=Release
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}