summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-02-19 10:18:16 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-02-19 10:18:29 +0100
commit238079e0c051367a6eb7e9550cc3b4f575d71af6 (patch)
tree9f628fa0c8c3e3f06636d495bd25cde13fd9c702 /media-libs/liblo
parentdev-libs/dqlite: add 1.16.2 (diff)
downloadgentoo-238079e0c051367a6eb7e9550cc3b4f575d71af6.tar.gz
gentoo-238079e0c051367a6eb7e9550cc3b4f575d71af6.tar.bz2
gentoo-238079e0c051367a6eb7e9550cc3b4f575d71af6.zip
media-libs/liblo: bump to 0.32 + eapi8
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/liblo')
-rw-r--r--media-libs/liblo/Manifest1
-rw-r--r--media-libs/liblo/liblo-0.32.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/liblo/Manifest b/media-libs/liblo/Manifest
index 40ad79ea145f..98827a91d629 100644
--- a/media-libs/liblo/Manifest
+++ b/media-libs/liblo/Manifest
@@ -1 +1,2 @@
DIST liblo-0.31.tar.gz 643928 BLAKE2B 724a6369856b5f2ccd50edb8eacbf309760548b1f855d8b4f343cbfc3257ab3ceffc5f4e40d594ecb20050fcea11b7a6bc26f8e4a6ea72969628ebef05209fd5 SHA512 97f9561296c2e53f92db0cfee625687208b490f8bc229b6cffe88b43ca2a8da1ed3217aaa2151245ea483e54ad6c5e92b9cf10a20661766fa6d3bedb5a8cdd01
+DIST liblo-0.32.tar.gz 675496 BLAKE2B 14bd133ae481eaff63f340165d33771987d046bfcf6bf377cd28b6174f259c07be1975920ce53e9ddc572dd0e13c078376df7d6bf8c41b7fa18fd987eeea06b7 SHA512 d6d26849f573073a6aaf6a72e65340b6b3aff72a26019251d8507018e9efce522ebfc29cc06dc753110fe97674bf3fe7f8e679206a6de1a9657031603b1b1d90
diff --git a/media-libs/liblo/liblo-0.32.ebuild b/media-libs/liblo/liblo-0.32.ebuild
new file mode 100644
index 000000000000..9171839108b5
--- /dev/null
+++ b/media-libs/liblo/liblo-0.32.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="https://sourceforge.net/projects/liblo/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~loong ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="doc? ( app-text/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.31-werror.patch
+)
+
+src_prepare() {
+ default
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ local myeconfargs=(
+ --enable-threads
+ --disable-network-tests
+ $(use_enable test tests)
+ # See README.md note wrt ipv6. Disabled by default upstream
+ # because can break Pd and SuperCollider.
+ $(use_enable ipv6)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}