summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2023-05-24 06:42:48 -0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-28 15:20:28 +0300
commit214c035be74df50726a826a8c42af13cda4fcc4d (patch)
tree3e65ab9b9137eb7f61e625bcf6b780c4cbe00682 /media-libs/kimageannotator
parentsys-apps/hd-idle: drop 1.05-r1 (diff)
downloadgentoo-214c035be74df50726a826a8c42af13cda4fcc4d.tar.gz
gentoo-214c035be74df50726a826a8c42af13cda4fcc4d.tar.bz2
gentoo-214c035be74df50726a826a8c42af13cda4fcc4d.zip
media-libs/kimageannotator: 0.6.1 bump
Closes: https://bugs.gentoo.org/907269 Closes: https://github.com/gentoo/gentoo/pull/31193 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs/kimageannotator')
-rw-r--r--media-libs/kimageannotator/Manifest1
-rw-r--r--media-libs/kimageannotator/kimageannotator-0.6.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-libs/kimageannotator/Manifest b/media-libs/kimageannotator/Manifest
index e399b2d0ebfd..2abeecfad611 100644
--- a/media-libs/kimageannotator/Manifest
+++ b/media-libs/kimageannotator/Manifest
@@ -1 +1,2 @@
DIST kImageAnnotator-0.6.0.tar.gz 257662 BLAKE2B 3736d0e862f1d3f3f9728e4d4d611c7e406d40fe022a2441b1a80355997d86a194064ecade63b7657d3cbf1f63364b8b74654d9c92d809ac056b7dc999d97415 SHA512 5782acd552af2297813164c0612810ec0d2127c174773040d99ec9d281f3575832b06667736a5521e88fa2d57ea6410e42a5d95232cb2dbdd9608917e5d6e896
+DIST kImageAnnotator-0.6.1.tar.gz 264176 BLAKE2B dfbfb50d2187572b0e68f1a699e91391fbb1fbc36f9b44f3ad97cab9e4ab3329e20ae4abe7fc68f1cf8dfd1960f2b03b3d6a6c949b4a7102b0c22d35690b8e05 SHA512 92ec8ff06011856e98e5624f9c3d98227e10991385fa41e110187db9b5d7b8de075199844e886618668040b69f8910be51b8cf55a009fac8887954c5b7695b25
diff --git a/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild b/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild
new file mode 100644
index 000000000000..ceddbc0c348d
--- /dev/null
+++ b/media-libs/kimageannotator/kimageannotator-0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kImageAnnotator
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for annotating images"
+HOMEPAGE="https://github.com/ksnip/kImageAnnotator"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5[png]
+ >=media-libs/kcolorpicker-0.2.0
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qttest:5
+ dev-cpp/gtest
+ )
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" virtx cmake_src_test
+}