summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Flogeras <dflogeras2@gmail.com>2021-02-16 10:36:32 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 20:56:57 +0100
commitac7da21ec34a39687cd13518fa156e15de0a2411 (patch)
treee8db341b87fae41100d8e6be4c4e6a3c78c6619a /media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild
parentdev-lang/spidermonkey: bump to v78.8.0 (diff)
downloadgentoo-ac7da21ec34a39687cd13518fa156e15de0a2411.tar.gz
gentoo-ac7da21ec34a39687cd13518fa156e15de0a2411.tar.bz2
gentoo-ac7da21ec34a39687cd13518fa156e15de0a2411.zip
media-libs/kcolorpicker: 0.1.5 bump
Bug: https://bugs.gentoo.org/770949 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Flogeras <dflogeras2@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19488 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild')
-rw-r--r--media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild b/media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild
new file mode 100644
index 000000000000..497f088f00b4
--- /dev/null
+++ b/media-libs/kcolorpicker/kcolorpicker-0.1.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit cmake virtualx
+
+MY_PN=kColorPicker
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Qt based color picker with popup menu"
+HOMEPAGE="https://github.com/ksnip/kColorPicker"
+SRC_URI="https://github.com/ksnip/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5[png]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local mycmakeargs+=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}