summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/csfml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/csfml')
-rw-r--r--media-libs/csfml/Manifest1
-rw-r--r--media-libs/csfml/csfml-1.6.ebuild34
-rw-r--r--media-libs/csfml/files/csfml-1.6-destdir.patch76
-rw-r--r--media-libs/csfml/metadata.xml10
4 files changed, 121 insertions, 0 deletions
diff --git a/media-libs/csfml/Manifest b/media-libs/csfml/Manifest
new file mode 100644
index 000000000000..f30b179808da
--- /dev/null
+++ b/media-libs/csfml/Manifest
@@ -0,0 +1 @@
+DIST SFML-1.6-c-sdk-linux-32.tar.gz 1070818 SHA256 c186cc5f0c9e4eee8864143d8e5757849bc84689af43223996e1b289958c076e
diff --git a/media-libs/csfml/csfml-1.6.ebuild b/media-libs/csfml/csfml-1.6.ebuild
new file mode 100644
index 000000000000..b892f59962c2
--- /dev/null
+++ b/media-libs/csfml/csfml-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="C library for the Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://sfml.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sfml/SFML-${PV}-c-sdk-linux-32.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="~media-libs/libsfml-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/SFML-${PV}/CSFML"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-destdir.patch
+}
+
+src_compile() {
+ emake CPP=$(tc-getCXX)
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix=/usr libdir=/usr/$(get_libdir) install
+ use doc && dohtml doc/html/*
+}
diff --git a/media-libs/csfml/files/csfml-1.6-destdir.patch b/media-libs/csfml/files/csfml-1.6-destdir.patch
new file mode 100644
index 000000000000..cdf0c46215ae
--- /dev/null
+++ b/media-libs/csfml/files/csfml-1.6-destdir.patch
@@ -0,0 +1,76 @@
+--- SFML-1.6.orig/CSFML/src/SFML/Audio/Makefile
++++ SFML-1.6/CSFML/src/SFML/Audio/Makefile
+@@ -20,4 +20,4 @@
+ @rm -rf $(LIBNAME)
+
+ install:
+- @($(CP) $(LIBNAME) $(DESTLIBDIR) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB))
++ @($(CP) $(LIBNAME) $(DESTDIR)/$(libdir) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTDIR)/$(libdir)/$(LIB))
+--- SFML-1.6.orig/CSFML/src/SFML/Graphics/Makefile
++++ SFML-1.6/CSFML/src/SFML/Graphics/Makefile
+@@ -20,4 +20,4 @@
+ @rm -rf $(LIBNAME)
+
+ install:
+- @($(CP) $(LIBNAME) $(DESTLIBDIR) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB))
++ @($(CP) $(LIBNAME) $(DESTDIR)/$(libdir) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTDIR)/$(libdir)/$(LIB))
+--- SFML-1.6.orig/CSFML/src/SFML/Makefile
++++ SFML-1.6/CSFML/src/SFML/Makefile
+@@ -1,15 +1,18 @@
+ export CC = gcc
+ export CPP = g++
+-export CFLAGS = -W -Wall -pedantic -fPIC -Wno-unused -I../.. -I../../../include -DNDEBUG -DCSFML_EXPORTS -O2
+-export LDFLAGS = -shared
++export CFLAGS += -W -Wall -pedantic -fPIC -Wno-unused -I../.. -I../../../include -DNDEBUG -DCSFML_EXPORTS
++export LDFLAGS += -shared
+ export LIBPATH = ../../../lib
+ export VERSION = 1.6
+ export CP = cp
+ export LN = ln
+ export LNFLAGS = -s -f
+-export DESTDIR = /usr/local
+-export DESTLIBDIR = $(DESTDIR)/lib
+-export DESTINCDIR = $(DESTDIR)/include
++export DESTDIR =
++ifeq ($(origin prefix), undefined)
++ export prefix = /usr/local
++endif
++export libdir = $(prefix)/lib
++export includedir = $(prefix)/include
+
+ all: csfml-system csfml-window csfml-network csfml-graphics csfml-audio
+
+@@ -42,6 +45,6 @@
+ @(cd ./System && $(MAKE) $@ && cd ../Window && $(MAKE) $@ && cd ../Network && $(MAKE) $@ && cd ../Graphics && $(MAKE) $@ && cd ../Audio && $(MAKE) $@)
+
+ install:
+- @(mkdir -p $(DESTLIBDIR))
+- @(mkdir -p $(DESTINCDIR))
+- @(cd ./System && $(MAKE) $@ && cd ../Window && $(MAKE) $@ && cd ../Network && $(MAKE) $@ && cd ../Graphics && $(MAKE) $@ && cd ../Audio && $(MAKE) $@ && $(CP) -r ../../../include/SFML/ $(DESTINCDIR))
++ @(mkdir -p $(DESTDIR)/$(libdir))
++ @(mkdir -p $(DESTDIR)/$(includedir))
++ @(cd ./System && $(MAKE) $@ && cd ../Window && $(MAKE) $@ && cd ../Network && $(MAKE) $@ && cd ../Graphics && $(MAKE) $@ && cd ../Audio && $(MAKE) $@ && $(CP) -r ../../../include/SFML/ $(DESTDIR)/$(includedir))
+--- SFML-1.6.orig/CSFML/src/SFML/Network/Makefile
++++ SFML-1.6/CSFML/src/SFML/Network/Makefile
+@@ -20,4 +20,4 @@
+ @rm -rf $(LIBNAME)
+
+ install:
+- @($(CP) $(LIBNAME) $(DESTLIBDIR) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB))
++ @($(CP) $(LIBNAME) $(DESTDIR)/$(libdir) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTDIR)/$(libdir)/$(LIB))
+--- SFML-1.6.orig/CSFML/src/SFML/System/Makefile
++++ SFML-1.6/CSFML/src/SFML/System/Makefile
+@@ -20,4 +20,4 @@
+ @rm -rf $(LIBNAME)
+
+ install:
+- @($(CP) $(LIBNAME) $(DESTLIBDIR) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB))
++ @($(CP) $(LIBNAME) $(DESTDIR)/$(libdir) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTDIR)/$(libdir)/$(LIB))
+--- SFML-1.6.orig/CSFML/src/SFML/Window/Makefile
++++ SFML-1.6/CSFML/src/SFML/Window/Makefile
+@@ -20,4 +20,4 @@
+ @rm -rf $(LIBNAME)
+
+ install:
+- @($(CP) $(LIBNAME) $(DESTLIBDIR) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB))
++ @($(CP) $(LIBNAME) $(DESTDIR)/$(libdir) && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTDIR)/$(libdir)/$(LIB))
diff --git a/media-libs/csfml/metadata.xml b/media-libs/csfml/metadata.xml
new file mode 100644
index 000000000000..1e6037059c9c
--- /dev/null
+++ b/media-libs/csfml/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sfml</remote-id>
+ </upstream>
+</pkgmetadata>