summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2020-12-20 10:14:27 +0100
committerMarkus Meier <maekke@gentoo.org>2020-12-20 10:14:27 +0100
commit38451c38409c18f28b17e83043f1e396b6c4643d (patch)
treefba7afe2c188e13001127b141f9088df9f7c89bb /media-gfx
parentdev-python/coverage: Bump to 5.3.1 (diff)
downloadgentoo-38451c38409c18f28b17e83043f1e396b6c4643d.tar.gz
gentoo-38451c38409c18f28b17e83043f1e396b6c4643d.tar.bz2
gentoo-38451c38409c18f28b17e83043f1e396b6c4643d.zip
media-gfx/hugin: bump EAPI and fix repoman warnings
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Markus Meier <maekke@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/hugin-2020.0.0-r1.ebuild (renamed from media-gfx/hugin/hugin-2020.0.0.ebuild)14
-rw-r--r--media-gfx/hugin/hugin-9999.ebuild21
2 files changed, 18 insertions, 17 deletions
diff --git a/media-gfx/hugin/hugin-2020.0.0.ebuild b/media-gfx/hugin/hugin-2020.0.0-r1.ebuild
index 7c7d2c57f260..60bec67bbd97 100644
--- a/media-gfx/hugin/hugin-2020.0.0.ebuild
+++ b/media-gfx/hugin/hugin-2020.0.0-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-WX_GTK_VER="3.0"
+WX_GTK_VER="3.0-gtk3"
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit python-single-r1 wxwidgets cmake-utils eapi7-ver xdg
+inherit python-single-r1 wxwidgets cmake xdg
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -39,7 +39,7 @@ CDEPEND="
virtual/glu
virtual/jpeg:0
virtual/opengl
- x11-libs/wxGTK:3.0=[X,opengl]
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,opengl]
lapack? ( virtual/blas virtual/lapack )
python? ( ${PYTHON_DEPS} )
sift? ( media-gfx/autopano-sift-C )"
@@ -68,7 +68,7 @@ src_prepare() {
-e "/COMMAND.*GZIP/d" \
-e "s/\.gz//g" \
"${S}"/doc/CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -76,11 +76,11 @@ src_configure() {
-DBUILD_HSI=$(usex python)
-DENABLE_LAPACK=$(usex lapack)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use python && python_optimize
local lang
diff --git a/media-gfx/hugin/hugin-9999.ebuild b/media-gfx/hugin/hugin-9999.ebuild
index 3eb92a7c66c7..0c9e3ac20a0f 100644
--- a/media-gfx/hugin/hugin-9999.ebuild
+++ b/media-gfx/hugin/hugin-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-WX_GTK_VER="3.0"
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+WX_GTK_VER="3.0-gtk3"
+PYTHON_COMPAT=( python3_{6,7,8} )
-inherit mercurial python-single-r1 wxwidgets cmake-utils eapi7-ver xdg
+inherit mercurial python-single-r1 wxwidgets cmake xdg
DESCRIPTION="GUI for the creation & processing of panoramic images"
HOMEPAGE="http://hugin.sf.net"
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS=""
LANGS=" ca ca-valencia cs da de en-GB es eu fi fr hu it ja nl pl pt-BR ro ru sk sv zh-CN zh-TW"
-IUSE="debug lapack python sift $(echo ${LANGS//\ /\ l10n_})"
+IUSE="debug lapack python raw sift $(echo ${LANGS//\ /\ l10n_})"
CDEPEND="
!!dev-util/cocom
@@ -41,12 +41,13 @@ CDEPEND="
virtual/glu
virtual/jpeg:0
virtual/opengl
- x11-libs/wxGTK:3.0=[X,opengl]
+ x11-libs/wxGTK:${WX_GTK_VER}=[X,opengl]
lapack? ( virtual/blas virtual/lapack )
python? ( ${PYTHON_DEPS} )
sift? ( media-gfx/autopano-sift-C )"
RDEPEND="${CDEPEND}
- media-libs/exiftool"
+ media-libs/exiftool
+ raw? ( media-gfx/dcraw )"
DEPEND="${CDEPEND}
dev-cpp/tclap
sys-devel/gettext
@@ -65,7 +66,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -73,11 +74,11 @@ src_configure() {
-DBUILD_HSI=$(usex python)
-DENABLE_LAPACK=$(usex lapack)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use python && python_optimize
local lang