summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 03:50:19 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-20 22:00:52 +0200
commit131d5000370c3ff3956eba3e208feed734e0b42f (patch)
tree7fb4f3f4aa7acaeaaef579838e5e9390a4d07707 /media-gfx
parentdev-lang/gnu-smalltalk: epatch->PATCHES=() (diff)
downloadgentoo-131d5000370c3ff3956eba3e208feed734e0b42f.tar.gz
gentoo-131d5000370c3ff3956eba3e208feed734e0b42f.tar.bz2
gentoo-131d5000370c3ff3956eba3e208feed734e0b42f.zip
media-gfx/nvidia-texture-tools: epatch->eapply
Also reworked the patchset tarball to all be -p1 applicable, and made the formatting uniform between the two revisions. Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/nvidia-texture-tools/Manifest2
-rw-r--r--media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r3.ebuild11
-rw-r--r--media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r4.ebuild5
3 files changed, 10 insertions, 8 deletions
diff --git a/media-gfx/nvidia-texture-tools/Manifest b/media-gfx/nvidia-texture-tools/Manifest
index 5620dbab0b12..e8778f08d307 100644
--- a/media-gfx/nvidia-texture-tools/Manifest
+++ b/media-gfx/nvidia-texture-tools/Manifest
@@ -1,2 +1,2 @@
DIST nvidia-texture-tools-2.0.8-1.tar.gz 935227 BLAKE2B aef1801795f6102ac7c96df236de0e8534bfacfc72d297ff3bcd13b530829e8848f33065477a1fb2ffaa35d75bd9e34913d3551469aa814cab8cb76f2f04e721 SHA512 8e7ac79daaa10a2b1b64cfc8d6b37b37698e2a46f925cc33cdfd8e4b36705db8836edec6f98c5d6da475d7773f4a5826b5cebc120b7c5a6f9515906e2e4fae9d
-DIST nvidia-texture-tools-2.0.8-patchset-1.tar.xz 9688 BLAKE2B b64aec479779a9d3e0b01d13571c3bfadbcad75d3288c57524805a55b40d1a3a558ad166921fe45beb7cc9b961fe50bb6e02422eccab3ad3fbe19811082a6aa8 SHA512 36305036d178c4a9960148d4ae5fd72e866ebc3f193f7c75e720275f4fa11d4a1f9067f42309de739db84678c81cd921f117cfe5b2e6a78785cf35c7e3947c8b
+DIST nvidia-texture-tools-2.0.8-patchset-1-r1.tar.xz 9604 BLAKE2B b93c9586688dd690668c9d57d533c3460b008cf357a202cc6dc315ab6d24cd3d796d8596024d193bdd9100fab52970b323f03dc16b4f72b3e551167bb46513b5 SHA512 988ea0731b7f98f804a715404fc8cb8a8956a6c6b795f0ce8570f800dac3319f222bac8f12ab6fde50bbec3d68926ed3b24516931f9aebe2a7ce0fcae0dc8e13
diff --git a/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r3.ebuild b/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r3.ebuild
index f264f6ce7ef5..d8f2a464d7e0 100644
--- a/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r3.ebuild
+++ b/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ inherit cmake-utils eutils
DESCRIPTION="A set of cuda-enabled texture tools and compressors"
HOMEPAGE="http://developer.nvidia.com/object/texture_tools.html"
SRC_URI="https://${PN}.googlecode.com/files/${P}-1.tar.gz
- https://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.xz"
+ https://dev.gentoo.org/~soap/distfiles/${P}-patchset-1-r1.tar.xz"
LICENSE="MIT"
SLOT="0"
@@ -28,9 +28,10 @@ RDEPEND="
glew? ( media-libs/glew:0= )
glut? ( media-libs/freeglut )
openexr? ( media-libs/openexr:= )
- "
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}/${P}-cg.patch" # fix bug #414509
@@ -38,6 +39,7 @@ PATCHES=(
"${FILESDIR}/${P}-openexr.patch" # fix bug #462494
"${FILESDIR}/${P}-clang.patch" # fix clang build
"${FILESDIR}/${P}-cpp14.patch" # fix bug #594938
+ "${WORKDIR}/patches"
)
S="${WORKDIR}/${PN}"
@@ -53,7 +55,6 @@ pkg_setup() {
src_prepare() {
edos2unix cmake/*
- EPATCH_SUFFIX=patch epatch "${WORKDIR}/patches"
cmake-utils_src_prepare
}
diff --git a/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r4.ebuild b/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r4.ebuild
index eaabe632f83e..a334693dbd29 100644
--- a/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r4.ebuild
+++ b/media-gfx/nvidia-texture-tools/nvidia-texture-tools-2.0.8-r4.ebuild
@@ -2,12 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit cmake-utils eutils
DESCRIPTION="A set of cuda-enabled texture tools and compressors"
HOMEPAGE="http://developer.nvidia.com/object/texture_tools.html"
SRC_URI="https://${PN}.googlecode.com/files/${P}-1.tar.gz
- https://dev.gentoo.org/~ssuominen/${P}-patchset-1.tar.xz"
+ https://dev.gentoo.org/~soap/distfiles/${P}-patchset-1-r1.tar.xz"
LICENSE="MIT"
SLOT="0"
@@ -38,13 +39,13 @@ PATCHES=(
"${FILESDIR}/${P}-clang.patch" # fix clang build
"${FILESDIR}/${P}-cpp14.patch" # fix bug #594938
"${FILESDIR}/${P}-drop-qt4.patch" # fix bug #560248
+ "${WORKDIR}/patches"
)
S="${WORKDIR}/${PN}"
src_prepare() {
edos2unix cmake/*
- EPATCH_SUFFIX=patch epatch "${WORKDIR}/patches"
cmake-utils_src_prepare
}