summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2023-02-20 13:37:27 -0500
committerNick Sarnie <sarnex@gentoo.org>2023-02-20 13:42:38 -0500
commit014b42a59e00c0710b479014670565799404e179 (patch)
tree73acb84615a8ef4b9abf0555947e74ef885dfe03 /media-gfx
parentpackage.mask: Last rite dev-python/pandas-datareader (diff)
downloadgentoo-014b42a59e00c0710b479014670565799404e179.tar.gz
gentoo-014b42a59e00c0710b479014670565799404e179.tar.bz2
gentoo-014b42a59e00c0710b479014670565799404e179.zip
media-gfx/displaycal-py3: new package, add 3.9.10
Closes: https://bugs.gentoo.org/724540 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/displaycal-py3/Manifest1
-rw-r--r--media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild66
-rw-r--r--media-gfx/displaycal-py3/metadata.xml17
3 files changed, 84 insertions, 0 deletions
diff --git a/media-gfx/displaycal-py3/Manifest b/media-gfx/displaycal-py3/Manifest
new file mode 100644
index 000000000000..9eff15b5ee37
--- /dev/null
+++ b/media-gfx/displaycal-py3/Manifest
@@ -0,0 +1 @@
+DIST DisplayCAL-3.9.10.tar.gz 10676033 BLAKE2B 94bfa3ac95bfc16788421fa5b9a31920c40da66d2875e4037b3b20b6792a1005ee9fea11b5325a94ffae845f56583647e42de9d4d7d96d149264a86e6d1158a6 SHA512 fc1b981925c6f4660557d8f0935a62d0112b39664b0c74cdb1a907e0e7b7e3f61ec76986fa2072f8ada1d105ebfa61bb116df75dc10f902ff545db3368634fc5
diff --git a/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild b/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild
new file mode 100644
index 000000000000..0aef7b5146ef
--- /dev/null
+++ b/media-gfx/displaycal-py3/displaycal-py3-3.9.10.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 xdg
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/eoyilmaz/displaycal-py3/releases/download/${PV}/${MY_P}.tar.gz"
+KEYWORDS="~amd64"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Modernize the DisplayCAL code including Python 3 support"
+HOMEPAGE="https://github.com/eoyilmaz/displaycal-py3"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/certifi:0[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pychromecast[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/zeroconf[${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.2.0[${PYTHON_USEDEP}]
+ media-gfx/argyllcms
+ x11-libs/libXxf86vm"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix QA warning
+ sed -e 's/license_file/license_files/g' -i setup.cfg || die
+
+ # Remove x-world MIME
+ sed -i 's|x-world/x-vrml;||g' \
+ misc/displaycal-vrml-to-x3d-converter.desktop || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # Use Gentoo package name for doc folder
+ mv "${ED}/usr/share/doc/${MY_P}" "${ED}/usr/share/doc/${P}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}
diff --git a/media-gfx/displaycal-py3/metadata.xml b/media-gfx/displaycal-py3/metadata.xml
new file mode 100644
index 000000000000..6ee5175df506
--- /dev/null
+++ b/media-gfx/displaycal-py3/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sarnex@gentoo.org</email>
+ <name>Nick Sarnie</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">eoyilmaz/displaycal-py3</remote-id>
+ </upstream>
+ <longdescription>
+ This project intended to modernize the DisplayCAL code including Python 3 support.
+ Florian Höch, the original developer, did an incredible job of creating and maintaining DisplayCAL for all these years.
+ But, it seems that, during the pandemic, very understandably, he lost his passion to the project.
+ Now, it is time for us, the DisplayCAL community, to contribute back to this great tool.
+ </longdescription>
+</pkgmetadata>