summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-04 10:17:07 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-04 10:17:16 +0100
commit953eba653a80d2f004f45964a892511207f1dbec (patch)
tree5d088901b551b26efa6f0ade5635ee374aac96d3 /media-gfx/mcomix
parentnet-libs/libtirpc: Removed old (diff)
downloadgentoo-953eba653a80d2f004f45964a892511207f1dbec.tar.gz
gentoo-953eba653a80d2f004f45964a892511207f1dbec.tar.bz2
gentoo-953eba653a80d2f004f45964a892511207f1dbec.zip
media-gfx/mcomix: update snapshot, fix live ebuild
Bug: https://bugs.gentoo.org/757093 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-gfx/mcomix')
-rw-r--r--media-gfx/mcomix/Manifest1
-rw-r--r--media-gfx/mcomix/mcomix-1.3.0_pre20201123.ebuild75
-rw-r--r--media-gfx/mcomix/mcomix-9999.ebuild5
3 files changed, 77 insertions, 4 deletions
diff --git a/media-gfx/mcomix/Manifest b/media-gfx/mcomix/Manifest
index 7070a2d548c8..a0df5274dc41 100644
--- a/media-gfx/mcomix/Manifest
+++ b/media-gfx/mcomix/Manifest
@@ -1 +1,2 @@
DIST mcomix-1.3.0_pre20200206.tar.gz 3292571 BLAKE2B ad76316020645495042d27bf831588e628da11077efe29b302a57be4e688558b4db8d3f850200bf4a54b84b428a16a52f88ea5e20be85b628ef3630a5f624643 SHA512 c98d4a7022993af3a5c0b5425df52f14b586549472bcd4576a72039c8c6d4fde31df4255df45ab7467acb0280bda02b92d4803b7f92b7c1c818b58df7b52a3ff
+DIST mcomix-1.3.0_pre20201123.tar.gz 3888279 BLAKE2B 0bce5d8b3d6e20fc3c422d137963fa8cf506ce969bb5c8062b1db4dcd85d5c1912352fa1eb8c752719b0ac95715486ae47d56e0bf24119f9f55af56f6fbf657c SHA512 24b470e1dca266851bb241f109b39c785443ece36d12a01e579c8a59cb7585ad3978b3696829318f04d4b172cfcf57cf100d76c7c25765260bf26f698d85ba2a
diff --git a/media-gfx/mcomix/mcomix-1.3.0_pre20201123.ebuild b/media-gfx/mcomix/mcomix-1.3.0_pre20201123.ebuild
new file mode 100644
index 000000000000..5f6da1834a5f
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-1.3.0_pre20201123.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit desktop python-r1 xdg
+
+# Hash used for this version
+GIT_PV="cdcb27533dc7ee2ebf7b0a8ab5ba10e61c0b8ff8"
+
+DESCRIPTION="GTK image viewer for comic book archives"
+HOMEPAGE="https://github.com/multiSnow/mcomix3"
+SRC_URI="https://github.com/multiSnow/mcomix3/archive/${GIT_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ virtual/jpeg
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ !media-gfx/comix"
+BDEPEND="sys-devel/gettext"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}/mcomix3-${GIT_PV}
+
+src_prepare() {
+ default
+
+ for file in mcomix/mcomix/messages/*/LC_MESSAGES/*po
+ do
+ msgfmt ${file} -o ${file/po/mo} || die
+ rm ${file} || die
+ done
+}
+
+src_install() {
+ python_foreach_impl python_domodule mcomix/mcomix
+ python_foreach_impl python_newscript mcomix/mcomixstarter.py mcomix
+
+ for size in 16 22 24 32 48
+ do
+ doicon -s ${size} \
+ mime/icons/${size}x${size}/*png \
+ mcomix/mcomix/images/${size}x${size}/mcomix.png
+ done
+ doicon mcomix/mcomix/images/mcomix.png
+ domenu mime/mcomix.desktop
+ doman man/mcomix.1
+
+ insinto /usr/share/metainfo
+ doins mime/mcomix.appdata.xml
+
+ dodoc README.rst TODO
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ echo
+ elog "Additional packages are required to open the most common comic archives:"
+ elog
+ elog " cbr: app-arch/unrar"
+ elog " cbz: app-arch/unzip"
+ elog
+ elog "You can also add support for 7z or LHA archives by installing"
+ elog "app-arch/p7zip or app-arch/lha. Install app-text/mupdf for"
+ elog "pdf support."
+ echo
+}
diff --git a/media-gfx/mcomix/mcomix-9999.ebuild b/media-gfx/mcomix/mcomix-9999.ebuild
index 15afb7c558eb..da1210c5e2bf 100644
--- a/media-gfx/mcomix/mcomix-9999.ebuild
+++ b/media-gfx/mcomix/mcomix-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit desktop git-r3 python-r1 xdg
DESCRIPTION="GTK image viewer for comic book archives"
@@ -52,9 +52,6 @@ src_install() {
insinto /usr/share/metainfo
doins mime/mcomix.appdata.xml
- insinto /usr/share/mime/packages
- doins mime/mcomix.xml
-
dodoc README.rst TODO
}