summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-04-11 17:40:55 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-04-11 17:42:43 +0200
commitcad96b791e068a9eac24cc9664334abba7f5415c (patch)
tree7ab3f30c350e6199b2f4f243906ce9075c4fef2f /media-gfx/maim
parentwww-apps/mythweb: EAPI8 bump, add missing || die (diff)
downloadgentoo-cad96b791e068a9eac24cc9664334abba7f5415c.tar.gz
gentoo-cad96b791e068a9eac24cc9664334abba7f5415c.tar.bz2
gentoo-cad96b791e068a9eac24cc9664334abba7f5415c.zip
media-gfx/maim: add 5.8.0
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'media-gfx/maim')
-rw-r--r--media-gfx/maim/Manifest1
-rw-r--r--media-gfx/maim/maim-5.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/maim/Manifest b/media-gfx/maim/Manifest
index 98028943f4e4..7ac309105d41 100644
--- a/media-gfx/maim/Manifest
+++ b/media-gfx/maim/Manifest
@@ -1 +1,2 @@
DIST maim-5.7.4.tar.gz 41663 BLAKE2B beb6cb327ae0cf022a90c095bf56b307870d3d7bd281f0e060d9cf7d49ba604cf4cbdfd9270b0e185295f0e3d2a151fbb8ba69398034145a08fc2721cc93740e SHA512 f91ba00e436514d2d0eecc664c02dd45c53750045b5bc4abbc2cfbf64159085e83736e820c54fa819b4d82b0905a3cfe76a5227db49dd54238f655fd4899cd6c
+DIST maim-5.8.0.tar.gz 42224 BLAKE2B 572743db1d59d802ed7eb7e259a5cb4a4d2147d95169bbb40adf6d36b849562e8f1756b082bc076bc46d2449827ac3b02f0b539ce86760c755920b4e35b6762d SHA512 418725b1950f9374c2ff7508e1c52f6986b253ea1c155ef28604e514f1cf0753185eea43cde76a65b9de80bb8dd65ced48b49ce5dfccaf20f5caa49f41743f5b
diff --git a/media-gfx/maim/maim-5.8.0.ebuild b/media-gfx/maim/maim-5.8.0.ebuild
new file mode 100644
index 000000000000..081088fee93f
--- /dev/null
+++ b/media-gfx/maim/maim-5.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Commandline tool to take screenshots of the desktop"
+HOMEPAGE="https://github.com/naelstrof/maim"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/maim.git"
+else
+ SRC_URI="https://github.com/naelstrof/maim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+ MIT"
+SLOT="0"
+IUSE="icu"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/libwebp:=
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-misc/slop-7.5:=
+ icu? ( dev-libs/icu:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAIM_UNICODE=$(usex icu)
+ )
+ cmake_src_configure
+}