summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 19:51:48 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 19:52:21 +0100
commit2701cb64ee7cd76093474d7b9868341afc7ee0f6 (patch)
treeaaf9ec9c9142278240fd712da01701d7f9e1d56c /media-gfx/exact-image
parentsys-apps/paludis: Kill accidental stable kws (diff)
downloadgentoo-2701cb64ee7cd76093474d7b9868341afc7ee0f6.tar.gz
gentoo-2701cb64ee7cd76093474d7b9868341afc7ee0f6.tar.bz2
gentoo-2701cb64ee7cd76093474d7b9868341afc7ee0f6.zip
media-gfx/exact-image: python-single-r1, EAPI=6
Diffstat (limited to 'media-gfx/exact-image')
-rw-r--r--media-gfx/exact-image/exact-image-0.8.1-r2.ebuild (renamed from media-gfx/exact-image/exact-image-0.8.1-r1.ebuild)21
-rw-r--r--media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch4
-rw-r--r--media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch4
3 files changed, 14 insertions, 15 deletions
diff --git a/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild b/media-gfx/exact-image/exact-image-0.8.1-r2.ebuild
index c12812e5a8c0..3b83d0e6502d 100644
--- a/media-gfx/exact-image/exact-image-0.8.1-r1.ebuild
+++ b/media-gfx/exact-image/exact-image-0.8.1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-PYTHON_DEPEND="python? 2:2.5"
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit eutils multilib python toolchain-funcs
+inherit eutils multilib python-single-r1 toolchain-funcs
DESCRIPTION="A fast, modern and generic image processing library"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
@@ -26,6 +26,7 @@ RDEPEND="x11-libs/agg[truetype]
php? ( dev-lang/php )
perl? ( dev-lang/perl )
png? ( >=media-libs/libpng-1.2.43 )
+ python? ( ${PYTHON_DEPS} )
ruby? ( dev-lang/ruby )
tiff? ( media-libs/tiff )
truetype? ( >=media-libs/freetype-2 )
@@ -40,21 +41,19 @@ DEPEND="${RDEPEND}
swig? ( dev-lang/swig )"
pkg_setup() {
- if use python; then
- python_set_active_version 2
- fi
- python_pkg_setup
+ use python && python-single-r1_pkg_setup
}
src_prepare() {
- epatch \
+ eapply \
"${FILESDIR}"/${PN}-0.7.5-libpng14.patch \
"${FILESDIR}"/${P}-libpng15.patch
+ eapply_user
# fix python hardcoded path wrt bug #327171
- sed -i -e "s:python2.5:python$(python_get_version):" \
+ sed -i -e "s:python2.5:${EPYTHON}:" \
-e "s:\$(libdir):usr/$(get_libdir):" \
- "${S}"/api/python/Makefile
+ "${S}"/api/python/Makefile || die
# Respect user CFLAGS/CXXFLAGS.
sed -i \
diff --git a/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch b/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch
index f25b9af02da9..7c62a6cbd726 100644
--- a/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch
+++ b/media-gfx/exact-image/files/exact-image-0.7.5-libpng14.patch
@@ -1,5 +1,5 @@
---- codecs/png.cc
-+++ codecs/png.cc
+--- a/codecs/png.cc
++++ b/codecs/png.cc
@@ -71,7 +71,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);
diff --git a/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch b/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch
index 44c94726e35c..94c8906a874a 100644
--- a/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch
+++ b/media-gfx/exact-image/files/exact-image-0.8.1-libpng15.patch
@@ -1,5 +1,5 @@
---- codecs/png.cc
-+++ codecs/png.cc
+--- a/codecs/png.cc
++++ b/codecs/png.cc
@@ -16,6 +16,7 @@
*/