summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/eom
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/eom')
-rw-r--r--media-gfx/eom/Manifest2
-rw-r--r--media-gfx/eom/eom-1.8.0.ebuild77
-rw-r--r--media-gfx/eom/eom-1.8.1.ebuild77
-rw-r--r--media-gfx/eom/metadata.xml8
4 files changed, 164 insertions, 0 deletions
diff --git a/media-gfx/eom/Manifest b/media-gfx/eom/Manifest
new file mode 100644
index 000000000000..143b9e0204b3
--- /dev/null
+++ b/media-gfx/eom/Manifest
@@ -0,0 +1,2 @@
+DIST eom-1.8.0.tar.xz 2190980 SHA256 ec8450bf2ebef13c2e376b1674f0f7402f87669a71eb9e2e4d1161a2784aaf9e SHA512 cc9d82ec164043653eae2f73a0b7896c0d09b2eb466a5c919b0e1df732dd18fff58fa978d01a9bbb2bb7b8427c11328affb3f4e6aeb18a77a18585f39a1f3f5a WHIRLPOOL 26c091d74a8a052a4ce1e0295e41d75bb14ed1d93024367f63214139624d61b74fdd74fc66ee02a472f7d7494cbcfa9aac4e1762f1057432f7afd5db1cf0e515
+DIST eom-1.8.1.tar.xz 2192220 SHA256 d8c97de2aab548dce910cdfd98a11b671c943e9b195d38b043e482e2323ac6d8 SHA512 e054286eebdc88390dd8855d6b43704d4bc5d0b7d69f0dc73108d26e75882ee13bfaec01a30dbc42cee14e10ca42eeb9a6f576fe8435055ba289fe2292f97837 WHIRLPOOL 10856132756b1ea7ab9be23547d94968fcce3183528cb0d656c9cd307108fe8623a70a7ee53c85db6ef74a333691ffcf1210f8c9885db4a31b63713d8924c0d9
diff --git a/media-gfx/eom/eom-1.8.0.ebuild b/media-gfx/eom/eom-1.8.0.ebuild
new file mode 100644
index 000000000000..b0258316ec83
--- /dev/null
+++ b/media-gfx/eom/eom-1.8.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE image viewer"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+IUSE="X dbus exif jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25.9:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.8:0
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[jpeg?,tiff?]
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ >=x11-themes/mate-icon-theme-1.8:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}] )
+ svg? ( >=gnome-base/librsvg-2.26:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with dbus) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ $(use_with X x) \
+ --without-cms
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
diff --git a/media-gfx/eom/eom-1.8.1.ebuild b/media-gfx/eom/eom-1.8.1.ebuild
new file mode 100644
index 000000000000..9ca917f5542f
--- /dev/null
+++ b/media-gfx/eom/eom-1.8.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="The MATE image viewer"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="X dbus exif jpeg lcms python svg tiff xmp"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/atk:0
+ >=dev-libs/glib-2.25.9:2
+ >=dev-libs/libxml2-2:2
+ gnome-base/dconf:0
+ >=mate-base/mate-desktop-1.8:0
+ sys-libs/zlib:0
+ x11-libs/cairo:0
+ >=x11-libs/gdk-pixbuf-2.4:2[jpeg?,tiff?]
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11:0
+ >=x11-misc/shared-mime-info-0.20:0
+ >=x11-themes/mate-icon-theme-1.8:0
+ virtual/libintl:0
+ dbus? ( >=dev-libs/dbus-glib-0.71:0 )
+ exif? (
+ >=media-libs/libexif-0.6.14:0
+ virtual/jpeg:0 )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.15.1:2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13:2[${PYTHON_USEDEP}] )
+ svg? ( >=gnome-base/librsvg-2.26:2 )
+ xmp? ( >=media-libs/exempi-1.99.5:2 )
+ !!media-gfx/mate-image-viewer"
+
+DEPEND="${RDEPEND}
+ app-text/yelp-tools:0
+ >=dev-util/intltool-0.40:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable python) \
+ $(use_with jpeg libjpeg) \
+ $(use_with exif libexif) \
+ $(use_with dbus) \
+ $(use_with lcms cms) \
+ $(use_with xmp) \
+ $(use_with svg librsvg) \
+ $(use_with X x) \
+ --without-cms
+}
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
diff --git a/media-gfx/eom/metadata.xml b/media-gfx/eom/metadata.xml
new file mode 100644
index 000000000000..b8d1003d2c27
--- /dev/null
+++ b/media-gfx/eom/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <upstream>
+ <remote-id type="github">mate-desktop/eom</remote-id>
+ </upstream>
+</pkgmetadata>