summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/dawn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/dawn')
-rw-r--r--media-gfx/dawn/Manifest1
-rw-r--r--media-gfx/dawn/dawn-3.90b.ebuild58
-rw-r--r--media-gfx/dawn/files/dawn-3.88a-no-interactive.patch292
-rw-r--r--media-gfx/dawn/files/dawn-3.90b-no-interactive.patch158
-rw-r--r--media-gfx/dawn/metadata.xml23
5 files changed, 532 insertions, 0 deletions
diff --git a/media-gfx/dawn/Manifest b/media-gfx/dawn/Manifest
new file mode 100644
index 000000000000..b31a8da04bf0
--- /dev/null
+++ b/media-gfx/dawn/Manifest
@@ -0,0 +1 @@
+DIST dawn_3_90b.tgz 1334732 SHA256 be9461b490a4acfd87152407adbbe423f3735d9f00a88a9573ecaa9db24ac676
diff --git a/media-gfx/dawn/dawn-3.90b.ebuild b/media-gfx/dawn/dawn-3.90b.ebuild
new file mode 100644
index 000000000000..d8b6c444f18f
--- /dev/null
+++ b/media-gfx/dawn/dawn-3.90b.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs versionator
+
+MYP=${PN}_$(replace_version_separator 1 _)
+
+DESCRIPTION="3D geometrical postscript renderer"
+HOMEPAGE="http://geant4.kek.jp/~tanaka/DAWN/About_DAWN.html"
+SRC_URI="http://geant4.kek.jp/~tanaka/src/${MYP}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="doc opengl X"
+
+RDEPEND="dev-lang/tk
+ X? ( x11-libs/libX11 )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-shells/tcsh
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-interactive.patch
+ sed -i -e "s/\$(LIB_DIR)/\$(LDFLAGS) &/" \
+ -e '/strip/d' Makefile*in || die
+}
+
+src_compile() {
+ tc-export CXX
+ emake clean
+ emake guiclean
+ if use X; then
+ ./configure_xwin || die
+ else
+ ./configure || die
+ fi
+ einfo "Compiling"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake DESTDIR="${D}" install || die
+ dodoc README.txt
+ if use doc; then
+ pdflatex DOC/G4PRIM_FORMAT_24.tex || die "pdf generation failed"
+ insinto /usr/share/doc/${PF}
+ doins DOC/G4PRIM_FORMAT_24.pdf
+ dohtml DOC/*.html
+ fi
+}
diff --git a/media-gfx/dawn/files/dawn-3.88a-no-interactive.patch b/media-gfx/dawn/files/dawn-3.88a-no-interactive.patch
new file mode 100644
index 000000000000..2280f35c8496
--- /dev/null
+++ b/media-gfx/dawn/files/dawn-3.88a-no-interactive.patch
@@ -0,0 +1,292 @@
+--- configure_min.orig 2008-04-02 22:58:34.504868912 +0100
++++ configure_min 2008-04-02 23:47:56.967829265 +0100
+@@ -13,22 +13,22 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+
+ ##### DELETE #####
+@@ -57,14 +57,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -78,7 +78,7 @@
+
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "" >> Makefile
+--- configure.orig 2008-04-02 22:58:23.660250913 +0100
++++ configure 2008-04-03 00:06:20.081610809 +0100
+@@ -17,19 +17,19 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " : "
+-set cpp_compiler=$<
++set cpp_compiler=
+ echo ""
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " : "
+-set optimize=$<
++set optimize=
+ echo ""
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+ echo ""
+
+ #-----
+@@ -37,7 +37,7 @@
+ echo " (e.g. -I/usr/X11R6/include) "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set xlib_inc=$<
++set xlib_inc=
+ echo ""
+
+
+@@ -46,7 +46,7 @@
+ echo " (e.g. -L/usr/X11R6/lib) "
+ echo " Hit return key if path is already set properly.)"
+ echo -n " : "
+-set xlib_lib=$<
++set xlib_lib=
+ echo ""
+
+
+@@ -55,7 +55,7 @@
+ echo " (e.g. -I/usr/X11R6/include) "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set openglinc=$<
++set openglinc=
+ echo ""
+
+ #-----
+@@ -63,7 +63,7 @@
+ echo " (e.g. -I/usr/X11R6/include/GL "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set openglinc2=$<
++set openglinc2=
+ echo ""
+
+
+@@ -72,24 +72,24 @@
+ echo " (e.g. -L/usr/X11R6/lib "
+ echo " Hit return key if path is already set properly.)"
+ echo -n " : "
+-set opengllib=$<
++set opengllib=
+ echo ""
+
+ #-----
+ echo -n "Select OpenGL/Mesa or old Masa (0: OpenGL/Mesa , 1: Old Mesa (ver.3.0)): "
+-set opengl_type=$<
++set opengl_type=0
+ echo ""
+
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+ echo ""
+
+ #----- Input system name
+ echo -n "Select a system (0: Defalut, 1: AIX, 2: IRIX, 3: Solaris, 4: RedHat/FedoraCore): "
+-set sysid=$<
++set sysid=0
+ switch ($sysid)
+ case "0":
+ set sysname = "Default"
+@@ -116,7 +116,7 @@
+ echo "Do you use remote-visualization function? (y/n, no default)"
+ echo " (Select n if your compilation fails for FRClientServer.cc)"
+ echo -n " : "
+-set ynflag_socket=$<
++set ynflag_socket=n
+ switch ($ynflag_socket)
+ case "y":
+ set macro_socket = '#define USE_SOCKET'
+@@ -159,14 +159,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -224,7 +224,7 @@
+ echo "" >> Makefile
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Socket libraries to be linked " >> Makefile
+@@ -313,6 +313,6 @@
+ echo ""
+ echo 'After compilation, type "make install" for installation.'
+ echo 'Then four executable files "dawn", "DAWN_GUI",'
+-echo '"dawnunixd", and "dawninetd" will be installed to '
++echo '"dawnunixd", and "dawninetd" will be installed'
+ echo "$install_dir."
+ echo ""
+--- configure_xwin.orig 2008-04-02 22:58:44.973465484 +0100
++++ configure_xwin 2008-04-03 00:02:15.950190359 +0100
+@@ -16,17 +16,17 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+
+ #-----
+@@ -34,7 +34,7 @@
+ echo " (e.g. -I/usr/X11R6/include) "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set xlib_inc=$<
++set xlib_inc=
+ echo ""
+
+
+@@ -43,17 +43,17 @@
+ echo " (e.g. -L/usr/X11R6/lib) "
+ echo " Hit return key if path is already set properly.)"
+ echo -n " : "
+-set xlib_lib=$<
++set xlib_lib=
+ echo ""
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+ #----- Input system name
+ echo -n "Select a system (0: Defalut, 1: AIX, 2: IRIX, 3: Solaris, 4: RedHat/FedoraCore): "
+-set sysid=$<
++set sysid=0
+ switch ($sysid)
+ case "0":
+ set sysname = "Default"
+@@ -80,7 +80,7 @@
+ echo "Do you use remote-visualization function? (y/n, no default)"
+ echo " (Select n if your compilation fails for FRClientServer.cc)"
+ echo -n " : "
+-set ynflag_socket=$<
++set ynflag_socket=n
+ switch ($ynflag_socket)
+ case "y":
+ set macro_socket = '#define USE_SOCKET'
+@@ -123,14 +123,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -152,7 +152,7 @@
+ echo "" >> Makefile
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Socket libraries to be linked " >> Makefile
+--- FRSocketMacro.h.orig 2008-04-02 23:58:51.126518123 +0100
++++ FRSocketMacro.h 2008-04-02 23:59:03.443220012 +0100
+@@ -14,8 +14,8 @@
+ #elif defined SOCKET_REDHAT61
+ #define CLIENT_ADDR_LENGTH socklen_t
+ #else
+- #define CLIENT_ADDR_LENGTH int
+-// #define CLIENT_ADDR_LENGTH size_t
++// #define CLIENT_ADDR_LENGTH int
++ #define CLIENT_ADDR_LENGTH size_t
+ #endif
+
+ //----- gethostname
diff --git a/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch b/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch
new file mode 100644
index 000000000000..244948ec5262
--- /dev/null
+++ b/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch
@@ -0,0 +1,158 @@
+--- configure_xwin.orig 2008-04-02 22:58:44.973465484 +0100
++++ configure_xwin 2008-04-03 00:02:15.950190359 +0100
+@@ -16,17 +16,17 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+
+ #-----
+@@ -34,7 +34,7 @@
+ echo " (e.g. -I/usr/X11R6/include) "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set xlib_inc=$<
++set xlib_inc=
+ echo ""
+
+
+@@ -43,17 +43,17 @@
+ echo " (e.g. -L/usr/X11R6/lib) "
+ echo " Hit return key if path is already set properly.)"
+ echo -n " : "
+-set xlib_lib=$<
++set xlib_lib=
+ echo ""
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+ #----- Input system name
+ echo -n "Select a system (0: Defalut, 1: AIX, 2: IRIX, 3: Solaris, 4: RedHat/FedoraCore): "
+-set sysid=$<
++set sysid=0
+ switch ($sysid)
+ case "0":
+ set sysname = "Default"
+@@ -80,7 +80,7 @@
+ echo "Do you use remote-visualization function? (y/n, no default)"
+ echo " (Select n if your compilation fails for FRClientServer.cc)"
+ echo -n " : "
+-set ynflag_socket=$<
++set ynflag_socket=n
+ switch ($ynflag_socket)
+ case "y":
+ set macro_socket = '#define USE_SOCKET'
+@@ -123,14 +123,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -152,7 +152,7 @@
+ echo "" >> Makefile
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Socket libraries to be linked " >> Makefile
+--- FRSocketMacro.h.orig 2008-04-02 23:58:51.126518123 +0100
++++ FRSocketMacro.h 2008-04-02 23:59:03.443220012 +0100
+@@ -14,8 +14,8 @@
+ #elif defined SOCKET_REDHAT61
+ #define CLIENT_ADDR_LENGTH socklen_t
+ #else
+- #define CLIENT_ADDR_LENGTH int
+-// #define CLIENT_ADDR_LENGTH size_t
++// #define CLIENT_ADDR_LENGTH int
++ #define CLIENT_ADDR_LENGTH size_t
+ #endif
+
+ //----- gethostname
+--- configure.orig 2010-08-21 14:22:18.000000000 +0100
++++ configure 2010-09-23 05:57:02.000000000 +0100
+@@ -13,22 +13,22 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+
+ ##### DELETE #####
+@@ -57,14 +57,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -78,7 +78,7 @@
+
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "" >> Makefile
diff --git a/media-gfx/dawn/metadata.xml b/media-gfx/dawn/metadata.xml
new file mode 100644
index 000000000000..7e312f55fd62
--- /dev/null
+++ b/media-gfx/dawn/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ Fukui Renderer DAWN (Drawer for Academic WritiNgs)
+ is a renderer, which reads 3D geometrical data and visualize them.
+ It is a vectorized 3D PostScript processor with analytical
+ hidden line/surface removal.
+ It aims at precise technical drawing of complicated objects.
+ It performs geometrical hidden line/surface removal and calculates
+ out all visible parts of the 3D data before drawing. This drawing
+ algorithm realizes device-independent technical high quality of
+ vectorized graphics.
+ 3D Data files should be generated by a modeler or by hands
+ separately. If you use DAWN as a visualizer of,
+ say, a simulator of physical experiments,
+ the simulator application itself is recognized as a modeler.
+ An important feature of DAWN is that it has been developed to
+ visualize 3D data generated by a high-energy experimental detector
+ simulator "GEANT4".
+</longdescription>
+</pkgmetadata>