summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-03-13 22:40:13 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-16 17:54:29 +0200
commit5e30455f6174131edf2fe4549db7170aa887ab34 (patch)
tree274d4260455c176fdeb9c5b0441927b4e29d5d45 /media-gfx/alembic
parentmedia-video/amdgpu-pro-amf: add missing RDEPEND for libdrm (diff)
downloadgentoo-5e30455f6174131edf2fe4549db7170aa887ab34.tar.gz
gentoo-5e30455f6174131edf2fe4549db7170aa887ab34.tar.bz2
gentoo-5e30455f6174131edf2fe4549db7170aa887ab34.zip
media-gfx/alembic: drop 1.8.2, 1.8.3-r1
Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/24540 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.2.ebuild54
-rw-r--r--media-gfx/alembic/alembic-1.8.3-r1.ebuild69
3 files changed, 0 insertions, 124 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 43d77b5e5a24..487eddd79e33 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1,2 +1 @@
-DIST alembic-1.8.2.tar.gz 861796 BLAKE2B 9ea2dea33b3116331dd02802055e8db7faa736bc2674e6b30209a9e178877523d9f14516b35729eaf6fc348b89367e9830ca1b998a8c7d10766b9b2f265b97d8 SHA512 23fec3d51cfd8ac8bc02749550de53a7b699ebe67654336864a8208a6a1d4f69e8e1a2c8e07832665c203788cbabbb65f346582741bac10ceb0d56c16d6b4217
DIST alembic-1.8.3.tar.gz 862221 BLAKE2B 81639b0968dbcaac0096eac83385b7d6b1dc27b4b1652ede8cf6b6cf3aa3eea3c6f5e53f033708b61f79d99ebfaa766a9cac3345a043d6cc0ba6d6c29dcb9ed0 SHA512 0049c72d93e66e12d704d27e7ba36cd9c718667f2ce4f7baa1bee1613ed88ba53abea98f457e14f7f2144cb353810a4108d26c7dd1a1543ec2af576272f19036
diff --git a/media-gfx/alembic/alembic-1.8.2.ebuild b/media-gfx/alembic/alembic-1.8.2.ebuild
deleted file mode 100644
index 70bbe084164e..000000000000
--- a/media-gfx/alembic/alembic-1.8.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Open framework for storing and sharing scene data"
-HOMEPAGE="https://www.alembic.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-# either pyilmbase or imath need to be keyworded for arm{,64} to re-add
-# python / pyalembic support
-IUSE="examples hdf5 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- || (
- >=dev-libs/imath-3.0.1
- >=media-libs/ilmbase-2.5.5
- )
- hdf5? (
- >=sci-libs/hdf5-1.10.2:=[zlib(+)]
- >=sys-libs/zlib-1.2.11-r1
- )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}/${PN}-1.8.0-0001-set-correct-libdir.patch" )
-
-DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
-
-src_configure() {
- local mycmakeargs=(
- -DALEMBIC_BUILD_LIBS=ON
- -DALEMBIC_SHARED_LIBS=ON
- # currently does nothing but require doxygen
- -DDOCS_PATH=OFF
- -DUSE_ARNOLD=OFF
- -DUSE_BINARIES=ON
- -DUSE_EXAMPLES=$(usex examples)
- -DUSE_HDF5=$(usex hdf5)
- -DUSE_MAYA=OFF
- -DUSE_PRMAN=OFF
- # TODO: needs imath keyworded for arm{,64}
- -DUSE_PYALEMBIC=OFF
- -DUSE_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
diff --git a/media-gfx/alembic/alembic-1.8.3-r1.ebuild b/media-gfx/alembic/alembic-1.8.3-r1.ebuild
deleted file mode 100644
index 909f899aa86f..000000000000
--- a/media-gfx/alembic/alembic-1.8.3-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit cmake python-single-r1
-
-DESCRIPTION="Open framework for storing and sharing scene data"
-HOMEPAGE="https://www.alembic.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~x86"
-IUSE="examples hdf5 python test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=media-libs/ilmbase-2.5.5:=
- python? ( >=dev-python/pyilmbase-2.5.5[${PYTHON_SINGLE_USEDEP}] )
- hdf5? (
- >=sci-libs/hdf5-1.10.2:=[zlib(+)]
- >=sys-libs/zlib-1.2.11-r1
- )
- python? ( $(python_gen_cond_dep 'dev-libs/boost[python,${PYTHON_USEDEP}]') )
-"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.8.0-0001-set-correct-libdir.patch
- "${FILESDIR}"/${P}-0001-find-py-ilmbase-in-config-mode.patch
-)
-
-DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
-
-src_prepare() {
- cmake_src_prepare
- # PyAlembic test doesn't properly find Imath, comment it for now
- cmake_run_in python/PyAlembic cmake_comment_add_subdirectory Tests
-}
-
-src_configure() {
- local mycmakeargs=(
- # Force falling back to ilmbase for now
- # bug #818232
- -DCMAKE_DISABLE_FIND_PACKAGE_Imath=ON
-
- -DALEMBIC_BUILD_LIBS=ON
- -DALEMBIC_SHARED_LIBS=ON
- # currently does nothing but require doxygen
- -DDOCS_PATH=OFF
- -DUSE_ARNOLD=OFF
- -DUSE_BINARIES=ON
- -DUSE_EXAMPLES=$(usex examples)
- -DUSE_HDF5=$(usex hdf5)
- -DUSE_MAYA=OFF
- -DUSE_PRMAN=OFF
- -DUSE_PYALEMBIC=$(usex python)
- -DUSE_TESTS=$(usex test)
- )
-
- use python && mycmakeargs+=( -DPython3_EXECUTABLE=${PYTHON} )
-
- cmake_src_configure
-}