summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-04-23 18:07:03 +0200
committerSam James <sam@gentoo.org>2021-05-04 22:01:34 +0000
commit47b69a1658ffcb36fcc019efd112d0fa3a948b3a (patch)
tree10d170898b595308d240516e1ae6f22aa7cd0c52 /media-gfx/alembic
parentmedia-gfx/freecad: bump to 0.19.2 (diff)
downloadgentoo-47b69a1658ffcb36fcc019efd112d0fa3a948b3a.tar.gz
gentoo-47b69a1658ffcb36fcc019efd112d0fa3a948b3a.tar.bz2
gentoo-47b69a1658ffcb36fcc019efd112d0fa3a948b3a.zip
media-gfx/alembic: bump to 1.8.0
Closes: https://bugs.gentoo.org/783843 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/20515 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/alembic')
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.0.ebuild52
-rw-r--r--media-gfx/alembic/files/alembic-1.8.0-0001-set-correct-libdir.patch57
3 files changed, 110 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 6b21cc8ad5b0..99b7d902ae57 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.7.16.tar.gz 855709 BLAKE2B 8009ed199b7dca190e40f56969d7c446e65bd78f58cee75dda4883ecf02b6c7ee422db76c4f523a76a4b2d42ef1547ededf5de0055cdb5d801c5cd4918a0b5f4 SHA512 bd4777dc4abf15bfb8307b00fd2d67671e89944d0dd8a74a657f4aee49e6a1cd0ab1fe5bb7f9afc63abcce2123466bb8a9a3886d41724ed2c242bc61d7d5b3a1
+DIST alembic-1.8.0.tar.gz 860886 BLAKE2B eccb1c74e90094a9b473ecb66260714a519110c20b18248c4fc5ecff5edf2b424b303764f80ee76333e588e85a92499d75a8104b972ccd142cc26532fd89df30 SHA512 23fc881863741f7fd081342f5c53c1ec3d00ab300ba8cd10e4a659ee820a9ed1244cf7cf2fd40482f6be32b9d7df44128363246e942bd03c802f3a2a81533b57
diff --git a/media-gfx/alembic/alembic-1.8.0.ebuild b/media-gfx/alembic/alembic-1.8.0.ebuild
new file mode 100644
index 000000000000..dedaae796d04
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+# arm{,64} either pyilmbase needs to be keyworded or imath merged and keyworded
+# to re-add python / pyalembic support
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples hdf5 test"
+RESTRICT="!test? ( test )"
+
+# TODO: once imath has been merge, switch to use imath instead
+# of ilmbase
+RDEPEND="
+ >=media-libs/ilmbase-2.5.5:=
+ hdf5? (
+ >=sci-libs/hdf5-1.10.2:=[zlib(+)]
+ >=sys-libs/zlib-1.2.11-r1
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+
+PATCHES=( "${FILESDIR}/${P}-0001-set-correct-libdir.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_BUILD_LIBS=ON
+ -DALEMBIC_SHARED_LIBS=ON
+ -DDOCS_PATH=OFF # currently does nothing but require doxygen
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=OFF
+ # TODO: needs imath merged and keyworded for arm{,64}
+ -DUSE_PYALEMBIC=OFF
+ -DUSE_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/media-gfx/alembic/files/alembic-1.8.0-0001-set-correct-libdir.patch b/media-gfx/alembic/files/alembic-1.8.0-0001-set-correct-libdir.patch
new file mode 100644
index 000000000000..3216e38d2381
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.8.0-0001-set-correct-libdir.patch
@@ -0,0 +1,57 @@
+From 9e877b10c05e9482ef00bda99033508cc64211fd Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Fri, 23 Apr 2021 15:20:15 +0200
+Subject: [PATCH] set correct libdir
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+---
+ CMakeLists.txt | 8 ++++----
+ lib/Alembic/CMakeLists.txt | 4 ++--
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 69fff1e..97d1e2d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -73,12 +73,12 @@ option(DOCS_PATH
+
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+ SET(LIB_TYPE SHARED)
+- SET(ARCHIVE_INSTALL_DIR lib)
++ SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (WIN32)
+ ADD_DEFINITIONS(-DALEMBIC_DLL)
+ ENDIF()
+diff --git a/lib/Alembic/CMakeLists.txt b/lib/Alembic/CMakeLists.txt
+index 20acfed..9859bbe 100644
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -78,7 +78,7 @@ TARGET_LINK_LIBRARIES(Alembic
+ ${ZLIB_LIBRARY}
+ )
+
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE PATH "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE PATH "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+ EXPORT AlembicTargets
+ LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -91,7 +91,7 @@ INSTALL(TARGETS Alembic
+
+ set(alembic_targets_file "${PROJECT_NAME}Targets.cmake")
+
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+ "Where to install the Alembic's cmake files")
+
+ INCLUDE(CMakePackageConfigHelpers)
+--
+2.31.1
+