summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mate-extra/mate-media
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mate-extra/mate-media')
-rw-r--r--mate-extra/mate-media/Manifest1
-rw-r--r--mate-extra/mate-media/mate-media-1.8.0.ebuild93
-rw-r--r--mate-extra/mate-media/metadata.xml11
3 files changed, 105 insertions, 0 deletions
diff --git a/mate-extra/mate-media/Manifest b/mate-extra/mate-media/Manifest
new file mode 100644
index 000000000000..2e6f7ed5786b
--- /dev/null
+++ b/mate-extra/mate-media/Manifest
@@ -0,0 +1 @@
+DIST mate-media-1.8.0.tar.xz 939728 SHA256 a264f9afcae7dff50aefb813616857db10ed62ac30c4071e690485ee9c6e5f61 SHA512 c41f35e3827246f16eea8887f9e3226c32dad260af478b8923d9d80ea4b9eb0e6ab87f975e2ad4838bf567494d5c5c1039f325033d5244dd677f73ef00ef865a WHIRLPOOL 771705bebee18c901c0def8bcc3b0a843cace5ce7c88558d8f008c520c46aa695ca6dd1071edbdf9bc7246aa72eb41e5e8c427805806bad7866bfcfc0969bca9
diff --git a/mate-extra/mate-media/mate-media-1.8.0.ebuild b/mate-extra/mate-media/mate-media-1.8.0.ebuild
new file mode 100644
index 000000000000..8795cbe56143
--- /dev/null
+++ b/mate-extra/mate-media/mate-media-1.8.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+
+inherit gnome2 versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Multimedia related programs for the MATE desktop"
+HOMEPAGE="http://mate-desktop.org"
+
+LICENSE="LGPL-2 GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="aac flac mp3 pulseaudio speex twolame vorbis"
+
+# FIXME: automagic dev-util/glade:3 support
+COMMON_DEPEND="app-text/rarian:0
+ dev-libs/libxml2:2
+ >=dev-libs/glib-2.18.2:2
+ >=x11-libs/gtk+-2.24:2
+ >=mate-base/mate-panel-1.8:0
+ >=mate-base/mate-desktop-1.8:0
+ >=media-libs/gstreamer-0.10.23:0.10
+ >=media-libs/gst-plugins-base-0.10.23:0.10
+ >=media-libs/gst-plugins-good-0.10:0.10
+ >=media-libs/libcanberra-0.13:0[gtk]
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ >=media-plugins/gst-plugins-gconf-0.10.1:0.10
+ >=dev-libs/libunique-1:1
+ x11-libs/cairo:0
+ x11-libs/pango:0
+ virtual/libintl:0
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.16:0[glib] )"
+
+# Specific gst plugins are used by the default audio encoding profiles
+RDEPEND="${COMMON_DEPEND}
+ >=media-plugins/gst-plugins-meta-0.10:0.10[flac?,vorbis?]
+ aac? (
+ >=media-plugins/gst-plugins-faac-0.10.23:0.10
+ >=media-plugins/gst-plugins-ffmpeg-0.10:0.10
+ )
+ mp3? (
+ >=media-libs/gst-plugins-ugly-0.10:0.10
+ >=media-plugins/gst-plugins-taglib-0.10.23:0.10
+ >=media-plugins/gst-plugins-lame-0.10:0.10
+ )
+ speex? (
+ >=media-plugins/gst-plugins-ogg-0.10.23:0.10
+ >=media-plugins/gst-plugins-speex-0.10.23:0.10
+ )
+ twolame? (
+ >=media-plugins/gst-plugins-taglib-0.10.23:0.10
+ >=media-plugins/gst-plugins-twolame-0.10:0.10
+ )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=app-text/scrollkeeper-dtd-1:1.0
+ >=dev-util/intltool-0.35.0:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ !!<mate-base/mate-applets-1.8:*"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable pulseaudio) \
+ $(use_enable !pulseaudio gstmix) \
+ $(use_enable !pulseaudio gst-mixer-applet)
+}
+
+DOCS="AUTHORS ChangeLog* NEWS README"
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ewarn
+ ewarn "If you cannot play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+
+ if use pulseaudio ; then
+ ewarn "You have enabled pulseaudio support, gstmixer will not be built"
+ ewarn "If you do not use pulseaudio, you do not want this"
+ fi
+}
diff --git a/mate-extra/mate-media/metadata.xml b/mate-extra/mate-media/metadata.xml
new file mode 100644
index 000000000000..032165d8cc95
--- /dev/null
+++ b/mate-extra/mate-media/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mate</herd>
+ <use>
+ <flag name="twolame">Bring in twolame gstreamer support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">mate-desktop/mate-media</remote-id>
+ </upstream>
+</pkgmetadata>