summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2024-04-06 15:05:58 +0100
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-09 20:19:07 +0300
commit5711f833579bb0931b3f0be111af938c3545b1bd (patch)
tree099e28ec38d230c2bc518bddae377085cdc1a209 /mate-base
parentmate-base/mate-desktop: drop 1.27.3, 1.27.4 (diff)
downloadgentoo-5711f833579bb0931b3f0be111af938c3545b1bd.tar.gz
gentoo-5711f833579bb0931b3f0be111af938c3545b1bd.tar.bz2
gentoo-5711f833579bb0931b3f0be111af938c3545b1bd.zip
mate-base/mate-desktop: add 1.28.2
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'mate-base')
-rw-r--r--mate-base/mate-desktop/Manifest1
-rw-r--r--mate-base/mate-desktop/mate-desktop-1.28.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/mate-base/mate-desktop/Manifest b/mate-base/mate-desktop/Manifest
index 079372b09287..026683d02d85 100644
--- a/mate-base/mate-desktop/Manifest
+++ b/mate-base/mate-desktop/Manifest
@@ -1 +1,2 @@
DIST mate-desktop-1.26.2.tar.xz 1203480 BLAKE2B a77df2562e70cae78f4ee6693d2a2f66e1fccb5c118ba9f51a96b68bd0dc0fe1166c458636bf940b70058ade79bfc51d260aa829b0400814c6e50c297d697c98 SHA512 0e7d0dfdc58a5a6f1e5a8d1204a1a1d78f868eddb32cc36b54b77d7aee4f999e570dc66e0f16751e78bdb162ceb4858976fa3d7db52785cbded0b53e5cf069e3
+DIST mate-desktop-1.28.2.tar.xz 1141084 BLAKE2B f9a136087d1b4d009c1349ecc15edffbb23dfae2124c985070b294151c7234f098141a2a0380a6dfead48b4cffb2481a18d131f5bc0ef2e50fcf4e98329ded39 SHA512 74e3cdb2bba218d06f7d95c1cd94794363fe6e2aa1b42af0b844e647a1f052109c7d5d01d9554dc8cd49e84a79cbc7563c9df96fde8248bf60b6554300779c9d
diff --git a/mate-base/mate-desktop/mate-desktop-1.28.2.ebuild b/mate-base/mate-desktop/mate-desktop-1.28.2.ebuild
new file mode 100644
index 000000000000..ea391a41c927
--- /dev/null
+++ b/mate-base/mate-desktop/mate-desktop-1.28.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Libraries for the MATE desktop that are not part of the UI"
+LICENSE="FDL-1.1 GPL-2+ LGPL-2+ MIT-with-advertising"
+SLOT="0"
+
+IUSE="X debug +introspection startup-notification"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/dconf-0.13.4
+ x11-libs/cairo
+ x11-libs/libX11
+ >=x11-libs/libXrandr-1.3
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+ startup-notification? ( >=x11-libs/startup-notification-0.5:0 )
+"
+
+RDEPEND="${COMMON_DEPEND}"
+
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/iso-codes
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ >=x11-libs/gdk-pixbuf-2.36.5
+ virtual/pkgconfig
+"
+
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ mate_src_configure \
+ --enable-mate-about \
+ $(use_with X x) \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_enable startup-notification)
+}