summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-30 07:46:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-30 08:16:43 +0100
commit8c34f1587cb3c4e39780724988ab031ae5effe1c (patch)
tree9a8fb2e15238e36756f107d715b61e1ed8e0283f /mail-filter
parentdev-python/starlette: Bump to 0.45.0 (diff)
downloadgentoo-8c34f1587cb3c4e39780724988ab031ae5effe1c.tar.gz
gentoo-8c34f1587cb3c4e39780724988ab031ae5effe1c.tar.bz2
gentoo-8c34f1587cb3c4e39780724988ab031ae5effe1c.zip
mail-filter/pyzor: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/pyzor/Manifest1
-rw-r--r--mail-filter/pyzor/pyzor-1.1.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/mail-filter/pyzor/Manifest b/mail-filter/pyzor/Manifest
index 23148d125558..a571fc5fcc3d 100644
--- a/mail-filter/pyzor/Manifest
+++ b/mail-filter/pyzor/Manifest
@@ -1 +1,2 @@
DIST pyzor-1.0.0_p20211223.tar.gz 138500 BLAKE2B 242a7b2df3451f659d820771454e685868792bd2275b6d69d4c4adfd6044c781abe2d72fe1500a6074851faf8e88e95d6578c546d4d95fda03e11609d1a0b436 SHA512 218bea40515a21b1e08b2bad5b7ba339ba84fff2da425dc58df72a967730ebe10e319944e1604ff56bb37f6a8ae7bc0cd974b54b18a4878ba103131b8ea47b67
+DIST pyzor-release-1-1-2.gh.tar.gz 138970 BLAKE2B 07fafe1eee577094525e1c888374c646eb6d56b1f4306669915f926235b8f433b5a5fb64680d6f7744bd835fa4eefc88805302bb312515bc7ccfed5d1f9643f8 SHA512 17cefeeb9a4befde16b3a68e219599d4a85319968b16f8c7352696cdfca9db8e0c18acc83bc0b7a6873be020e91f7dee09389ea9cbde8cdad000c87d5941b702
diff --git a/mail-filter/pyzor/pyzor-1.1.2.ebuild b/mail-filter/pyzor/pyzor-1.1.2.ebuild
new file mode 100644
index 000000000000..d3a1c7d72dd2
--- /dev/null
+++ b/mail-filter/pyzor/pyzor-1.1.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+TAG=release-${PV//./-}
+MY_P=${PN}-${TAG}
+DESCRIPTION="A distributed, collaborative spam detection and filtering network"
+HOMEPAGE="
+ https://github.com/SpamExperts/pyzor/
+ https://pypi.org/project/pyzor/
+"
+SRC_URI="
+ https://github.com/SpamExperts/pyzor/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gdbm mysql pyzord redis selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ pyzord? (
+ gdbm? ( $(python_gen_impl_dep 'gdbm') )
+ mysql? ( dev-python/mysqlclient[${PYTHON_USEDEP}] )
+ redis? ( dev-python/redis[${PYTHON_USEDEP}] )
+ )
+ selinux? ( sec-policy/selinux-pyzor )
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'gdbm')
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+ )
+"
+
+REQUIRED_USE="
+ pyzord? ( || ( gdbm redis ) )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ epytest -vv tests/unit
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use pyzord; then
+ dodir /usr/sbin
+ mv "${ED}"/usr/bin/pyzord* "${ED}/usr/sbin" \
+ || die "failed to relocate pyzord"
+ else
+ rm "${ED}"/usr/bin/pyzord* || die "failed to remove pyzord"
+ fi
+}