summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2024-04-20 16:20:10 +0200
committerHanno Böck <hanno@gentoo.org>2024-04-20 16:20:56 +0200
commit8384fdc3a5d6c007d80831ddbb84f6f702f40aac (patch)
treec6c7b8fc66facce2934ea84daf2d7b3a3cc4884a /mail-filter
parentdev-qt/qtdeclarative: use QT6_RESTRICT_TESTS (diff)
downloadgentoo-8384fdc3a5d6c007d80831ddbb84f6f702f40aac.tar.gz
gentoo-8384fdc3a5d6c007d80831ddbb84f6f702f40aac.tar.bz2
gentoo-8384fdc3a5d6c007d80831ddbb84f6f702f40aac.zip
mail-filter/zdkimfilter: add 3.18
Signed-off-by: Hanno Böck <hanno@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/zdkimfilter/Manifest1
-rw-r--r--mail-filter/zdkimfilter/zdkimfilter-3.18.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/mail-filter/zdkimfilter/Manifest b/mail-filter/zdkimfilter/Manifest
index 1ac24bc1f7d0..6f64c5bcab63 100644
--- a/mail-filter/zdkimfilter/Manifest
+++ b/mail-filter/zdkimfilter/Manifest
@@ -1 +1,2 @@
DIST zdkimfilter-3.17.tar.gz 950222 BLAKE2B b1a9b6cc19dac6e78d8f9f16eaf79af043021f1ede9f29e702b76e3d3ac9c96ade2ed4a3e0d1dd49d75326cee5c8bcfe36b126f1537853a90c475c39f19aab20 SHA512 3624d80fc9c077b0ba33e4227fdf74f16d4f9a9242fd6aa960277c61ed08b822e39669bd564f15d4924b8753d59c0b6eb797a9e5d836b9101dcd5c5b19b69578
+DIST zdkimfilter-3.18.tar.gz 955330 BLAKE2B e61a2f3b3cf91699a1714e2e546db7b26c461955ba719af866a485649fb0934b8651e3350b56cf4fda5902b19ac94c279092077440b359d7d70f8d5caf68d952 SHA512 e596213d26914513ead177f5ac20a47fc7381f06c527098b9dc04bd77dcd1d85ba8b21b86337dbf4e4d129c5248c312bdec92afd4af7c4a32bd632d4663e6861
diff --git a/mail-filter/zdkimfilter/zdkimfilter-3.18.ebuild b/mail-filter/zdkimfilter/zdkimfilter-3.18.ebuild
new file mode 100644
index 000000000000..09af6b16b266
--- /dev/null
+++ b/mail-filter/zdkimfilter/zdkimfilter-3.18.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="DKIM filter for Courier-MTA"
+HOMEPAGE="https://www.tana.it/sw/zdkimfilter"
+SRC_URI="https://www.tana.it/sw/zdkimfilter/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+DEPEND="net-libs/gnutls
+ mail-mta/courier
+ dev-db/opendbx
+ dev-libs/nettle:=
+ net-dns/libidn2:=
+ dev-libs/libunistring:=
+ dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+# Tests don't work with portage sandbox
+RESTRICT="test"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ diropts -o mail -g mail
+ dodir /etc/courier/filters/keys
+ dodoc release-notes-*.txt README ChangeLog
+ dodoc odbx_example.{conf,sql}
+}