summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-13 15:51:24 +0000
committerSam James <sam@gentoo.org>2021-04-13 15:58:49 +0000
commit3325b59726a4c506370d927d7938a6d0317be178 (patch)
treec7cb49a63e9d20bbd6a13925ae01f4aed1b3f587 /mail-filter
parentmail-filter/spamassassin: Bump to 3.4.6 (diff)
downloadgentoo-3325b59726a4c506370d927d7938a6d0317be178.tar.gz
gentoo-3325b59726a4c506370d927d7938a6d0317be178.tar.bz2
gentoo-3325b59726a4c506370d927d7938a6d0317be178.zip
mail-filter/spamassassin: drop test which needs dev-perl/DBD conditionally
t/sql_based_whitelist.t needs dev-perl/DBD which is only pulled in with USE=sqlite/mysql/postgres. Rather than add REQUIRED_USE which harms automation for arch testing, we conditionally delete the test for now. (We could alternatively add a bunch of stuff as test-dependencies only, but I wanted a minimal change to the ebuild for now.) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.5.ebuild7
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.6.ebuild7
2 files changed, 14 insertions, 0 deletions
diff --git a/mail-filter/spamassassin/spamassassin-3.4.5.ebuild b/mail-filter/spamassassin/spamassassin-3.4.5.ebuild
index 562694ddd4ca..732579b87577 100644
--- a/mail-filter/spamassassin/spamassassin-3.4.5.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.4.5.ebuild
@@ -107,6 +107,13 @@ src_prepare() {
# workaround.
perl_rm_files t/spamc_*.t
+ # Some tests need extra dependencies
+ # e.g. t/sql_based_whitelist.t needs DBD
+ # This is kinder than REQUIRED_USE for tests which hurts automation
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ perl_rm_files t/sql_based_whitelist.t
+ fi
+
# Disable plugin by default
sed -i -e 's/^loadplugin/\#loadplugin/g' \
"rules/init.pre" \
diff --git a/mail-filter/spamassassin/spamassassin-3.4.6.ebuild b/mail-filter/spamassassin/spamassassin-3.4.6.ebuild
index 562694ddd4ca..732579b87577 100644
--- a/mail-filter/spamassassin/spamassassin-3.4.6.ebuild
+++ b/mail-filter/spamassassin/spamassassin-3.4.6.ebuild
@@ -107,6 +107,13 @@ src_prepare() {
# workaround.
perl_rm_files t/spamc_*.t
+ # Some tests need extra dependencies
+ # e.g. t/sql_based_whitelist.t needs DBD
+ # This is kinder than REQUIRED_USE for tests which hurts automation
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ perl_rm_files t/sql_based_whitelist.t
+ fi
+
# Disable plugin by default
sed -i -e 's/^loadplugin/\#loadplugin/g' \
"rules/init.pre" \