summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:26:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:22 +0100
commit6b5529ead21eb493aed90dbfbbcdc847453c2376 (patch)
treea57ed5735e9b4eaa8a2a9fc24aac43d31b246fe3 /llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild
parentMove {sys-devel → llvm-core}/llvmgold (diff)
downloadgentoo-6b5529ead21eb493aed90dbfbbcdc847453c2376.tar.gz
gentoo-6b5529ead21eb493aed90dbfbbcdc847453c2376.tar.bz2
gentoo-6b5529ead21eb493aed90dbfbbcdc847453c2376.zip
Move {sys-devel → llvm-core}/llvm-toolchain-symlinks
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild')
-rw-r--r--llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild b/llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild
new file mode 100644
index 000000000000..751321457456
--- /dev/null
+++ b/llvm-core/llvm-toolchain-symlinks/llvm-toolchain-symlinks-18-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLVM on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="amd64 arm arm64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
+IUSE="multilib-symlinks +native-symlinks"
+
+RDEPEND="
+ sys-devel/llvm:${SLOT}
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local tools=(
+ addr2line ar dlltool nm objcopy objdump ranlib readelf size
+ strings strip windres
+ # https://bugs.gentoo.org/936068
+ cxxfilt:c++filt
+ )
+ local chosts=( "${CHOST}" )
+ if use multilib-symlinks; then
+ local abi
+ for abi in $(get_all_abis); do
+ chosts+=( "$(get_abi_CHOST "${abi}")" )
+ done
+ fi
+
+ local chost t
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t%:*}" "${dest}/${t#*:}"
+ done
+ for chost in "${chosts[@]}"; do
+ for t in "${tools[@]}"; do
+ dosym "llvm-${t%:*}" "${dest}/${chost}-${t#*:}"
+ done
+ done
+}