summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 19:56:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-27 21:24:09 +0100
commitfb9e4f2d54dad43d39c2ae04a45e790d460bf6b1 (patch)
treecd2e14c7b513dcb87e546c3ed9b4feadc1bb121a /kde-plasma/xembed-sni-proxy
parentnet-dns/pdns-recursor: Stable on am64/x86, bug #671982 (diff)
downloadgentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.gz
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.tar.bz2
gentoo-fb9e4f2d54dad43d39c2ae04a45e790d460bf6b1.zip
kde-plasma: Add KDE Plasma 5.14.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy')
-rw-r--r--kde-plasma/xembed-sni-proxy/Manifest1
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/Manifest b/kde-plasma/xembed-sni-proxy/Manifest
index 58febfe2bc62..36c8cca07c80 100644
--- a/kde-plasma/xembed-sni-proxy/Manifest
+++ b/kde-plasma/xembed-sni-proxy/Manifest
@@ -1 +1,2 @@
DIST plasma-workspace-5.14.3.tar.xz 4584420 BLAKE2B 50975eef224435e4359447fb0ea8f2ed447cd459860071bbdd32ac2239e0e8ab035fe2703474c856bc3ca173cfddd2d4166d281ca2fa2b6e2c355d19ee2f45ee SHA512 c79ffa14874f5ef1b476ebd5586f7175dcce1190601af3e75d8d0186aca8cb526c94b1445624d75b6a0dbc5bb780673d0c361aa49c5e5752a4639bba75af42a0
+DIST plasma-workspace-5.14.4.tar.xz 4572780 BLAKE2B c0c59acdd4622949ec87e91e827595c048c3f736e27a2f7c649765aee3bbd7ef00ccba7909dd456881bf4cf382adbff3019be2a4f9d098591f8781399aee9902 SHA512 017b2b8d52c243072ffd6b7b4a766ed27d055dae36f6cf9d10e4f06748555680b55ebdae6db07a043b18359c391bf294f0bc0e601f26e5cd12b532fffcb07645
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.4.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.4.ebuild
new file mode 100644
index 000000000000..74322bcb6432
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORKS_MINIMAL="5.50.0"
+QT_MINIMAL="5.9.6"
+KDE_AUTODEPS="false"
+KMNAME="plasma-workspace"
+inherit kde5
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.2-standalone.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/${PV}/" \
+ -e "/set/s/GENTOO_QT_MINIMAL/${QT_MINIMAL}/" \
+ -e "/set/s/GENTOO_KF5_MINIMAL/${FRAMEWORKS_MINIMAL}/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}