summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-26 20:20:55 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-26 20:55:44 +0100
commit90565249851985e8affd0d29447a1607db26148b (patch)
tree7527fef7381614f7e97a6eb0e2566ab49de09200 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.0.3 version bump (diff)
downloadgentoo-90565249851985e8affd0d29447a1607db26148b.tar.gz
gentoo-90565249851985e8affd0d29447a1607db26148b.tar.bz2
gentoo-90565249851985e8affd0d29447a1607db26148b.zip
kde-plasma/kwallet-pam: 6.0.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 3acafbce5d9d..b5ba4b663587 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
DIST kwallet-pam-6.0.2.tar.xz 22928 BLAKE2B 4551b13f3a9e74271acd8a7dea231b77700648309edd3cae44701d56d2a3f915e48e6491e64cc8fc26db1e8d021bf7e9bc81a7ebd2fb02b2a126f0b67b50807a SHA512 fce0a477de5b573ff940f045ad2a4f84a914c50480a69300d1de8488ca5c06345757a632defa752c309697f8187126c189aba13da650a8079680925550bc44c5
+DIST kwallet-pam-6.0.3.tar.xz 23008 BLAKE2B 97253e71ac17573ac9522a59223ed9b8d4be065da1233f29e9376480cc1d8ae3e08823130836f1420f8cd494a6714da71d64f4e7ad843ff69146fc8604457282 SHA512 bdef907847de6a9aeef46e3e00488643f9f965b91cec547e6d14e948558aded1738fcf3f84da6de137375945fb67fb5913da5fbaebe0a08e2e313bbabb8e93ed
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.0.3.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.0.3.ebuild
new file mode 100644
index 000000000000..cb964d02d812
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}