summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-misc/stdin-plasmoid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-misc/stdin-plasmoid')
-rw-r--r--kde-misc/stdin-plasmoid/Manifest1
-rw-r--r--kde-misc/stdin-plasmoid/metadata.xml6
-rw-r--r--kde-misc/stdin-plasmoid/stdin-plasmoid-0.2_beta1.ebuild24
3 files changed, 31 insertions, 0 deletions
diff --git a/kde-misc/stdin-plasmoid/Manifest b/kde-misc/stdin-plasmoid/Manifest
new file mode 100644
index 000000000000..3cc80c76c030
--- /dev/null
+++ b/kde-misc/stdin-plasmoid/Manifest
@@ -0,0 +1 @@
+DIST 92309-0.2-beta1.tar.bz2 27400 SHA256 29c2ea5bcddffb1b3d0e2326bb50025a413bc904e50093582ba928812ddb8d6d SHA512 93d8ec9a45b1c447754af73162fd8924a84f788c873d6c0cbe57283873ea986a8abf47966beb07be5ff8d6eb89c3f46c85edf6aace20266425fa42815cb07cd8 WHIRLPOOL d12e38b9f06623a00c7786ece6aac13476ca70f35f3a169a9807cac98c2dbf13023906754b234426cb168fe0848e9150d4ab05fa1161e739e70ed652faf303da
diff --git a/kde-misc/stdin-plasmoid/metadata.xml b/kde-misc/stdin-plasmoid/metadata.xml
new file mode 100644
index 000000000000..721dd1c8d2fa
--- /dev/null
+++ b/kde-misc/stdin-plasmoid/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
+
diff --git a/kde-misc/stdin-plasmoid/stdin-plasmoid-0.2_beta1.ebuild b/kde-misc/stdin-plasmoid/stdin-plasmoid-0.2_beta1.ebuild
new file mode 100644
index 000000000000..1b2224da8918
--- /dev/null
+++ b/kde-misc/stdin-plasmoid/stdin-plasmoid-0.2_beta1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base versionator
+
+MY_P="$(replace_version_separator 2 '-')"
+
+DESCRIPTION="KDE4 plasmoid for executing a process and capturing its stderr and stdout"
+HOMEPAGE="http://www.kde-look.org/content/show.php/STDIN+Plasmoid?content=92309"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/92309-${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ $(add_kdebase_dep plasma-workspace)
+"
+
+S="${WORKDIR}/${MY_P}"