summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-06-10 11:58:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-06-10 12:02:22 +0200
commit4aad7f76276fe579e4a2d331eb9c8a017fdf8f30 (patch)
tree1afec5015bf0d55e160daa3b65d6b9e97b694241 /kde-frameworks
parentkde-frameworks/plasma: 5.107.0 version bump (diff)
downloadgentoo-4aad7f76276fe579e4a2d331eb9c8a017fdf8f30.tar.gz
gentoo-4aad7f76276fe579e4a2d331eb9c8a017fdf8f30.tar.bz2
gentoo-4aad7f76276fe579e4a2d331eb9c8a017fdf8f30.zip
kde-frameworks/purpose: 5.107.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.107.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index 252551a3f9e8..c91852119939 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.104.0.tar.xz 177424 BLAKE2B 790cffe2765bc1cca1f060bfe7faafa9c9c6e2ea211cf2b8ec912040a8813433896d52b35adcdc6a961ab2f1a67f7d251854f8c3007c6f1dd2f8c1f74cec729e SHA512 303640b2bae5c0bdd373881d06350ac05edb9dcfca0d0baa155a93fd98f4dadf2467254c46ba55508deaec21ca78d1ad458874b98d3bfd53856844cf3f13a3fa
DIST purpose-5.106.0.tar.xz 177988 BLAKE2B 68a5bfdf89e4e407b0f5494d5fa1cc4fbef990769b84c93fe2a768b809936375aa84190cf999e6c91ad602de0be21e37f511dea31f7be38f1c32882faa9df376 SHA512 4ed8f6b4fd5a2e4fff02380aded436a2ffaadde9a97e48c6430800db597e1fd46dd5aba3b57888d62838a9d316e2ac6e0b0acc4878c723e29f0231d5a692c33e
+DIST purpose-5.107.0.tar.xz 179408 BLAKE2B b8d8ae29e5848a226c2b6b885b7778b4ef1e57d5ace99185e1a5e77deb6d29d4f7685a1254df1c720e85a41c80124ca0e8dad8274a6564118a427110020ac964 SHA512 ce146b0ffb0a6b385555c7e7f11f81d8f4837b345ff70321e1f6dc2993d2649d6e51686e703eaa89d2e07fee612bb609bdcba7c915d52471e5ed98ea9ebd736f
diff --git a/kde-frameworks/purpose/purpose-5.107.0.ebuild b/kde-frameworks/purpose/purpose-5.107.0.ebuild
new file mode 100644
index 000000000000..a5a92b820096
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.107.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}