summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-14 09:52:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-14 10:46:34 +0200
commitdbadfce5e87c4c72a574f16f74da6869bc8bd913 (patch)
tree74397022d54ee3b66ecd07265ef27752c4355f92 /kde-frameworks/sonnet
parentnet-misc/cni-plugins: Version bump to 0.8.0 (diff)
downloadgentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.tar.gz
gentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.tar.bz2
gentoo-dbadfce5e87c4c72a574f16f74da6869bc8bd913.zip
kde-frameworks: Add KDE Frameworks 5.58.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.58.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index 7d0735c8e173..72908f401335 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1,2 +1,3 @@
DIST sonnet-5.54.0.tar.xz 286720 BLAKE2B 6e603c8381ea5081f72896b12a7bca7d5eae6d8dac311f6120adad90a5c062b2707fa0276b2dd893eb3ce069fb4d0d2de63ad974e2ab8bf8e795a0d8cadc1a7c SHA512 fe7551fb65fe896a872c3f0af4ce1c60f4b974f993465b5ae7b3eea219a0964f7ae5107aa9346884ffd37c95b4bf7ea0bed05592245978c07fd633af88eeca88
DIST sonnet-5.57.0.tar.xz 287740 BLAKE2B e4b3fd949b1ea268a80980ee6ae70929b8b8c344633c81c83488551cc75169adf9a03413c4c8d4f49f6cbee96cc0bc4c4c0e94b259bd2c7c94ee570331cd8b8d SHA512 43bd410e64465bfa8d5da35137b44d64ceaa38ca9b526f017930e97ec4ca96d4f23299f8c3a3c7711964ec5a1285a87475d90693ea8a86596a93c7f62783f732
+DIST sonnet-5.58.0.tar.xz 287320 BLAKE2B 3345bdd981b4d27753bd4443f6d5d39f1297459a2e860eb4f8813c41752ffc92007bb65f3807a20eb79f7e5d92957d58686fb67764f8886ab40b3c63fe619383 SHA512 c98d5d8fb19e0995b38ff414c54ea38e4d8303963b36fe140fddb53378c790adfbac3289045b147a6baa283d0a2db8112106808e09c068b180689a8f055719d0
diff --git a/kde-frameworks/sonnet/sonnet-5.58.0.ebuild b/kde-frameworks/sonnet/sonnet-5.58.0.ebuild
new file mode 100644
index 000000000000..cc912eb777c3
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.58.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}