summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 23:32:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-15 10:32:38 +0200
commit8a7b369d7e0dc99db041038c236d463c552c6315 (patch)
tree20b4631f1efedc6dc72e862a8e49bc3dcf032328 /kde-frameworks/sonnet
parentapp-admin/sysstat: Old. (diff)
downloadgentoo-8a7b369d7e0dc99db041038c236d463c552c6315.tar.gz
gentoo-8a7b369d7e0dc99db041038c236d463c552c6315.tar.bz2
gentoo-8a7b369d7e0dc99db041038c236d463c552c6315.zip
kde-frameworks: Add KDE Frameworks 5.51.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.51.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index e214fc6530d9..5c4832131c43 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.50.0.tar.xz 286156 BLAKE2B f8b71d132c329819fccb22a55953c84e6ba419e04a4a3d79b03503f189c54aade52297cc0d3196ca39b3005858dda96ac3f379098da051d1c50dc653c7b7a673 SHA512 ac0f5a0f729150d305410a4b91e3db7f1ede4148116821364611984eabfe4533fcd0a0ae4fd25f515a1b44b8983156224ef0da9fc4513be04b5b411a4dc62174
+DIST sonnet-5.51.0.tar.xz 286128 BLAKE2B 64b8eaf870b9a67881aa966b7f26b465b2c99b8ed90a41371f6c706bf82b0c028d29e2bc8471ca8d5ac4f1c3f694799a3bd868bffde361532306c590dc27330d SHA512 6854d066ceee7826d058b8b9136cae52428e140237881c1ae80685304b456de8ac410896a9f1f136501cf39f09351f3c4354fe3f5b51bd7bbb6bfef822d2b859
diff --git a/kde-frameworks/sonnet/sonnet-5.51.0.ebuild b/kde-frameworks/sonnet/sonnet-5.51.0.ebuild
new file mode 100644
index 000000000000..e988ec885f87
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.51.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package aspell ASPELL)
+ $(cmake-utils_use_find_package hunspell HUNSPELL)
+ )
+
+ kde5_src_configure
+}