summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 13:48:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-12 14:37:44 +0200
commitd33dc4975dce205bfc155259c2e364f67be35adb (patch)
tree7c5214590d30eaf8553fbdb92d40276240a40eb9 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.74.0 version bump (diff)
downloadgentoo-d33dc4975dce205bfc155259c2e364f67be35adb.tar.gz
gentoo-d33dc4975dce205bfc155259c2e364f67be35adb.tar.bz2
gentoo-d33dc4975dce205bfc155259c2e364f67be35adb.zip
kde-frameworks/purpose: 5.74.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.74.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index f6234aca29ab..9ad28f861ac3 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.70.0.tar.xz 153468 BLAKE2B e918c824658b52829607ba9ddf727178d2689aa64f5caa075dbf0947ca53819f6b8a15d49df1d3c4a408a7017cfc63416a46af2466ca51e16c7383c45b799060 SHA512 932fc3a56c47a3a031f4acc32ae5ea04733c99f953ce3248e60bc47b836d26929e71bb10633c3859d642c8667e4b1dbb60f03f450da8b0c2bda703142cf80916
DIST purpose-5.73.0.tar.xz 155468 BLAKE2B fb051ca664e24efb5fc5013fb608578185de516a29ce609d5307e3ad487c130a04e64a50bb1387a4258c9a13c2565d3f0ec6b008f138edce1010728fd92d7e48 SHA512 964e2b47e4c81f5d4dccfabd964bc5d118fbd70ab0dd615d7ec282b3281e95ebec2df82e35420006accb7b1e89fe38b4ea288e98fd169014446e35454fdd0d52
+DIST purpose-5.74.0.tar.xz 156216 BLAKE2B 7d810f2d3b1af7cd041b8e9449fc5934bca7b739b5edf7fe1f5da553f264f189cfac0dd715dddf66a6f46be0a9389dae5d9eb35558b0c41b89dd36e53d945ccd SHA512 dea52fd5d10cc0c34ecab742b691675076ddf1346e2b352cd5f74cd266576f85eb9d721bf68a29cea62f9879b826bf375b70580451c31bdd33509f57ae3cf23a
diff --git a/kde-frameworks/purpose/purpose-5.74.0.ebuild b/kde-frameworks/purpose/purpose-5.74.0.ebuild
new file mode 100644
index 000000000000..bc4f598c495a
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.74.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.14.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth +dolphin +kaccounts"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ dolphin? ( =kde-frameworks/knotifications-${PVCUT}*:5 )
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+# requires running environment
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package dolphin KF5Notifications)
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Optional dependencies:"
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}