summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 00:59:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-29 01:12:14 +0100
commitedec91eb45321a028ed914292879eb240edae7e7 (patch)
tree90e993b071fd01a7c80f5eff71f4857950abf643 /kde-frameworks/plasma
parentkde-frameworks/kded: Only recreate icons if an icon dir changed (diff)
downloadgentoo-edec91eb45321a028ed914292879eb240edae7e7.tar.gz
gentoo-edec91eb45321a028ed914292879eb240edae7e7.tar.bz2
gentoo-edec91eb45321a028ed914292879eb240edae7e7.zip
kde-frameworks/plasma: Adjust fade animation to not flicker as much
Upstream commit 3fcd43a6ed03d0aff188dfc190cc464c34302a1f KDE-bug: https://bugs.kde.org/show_bug.cgi?id=463061 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=463685 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/plasma')
-rw-r--r--kde-frameworks/plasma/files/plasma-5.102.0-fix-flicker-on-fade-animation.patch44
-rw-r--r--kde-frameworks/plasma/plasma-5.102.0-r2.ebuild72
2 files changed, 116 insertions, 0 deletions
diff --git a/kde-frameworks/plasma/files/plasma-5.102.0-fix-flicker-on-fade-animation.patch b/kde-frameworks/plasma/files/plasma-5.102.0-fix-flicker-on-fade-animation.patch
new file mode 100644
index 000000000000..1c6ddab618aa
--- /dev/null
+++ b/kde-frameworks/plasma/files/plasma-5.102.0-fix-flicker-on-fade-animation.patch
@@ -0,0 +1,44 @@
+From 3fcd43a6ed03d0aff188dfc190cc464c34302a1f Mon Sep 17 00:00:00 2001
+From: Arjen Hiemstra <ahiemstra@heimr.nl>
+Date: Tue, 10 Jan 2023 12:46:20 +0100
+Subject: [PATCH] iconitem: Adjust fade animation to not flicker as much
+
+As it turns out, mix(old texture, new texture, animation value) does
+actually result in a different visual from simply blending the two
+textures on top of each other, because the old texture first gets
+blended with the underlying color. This results in some of the
+underlying color bleeding through, which can cause flickering if the two
+textures are almost the same. To avoid this, change the animation
+slightly so that rather than crossfading, we first fade in the new
+texture then fade out the old texture. This doesn't cause a whole lot of
+visual difference for two completely different textures, but removes the
+flickering when they are very similar.
+
+BUG: 463061
+BUG: 463685
+---
+ src/declarativeimports/core/iconitem.cpp | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/src/declarativeimports/core/iconitem.cpp b/src/declarativeimports/core/iconitem.cpp
+index de1f56c69..a474a72f9 100644
+--- a/src/declarativeimports/core/iconitem.cpp
++++ b/src/declarativeimports/core/iconitem.cpp
+@@ -645,8 +645,12 @@ QSGNode *IconItem::updatePaintNode(QSGNode *oldNode, UpdatePaintNodeData *update
+ m_textureChanged = true;
+ }
+
+- updateSubtree(oldNode->firstChild(), 1.0 - m_animValue);
+- updateSubtree(oldNode->lastChild(), m_animValue);
++ // Rather than doing a perfect crossfade, first fade in the new texture
++ // then fade out the old texture. This is done to avoid the underlying
++ // color bleeding through when both textures are at ~0.5 opacity, which
++ // causes flickering if the two textures are very similar.
++ updateSubtree(oldNode->firstChild(), 2.0 - m_animValue * 2.0);
++ updateSubtree(oldNode->lastChild(), m_animValue * 2.0);
+ } else {
+ if (oldNode->childCount() == 0) {
+ oldNode->appendChildNode(createSubtree(1.0));
+--
+GitLab
+
diff --git a/kde-frameworks/plasma/plasma-5.102.0-r2.ebuild b/kde-frameworks/plasma/plasma-5.102.0-r2.ebuild
new file mode 100644
index 000000000000..19a29410133d
--- /dev/null
+++ b/kde-frameworks/plasma/plasma-5.102.0-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="${PN}-framework"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Plasma framework"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gles2-only man wayland"
+
+RESTRICT="test"
+
+# kde-frameworks/kwindowsystem[X]: Unconditional use of KX11Extras
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[gles2-only=,X]
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ =kde-frameworks/kactivities-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5[qml]
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdeclarative-${PVCUT}*:5
+ =kde-frameworks/kglobalaccel-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X]
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ x11-libs/libX11
+ x11-libs/libxcb
+ !gles2-only? ( media-libs/libglvnd[X] )
+ wayland? (
+ =kde-frameworks/kwayland-${PVCUT}*:5
+ media-libs/libglvnd
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-flicker-on-fade-animation.patch" ) # KDE-bug 463061, 463685
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package !gles2-only OpenGL)
+ $(cmake_use_find_package man KF5DocTools)
+ $(cmake_use_find_package wayland EGL)
+ $(cmake_use_find_package wayland KF5Wayland)
+ )
+
+ ecm_src_configure
+}