summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 17:32:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-04-08 17:33:41 +0200
commit772d5a9a522abd8a460b5be807bf568635a9abf0 (patch)
treeecf9649a57c723b7b09a2921555ba446a029701b /kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild
parentmedia-gfx/gimp: Sync 9999, move to https (diff)
downloadgentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.tar.gz
gentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.tar.bz2
gentoo-772d5a9a522abd8a460b5be807bf568635a9abf0.zip
kde-frameworks: Add KDE Frameworks 5.33.0 release
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild')
-rw-r--r--kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild b/kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild
new file mode 100644
index 000000000000..e6f37899e571
--- /dev/null
+++ b/kde-frameworks/kdnssd/kdnssd-5.33.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Framework for network service discovery using Zeroconf"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="nls zeroconf"
+
+RDEPEND="
+ $(add_qt_dep qtnetwork)
+ zeroconf? (
+ $(add_qt_dep qtdbus)
+ net-dns/avahi[mdnsresponder-compat]
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_DNSSD=ON
+ $(cmake-utils_use_find_package zeroconf Avahi)
+ )
+
+ kde5_src_configure
+}