summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 15:05:44 +0100
commitfc673f93b204709bd56426d01fb497d17a231549 (patch)
treea4e35f1a0c18dd58b04ced4408e79f76c9383ffc /kde-frameworks/kcrash
parentkde-apps/kalarm: Drop bogus COMMON_DEPEND (diff)
downloadgentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.gz
gentoo-fc673f93b204709bd56426d01fb497d17a231549.tar.bz2
gentoo-fc673f93b204709bd56426d01fb497d17a231549.zip
kde-frameworks: Add KDE Frameworks 5.55.0
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kcrash')
-rw-r--r--kde-frameworks/kcrash/Manifest1
-rw-r--r--kde-frameworks/kcrash/kcrash-5.55.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/kcrash/Manifest b/kde-frameworks/kcrash/Manifest
index 4996704d122c..ce3c2e7e7592 100644
--- a/kde-frameworks/kcrash/Manifest
+++ b/kde-frameworks/kcrash/Manifest
@@ -1 +1,2 @@
DIST kcrash-5.54.0.tar.xz 21980 BLAKE2B 85d4d27fb4404f78b6fabe2319f24ab132842ecdca0b82712ddc34e100096f779cb535d322d613ddb019d2aeffcf6acc1502d9ff3096f85629c4e36c66883132 SHA512 1dae5de58b8f91e463af8bf745a474472f2d53d2c2ea3bdbff2477c9220a720df1c7f97400e58a3060f891120ced85bb37f9458a7b17b6c1af1be765c9fea671
+DIST kcrash-5.55.0.tar.xz 22904 BLAKE2B 2893aafb1611cf87b553a052d63b66814dd4889a5daf25ae1564e2a0642afbbbbfca29d8966ce294db552547ef98eaa8c5f675d21267c434152b9f16b3c9a082 SHA512 450b719e1dc74739fe6467cb3523650adecfb9643fe18922f4c78eb8109a2293849654ef2bb85eccebf3ed089c2ec80878d2a87cb2016dcaec19e5233fc971b4
diff --git a/kde-frameworks/kcrash/kcrash-5.55.0.ebuild b/kde-frameworks/kcrash/kcrash-5.55.0.ebuild
new file mode 100644
index 000000000000..ff1cccbf3945
--- /dev/null
+++ b/kde-frameworks/kcrash/kcrash-5.55.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for intercepting and handling application crashes"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+ test? ( $(add_qt_dep qtwidgets) )
+"
+RDEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"