summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-12 14:58:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-12 18:56:40 +0100
commit7d4a3bf0a859dcce2366dd91ae2192abfb4e06c1 (patch)
treeacee6e89bcebbb34d02d18a34ab17d277c8b32f3 /kde-frameworks/frameworkintegration
parentnet-p2p/ktorrent: Rename IUSE=search -> webengine (diff)
downloadgentoo-7d4a3bf0a859dcce2366dd91ae2192abfb4e06c1.tar.gz
gentoo-7d4a3bf0a859dcce2366dd91ae2192abfb4e06c1.tar.bz2
gentoo-7d4a3bf0a859dcce2366dd91ae2192abfb4e06c1.zip
kde-frameworks/frameworkintegration: 5.77.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.77.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 2fdfebbc1f9e..9971afb0092f 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.74.0.tar.xz 1754176 BLAKE2B f325c8362182c066f7fef108a350e9c9378e084c7955e1395fb44918759dbd7e5f55cae037525b286cf9f6b0c67788a766b62bdf737994378b1978a7ef7dd507 SHA512 4bf533b261c149a10ed4b4607f532b57b989f6e130c417a0398216ddbe1b4b3ab964009aa5c021bdc92960f8c25c7f5c66cf8606ed7956b25adfa401d0f08e68
DIST frameworkintegration-5.76.0.tar.xz 1754768 BLAKE2B 8b2dbed7f8b57647b796475646abe16258cdfa4321c0648121c891f9bba662abcb573dcc74bb24b4dea21b5b6d899732a36c874984e0848682300d4537241392 SHA512 7f54c0c2c70eddb8442fe28e009994a80f5627294d235ec1a341e71f6ac9abbd5a6515018c883ce1825a36478403ed5f4bca03424f077abbba28f1f29f4820d4
+DIST frameworkintegration-5.77.0.tar.xz 1754776 BLAKE2B 6184144a4ae91a8853de0fc8ab6e72afba493492b1ba408e428622f8028501f342a5bc9f8fd881a55935a48d2b695e5b9c920ef674e9e1613c9cd7b1803336c7 SHA512 e388fc092c0a3e3414563add6ca2a03ad6f3a3c25093293675ae0a2df594094420b75d000f2fcfa560044b1350672db5cea9f620ad9bd4349a1ebdd271624079
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.77.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.77.0.ebuild
new file mode 100644
index 000000000000..694c122e0a59
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.77.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+# requires running Plasma environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}