summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/kdeplasma-addons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/Manifest1
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.14.3.ebuild61
-rw-r--r--kde-base/kdeplasma-addons/metadata.xml18
3 files changed, 80 insertions, 0 deletions
diff --git a/kde-base/kdeplasma-addons/Manifest b/kde-base/kdeplasma-addons/Manifest
new file mode 100644
index 000000000000..166ed064c52d
--- /dev/null
+++ b/kde-base/kdeplasma-addons/Manifest
@@ -0,0 +1 @@
+DIST kdeplasma-addons-4.14.3.tar.xz 1791328 SHA256 12d58e30362729473db208c0650676dac0fdae8b3f223ce92e8df41e3e928f24 SHA512 e4382aa1aab27ddcdecdd53ca0d931b9d53d27dfe4b53736642e1e030ac940ee6909029d7ddb865ee13567facb4e380d3c23601b9ea985151fccba8860077925 WHIRLPOOL 13b3a9f6706bbdda6ab4010aedbb1da4f677de771e3bd5f7c6dc2074db413860ea26bbeae919b7927e31116f535f51ef67ada1d2aa3b368ca4df23f4146a4165
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.3.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.3.ebuild
new file mode 100644
index 000000000000..2ee2f266ae60
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.14.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json +kdepim nepomuk oauth
+qalculate qwt scim"
+
+RESTRICT=test
+# tests hang
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ $(add_kdebase_dep kdelibs 'nepomuk?')
+ $(add_kdebase_dep krunner '' 4.11)
+ $(add_kdebase_dep plasma-workspace 'nepomuk?' 4.11)
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdeapps_dep marble) )
+ exif? ( $(add_kdeapps_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ kdepim? ( $(add_kdebase_dep kdepimlibs) )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[openssl]
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_build ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with kdepim KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_build scim)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-base/kdeplasma-addons/metadata.xml b/kde-base/kdeplasma-addons/metadata.xml
new file mode 100644
index 000000000000..f465b65cadf2
--- /dev/null
+++ b/kde-base/kdeplasma-addons/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="attica">Enable support for <pkg>dev-libs/libattica</pkg></flag>
+ <flag name="ibus">Use ibus input method via <pkg>app-i18n/ibus</pkg></flag>
+ <flag name="desktopglobe">Enable Desktop Globe wallpaper using <pkg>kde-base/marble</pkg></flag>
+ <flag name="fcitx">Use fcitx input method via <pkg>app-i18n/fcitx</pkg></flag>
+ <flag name="json">Enable JSON support via <pkg>dev-libs/qjson</pkg></flag>
+ <flag name="kdepim">KDE PIM integration via <pkg>kde-base/kdepimlibs</pkg></flag>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ <flag name="oauth">Enable OAuth support via <pkg>dev-libs/qoauth</pkg></flag>
+ <flag name="qalculate">Enable Qalculate runner using <pkg>sci-libs/libqalculate</pkg></flag>
+ <flag name="qwt">Enable applets that use <pkg>x11-libs/qwt:5</pkg></flag>
+ <flag name="scim">Enable applets that use <pkg>app-i18n/scim</pkg></flag>
+ </use>
+</pkgmetadata>