summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/lokalize
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/lokalize')
-rw-r--r--kde-apps/lokalize/Manifest1
-rw-r--r--kde-apps/lokalize/lokalize-4.14.3.ebuild47
-rw-r--r--kde-apps/lokalize/metadata.xml8
3 files changed, 56 insertions, 0 deletions
diff --git a/kde-apps/lokalize/Manifest b/kde-apps/lokalize/Manifest
new file mode 100644
index 000000000000..4371eee50a7e
--- /dev/null
+++ b/kde-apps/lokalize/Manifest
@@ -0,0 +1 @@
+DIST lokalize-4.14.3.tar.xz 846236 SHA256 0f59c761597bca8e52f90bc838855f1798c2a1e5d50d926134df5fcdfeaee5c5 SHA512 543aa2464fd2d793084b8c3307df55d33a51c223846009142212e0750f3a7b2ecd309be1dc03c8313b8d14ea8ccefa08e3aa6d237f8298256919449864e13b11 WHIRLPOOL d5665375d4d9b0d43abd2c2515e9f1cc07c0439ff603ff95c67ee0c30ca5d4b39227e228c6bdc414b196bd81d23114e46e0431953843cf72fdf71dafaa3b1fc8
diff --git a/kde-apps/lokalize/lokalize-4.14.3.ebuild b/kde-apps/lokalize/lokalize-4.14.3.ebuild
new file mode 100644
index 000000000000..f55286cdef22
--- /dev/null
+++ b/kde-apps/lokalize/lokalize-4.14.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="KDE4 translation tool"
+HOMEPAGE="http://www.kde.org/applications/development/lokalize
+http://l10n.kde.org/tools"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug nepomuk"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=app-text/hunspell-1.2.8
+ >=dev-qt/qtsql-4.5.0:4[sqlite]
+ nepomuk? ( >=dev-libs/soprano-2.9.0 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kdesdk-strigi-analyzer)
+ $(add_kdebase_dep krosspython "${PYTHON_USEDEP}")
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_install() {
+ kde4-base_src_install
+ python_fix_shebang "${ED}/usr/share/apps/${PN}"
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! has_version dev-vcs/subversion ; then
+ elog "To be able to autofetch KDE translations in new project wizard, install dev-vcs/subversion."
+ fi
+}
diff --git a/kde-apps/lokalize/metadata.xml b/kde-apps/lokalize/metadata.xml
new file mode 100644
index 000000000000..2d94d9badf67
--- /dev/null
+++ b/kde-apps/lokalize/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <use>
+ <flag name="nepomuk">Enable Nepomuk based semantic desktop support (deprecated)</flag>
+ </use>
+</pkgmetadata>