summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/kate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/kate')
-rw-r--r--kde-apps/kate/Manifest1
-rw-r--r--kde-apps/kate/kate-4.14.3.ebuild62
-rw-r--r--kde-apps/kate/metadata.xml5
3 files changed, 68 insertions, 0 deletions
diff --git a/kde-apps/kate/Manifest b/kde-apps/kate/Manifest
new file mode 100644
index 000000000000..b4d36ec8a86c
--- /dev/null
+++ b/kde-apps/kate/Manifest
@@ -0,0 +1 @@
+DIST kate-4.14.3.tar.xz 2766880 SHA256 513d4ae2c36fa6b59caf3b2b685e3ea1167093d16025859cfac90d75617e707d SHA512 0d197bb00fb9a56572e140dd3c50338c90a0cb3bb8ebc78cc0e6d6ab04d6c129537a2ab8076ff9b844e159687c0a73cbacbe678e006b2d86b57285068158e38e WHIRLPOOL bb1c499c55dc768ab936d4a2e2f6ac79ddb28d84c517bfa1ec421fdfbc6f9e727ae5c0e3f1773e3664ad263217c1b89f9c83b51ad0ca6fdee36e23b20fa964d5
diff --git a/kde-apps/kate/kate-4.14.3.ebuild b/kde-apps/kate/kate-4.14.3.ebuild
new file mode 100644
index 000000000000..e902a805380d
--- /dev/null
+++ b/kde-apps/kate/kate-4.14.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KDE_HANDBOOK="optional"
+KMNAME="kate"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit python-single-r1 kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor"
+HOMEPAGE="http://www.kde.org/applications/utilities/kate http://kate-editor.org"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ $(add_kdebase_dep kactivities '' 4.13)
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qjson
+ python? (
+ ${PYTHON_DEPS}
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}" 4.9.2-r1)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep katepart)
+"
+
+KMEXTRA="
+ addons/kate
+ addons/plasma
+"
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ kde4-meta_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build python pate)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}
diff --git a/kde-apps/kate/metadata.xml b/kde-apps/kate/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-apps/kate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>