summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-09-07 20:29:32 +0200
commit996987a2817587de8e6dd587fdfdf8897d383ae4 (patch)
treed607e47be660333a574a1618e0f090dd0f0ea60a /kde-apps/ark
parentmedia-radio/flrig: Version bump (diff)
downloadgentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.gz
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.tar.bz2
gentoo-996987a2817587de8e6dd587fdfdf8897d383ae4.zip
kde-apps: Add KDE Applications 17.08.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-17.08.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index da23db3a1ca5..2892d9b4e733 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-17.04.3.tar.xz 1888304 SHA256 36ea400aa72ee3e8ec09c3ef2a0ffc5dad6b4afb34aa0c0736a885f4635333ad SHA512 58e3c5060381f59af2ec9ede0beefc2da6349701415c591fe568c16f30b7e5f95ce5cbeb14ca1d995f5968ea68d23593ed37c4f6ea54e77faff5a97d7a3efed0 WHIRLPOOL 3335e272eb009a12e2ea50f0a8aa17d1e1599517788814ac6fcc8b3323c66f5442d74b0b54ee22f29d26d37f66c5fb3353074eb4fd42ad5168829423eaa09cd8
DIST ark-17.08.0.tar.xz 1964332 SHA256 a1e76d7129f80a2b7e511de5b65f1d6718a3fdf8a7d5de85fad842b6822777b4 SHA512 112ffb00e6936df6a0e436fa29a61af85ad775b845d8eea27d2077ea341882a876b8f9db090dca805e44eee77ac2473d921b910118c415a3d4a96db19859b002 WHIRLPOOL 80f1f639c5d40010ca7d93e8bfdfd0f9b460f2749621ca38d91a81b2071fecda5d5b8b5076f39c5a99f21af54f2db6bfb813ce02090e9eab988e196e9613c9bd
+DIST ark-17.08.1.tar.xz 1965280 SHA256 c9c49e220adf12d8132a2e307f34e28ffbd317e41a64823e2f901ac24ef92f05 SHA512 7c85ee28f60b6f99204977cb1f5b76ae893166540fb13a58fba7f964a76d7c4e0d7b9fa430000d4822e4ac26c3cec9d8280c20673dc166196fed33ae57bc907d WHIRLPOOL e6bb69af7954d7be5b9e75b43e9a8b6fb295f4d968a75a504bafccc8365a85791b02953db237acc4c0ffcfd1e85f7e9db79688345a292b57f2d11bd8272070ca
diff --git a/kde-apps/ark/ark-17.08.1.ebuild b/kde-apps/ark/ark-17.08.1.ebuild
new file mode 100644
index 000000000000..b40db618e929
--- /dev/null
+++ b/kde-apps/ark/ark-17.08.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip zlib"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib?]
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ $(cmake-utils_use_find_package zlib ZLIB)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ # not a typo, app-arch/unar is a real package
+ if ! has_version app-arch/unar ; then
+ elog "For handling rar archives, install app-arch/unar"
+ fi
+
+ if ! has_version app-arch/p7zip ; then
+ elog "For handling 7-Zip archives, install app-arch/p7zip"
+ fi
+
+ if ! has_version app-arch/lrzip ; then
+ elog "For handling lrz archives, install app-arch/lrzip"
+ fi
+}