summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 12:48:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-08 13:28:34 +0100
commit4596f01b1eeebf3ee9cb8ec94f694191e4150c0b (patch)
tree0ea2e0348c592fa6fb772ef4d664ee944481630f /kde-apps/ark
parentdev-libs/rasqal: Fix typo (diff)
downloadgentoo-4596f01b1eeebf3ee9cb8ec94f694191e4150c0b.tar.gz
gentoo-4596f01b1eeebf3ee9cb8ec94f694191e4150c0b.tar.bz2
gentoo-4596f01b1eeebf3ee9cb8ec94f694191e4150c0b.zip
kde-apps: Add KDE Applications 18.08.3
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/Manifest1
-rw-r--r--kde-apps/ark/ark-18.08.3.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/ark/Manifest b/kde-apps/ark/Manifest
index 1095158c5f8d..1023b296a0c1 100644
--- a/kde-apps/ark/Manifest
+++ b/kde-apps/ark/Manifest
@@ -1,2 +1,3 @@
DIST ark-18.04.3.tar.xz 1973656 BLAKE2B afa413156233a31a1c7d102799b347b6879453a4c0a870511cb9040c9160c4da4eab30722ad9ec07ec1e9b68e942c137c464e0054738d8ee3632546b49c9dc93 SHA512 39348d3cbd3ed044ecc40a235c3e93dacb638e3ea867f814c722630786fbf7ea48643f967fb46f3358c64966a250306f11ab2a76c9147bc135ba826bcce9d33d
DIST ark-18.08.2.tar.xz 2580240 BLAKE2B f6e32d518d4c4a278542fee20e8eb717004d51fc61ecd79e1d386c87628783fa1644062aae285e417f709ce79d99574c420ebf9c5b5faea2075de35d8115baa2 SHA512 5522fba835d75e317f6bcec40c2b8faf0fb7793a643637ca37d28698c0cf9cc639892f6dd272272095d74f648b9bfea7f5c67f0b2c41847e99564c9ec5f6954c
+DIST ark-18.08.3.tar.xz 2580200 BLAKE2B 7ecfcc542d25c0a6ba8639e4a5cd353358d5188077ca309c6fe6dc07288c071083ff7a025d71d489d3fed412c63d69f33d480084afbd015b6c45b64cf08a3286 SHA512 56ec9a592cc0862dfe39dbef424b1fb09e8d32050448558c402b864756e00ba402e9fdec7159e3bd5b7013217f6cf1b33cdd4b0d663a11b8bfe5c4c76535f820
diff --git a/kde-apps/ark/ark-18.08.3.ebuild b/kde-apps/ark/ark-18.08.3.ebuild
new file mode 100644
index 000000000000..c6f3ec55fd70
--- /dev/null
+++ b/kde-apps/ark/ark-18.08.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="optional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="KDE Archiving tool"
+HOMEPAGE="https://www.kde.org/applications/utilities/ark
+https://utils.kde.org/projects/ark/"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 lzma zip"
+
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ app-arch/libarchive:=[bzip2?,lzma?,zlib]
+ sys-libs/zlib
+ zip? ( >=dev-libs/libzip-1.2.0:= )
+"
+DEPEND="${RDEPEND}
+ $(add_qt_dep qtconcurrent)
+ sys-devel/gettext
+"
+
+# bug #560548, last checked with 16.04.1
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package bzip2 BZip2)
+ $(cmake-utils_use_find_package lzma LibLZMA)
+ $(cmake-utils_use_find_package zip LibZip)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version app-arch/unar && ! has_version app-arch/unrar; then
+ elog "For extracting rar archives, install app-arch/unar (free) or app-arch/unrar (non-free)."
+ fi
+
+ has_version app-arch/rar || \
+ elog "For creating rar archives, installing app-arch/rar is required."
+
+ has_version app-arch/p7zip || \
+ elog "For handling 7-Zip archives, install app-arch/p7zip."
+
+ has_version app-arch/lrzip || \
+ elog "For handling lrz archives, install app-arch/lrzip."
+}