summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-06-14 21:10:20 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-09 11:53:18 +0200
commitfe307503df05115b3509af5c8c082ca7a0d9660d (patch)
tree1f46433dd6cd59c59144b16d5edf5b561fad0fcc /gui-libs
parentgui-libs/vte-common: Bump to 0.76.3 (diff)
downloadgentoo-fe307503df05115b3509af5c8c082ca7a0d9660d.tar.gz
gentoo-fe307503df05115b3509af5c8c082ca7a0d9660d.tar.bz2
gentoo-fe307503df05115b3509af5c8c082ca7a0d9660d.zip
gui-libs/vte: Bump to 0.76.3
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/vte/Manifest3
-rw-r--r--gui-libs/vte/vte-0.76.3.ebuild106
2 files changed, 109 insertions, 0 deletions
diff --git a/gui-libs/vte/Manifest b/gui-libs/vte/Manifest
index 00b6698009f1..22e7b701e3e9 100644
--- a/gui-libs/vte/Manifest
+++ b/gui-libs/vte/Manifest
@@ -1,2 +1,5 @@
DIST vte-0.74.0-command-notify.patch.xz 9248 BLAKE2B 30917bc72d2b3fd917178f49c26f023d40d37e9a44a896c44e55345396d0bfdb1b109f8b2fdead96c31f92f5febcc397f2899511647c3adf3c2aace2be8ffa94 SHA512 fc0bb3cfa70fc5e1384c44fcce6d6a76957d0dd72f61a882d9df22d55dd06fcee4e7bd2a136c443158fe403992befe5d7ce5970b8b657b690b3875ff5171ea83
DIST vte-0.74.2.tar.bz2 505422 BLAKE2B 243eabfb26c0ec65d0b202437ae79265440256941dae4263e9d6dc9afea24d0fbbd7d421864a90b54d2ba953cd60a2b5a41aef9fb9e53396176bcc71400eef82 SHA512 203dd0f8606b8979cde01781412e0dbab3cb8857828e55f6d69ecfc2e4d58d53430aa5c61a2203e122c772ba1f6c5b739d3c03456b133580e76d511d67f3f534
+DIST vte-0.76.3-a11y-implement-GtkAccessibleText.patch.xz 9548 BLAKE2B 2c34f44cff5e1abf00358984c8000a3d7bce3b020be08052d016ca69864f9ab9b1a22ca6709dd5e78a13c8e43a6c4ace1fc1e74f5be83a9988c2b0083880ab95 SHA512 490ec91f27a8a873ee03f8aebb222217c85b2f865e6662dcc5efc1d9fe3765c966d4e9cd8691c4f1779e232139822eb1aa0f464e7090da96c6c17b556f642927
+DIST vte-0.76.3-command-notify.patch.xz 4336 BLAKE2B d3fd8eef9c3322af20ceac4678635edbb00159fa88147a897f655a5920c638da19fff10e08215a891df2cdd5721cd808b6041d84e74980a9f129e07de621526b SHA512 1c974ae97823659bee873036d656423255fae2b71baa4f4221b656055d69d55120f5cccfe3d9e514a64a2c5f87f94c1e4b47b4a2a233faf28ca06a959efe3e3b
+DIST vte-0.76.3.tar.xz 961684 BLAKE2B 066eaa2e35652481e9cf487084e522f55fdedfccf6435440d13d80523e64fd9969b7ee0a235c6a97c5c0531ddad6977bfc42ccb6915d52990965b1af9a63470e SHA512 59cf3241f59b7ce795098814a04816d150330e4464a2438c974ac03cfd6aa05e7e037121a6a21929d6b12eb17fb1a4bf48c936604f0e0b770e3f125adb5a4c50
diff --git a/gui-libs/vte/vte-0.76.3.ebuild b/gui-libs/vte/vte-0.76.3.ebuild
new file mode 100644
index 000000000000..f9f2bd5dbda3
--- /dev/null
+++ b/gui-libs/vte/vte-0.76.3.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome.org meson python-any-r1 vala xdg
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/vte/"
+
+SRC_URI="${SRC_URI} !vanilla? ( https://dev.gentoo.org/~pacho/distfiles/${P}-command-notify.patch.xz https://dev.gentoo.org/~pacho/distfiles/${P}-a11y-implement-GtkAccessibleText.patch.xz )"
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91-gtk4" # vte_api_version + "-gtk4" in meson.build
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+crypt debug gtk-doc +icu +introspection systemd +vala vanilla"
+REQUIRED_USE="
+ gtk-doc? ( introspection )
+ vala? ( introspection )
+"
+
+DEPEND="
+ >=gui-libs/gtk-4.14:4[introspection?]
+ >=x11-libs/cairo-1.0
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.72:2
+ crypt? ( >=net-libs/gnutls-3.2.7:0= )
+ icu? ( dev-libs/icu:= )
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21:=
+ systemd? ( >=sys-apps/systemd-220:= )
+ >=app-arch/lz4-1.9
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+ x11-libs/pango[introspection?]
+"
+RDEPEND="${DEPEND}
+ ~gui-libs/vte-common-${PV}[systemd?]
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ gtk-doc? ( dev-util/gi-docgen )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.66.2-musl-W_EXITCODE.patch
+
+ if ! use vanilla; then
+ # From https://src.fedoraproject.org/rpms/vte291/raw/f40/f/0001-add-notification-and-shell-precmd-preexec.patch
+ # Adds OSC 777 support for desktop notifications in gnome-terminal or elsewhere
+ eapply "${WORKDIR}"/${P}-command-notify.patch
+ # From https://src.fedoraproject.org/rpms/vte291/raw/f40/f/0001-a11y-implement-GtkAccessibleText.patch
+ # Migrate to GTK4 and add VteTerminal:enable-a11y feature flag
+ eapply "${WORKDIR}"/${P}-a11y-implement-GtkAccessibleText.patch
+ fi
+
+ # -Ddebugg option enables various debug support via VTE_DEBUG, but also ggdb3; strip the latter
+ sed -e '/ggdb3/d' -i meson.build || die
+ sed -i 's/vte_gettext_domain = vte_api_name/vte_gettext_domain = vte_gtk4_api_name/' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=true
+ $(meson_use debug)
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=true
+ $(meson_use crypt gnutls)
+ -Dgtk3=false
+ -Dgtk4=true
+ $(meson_use icu)
+ $(meson_use systemd _systemd)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ # not meson_src_install because this would include einstalldocs, which
+ # would result in file collisions with x11-libs/vte
+ meson_install
+
+ # Remove files that are provided by gui-libs/vte-common
+ rm "${ED}"/usr/libexec/vte-urlencode-cwd || die
+ rm "${ED}"/etc/profile.d/vte.sh || die
+ rm "${ED}"/etc/profile.d/vte.csh || die
+ if use systemd; then
+ rm "${ED}"/usr/lib/systemd/user/vte-spawn-.scope.d/defaults.conf || die
+ fi
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/vte-${SLOT} "${ED}"/usr/share/gtk-doc/ || die
+ fi
+}