summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-07-23 19:31:54 -0700
committerYixun Lan <dlan@gentoo.org>2024-07-25 00:01:05 +0000
commit40447ea88b0f32d2b4ff86a744f8e7227e29aae1 (patch)
treef58937c8ff791bfe0104f19200ea508ecb4407cd /gui-libs
parentgui-libs/hyprutils: add 0.2.0 (diff)
downloadgentoo-40447ea88b0f32d2b4ff86a744f8e7227e29aae1.tar.gz
gentoo-40447ea88b0f32d2b4ff86a744f8e7227e29aae1.tar.bz2
gentoo-40447ea88b0f32d2b4ff86a744f8e7227e29aae1.zip
gui-libs/aquamarine: new package, add 9999
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/aquamarine/aquamarine-9999.ebuild51
-rw-r--r--gui-libs/aquamarine/metadata.xml21
2 files changed, 72 insertions, 0 deletions
diff --git a/gui-libs/aquamarine/aquamarine-9999.ebuild b/gui-libs/aquamarine/aquamarine-9999.ebuild
new file mode 100644
index 000000000000..80acaec62cc4
--- /dev/null
+++ b/gui-libs/aquamarine/aquamarine-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Aquamarine is a very light linux rendering backend library"
+HOMEPAGE="https://github.com/hyprwm/aquamarine"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ media-libs/libdisplay-info
+ >=dev-libs/libinput-1.26.1
+ >=dev-util/hyprwayland-scanner-0.4.0
+ >=gui-libs/hyprutils-0.1.5
+ gui-libs/egl-gbm
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+ x11-libs/pixman
+ virtual/libudev
+ sys-apps/hwdata
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i "/add_compile_options(-O3)/d" "${S}/CMakeLists.txt" || die
+ cmake_src_prepare
+}
diff --git a/gui-libs/aquamarine/metadata.xml b/gui-libs/aquamarine/metadata.xml
new file mode 100644
index 000000000000..3b4e390d189e
--- /dev/null
+++ b/gui-libs/aquamarine/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>julien@jroy.ca</email>
+ <name>Julien Roy</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>johnmh@johnmh.me</email>
+ <name>John M. Harris, Jr.</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/hyprwm/aquamarine/releases</changelog>
+ <bugs-to>https://github.com/hyprwm/aquamarine/issues</bugs-to>
+ <remote-id type="github">hyprwm/aquamarine</remote-id>
+ </upstream>
+</pkgmetadata>