summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-02-22 17:35:51 -0500
committerAaron Bauman <bman@gentoo.org>2019-02-22 17:35:51 -0500
commit97aba5400b89ac05a73194209a48f48cb03611e6 (patch)
treed5a8ab72bdc7ed443e514842a36bb9b6fd426ba1 /gui-apps
parentdev-libs/sway{idle,lock}: drop and move to gui-apps/ (diff)
downloadgentoo-97aba5400b89ac05a73194209a48f48cb03611e6.tar.gz
gentoo-97aba5400b89ac05a73194209a48f48cb03611e6.tar.bz2
gentoo-97aba5400b89ac05a73194209a48f48cb03611e6.zip
gui-apps/sway{idle,lock}: add new category and move packages
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swayidle/Manifest1
-rw-r--r--gui-apps/swayidle/metadata.xml30
-rw-r--r--gui-apps/swayidle/swayidle-1.2.ebuild57
-rw-r--r--gui-apps/swayidle/swayidle-9999.ebuild57
-rw-r--r--gui-apps/swaylock/Manifest1
-rw-r--r--gui-apps/swaylock/metadata.xml34
-rw-r--r--gui-apps/swaylock/swaylock-1.3.ebuild61
-rw-r--r--gui-apps/swaylock/swaylock-9999.ebuild61
8 files changed, 302 insertions, 0 deletions
diff --git a/gui-apps/swayidle/Manifest b/gui-apps/swayidle/Manifest
new file mode 100644
index 000000000000..cbd8e77cc479
--- /dev/null
+++ b/gui-apps/swayidle/Manifest
@@ -0,0 +1 @@
+DIST swayidle-1.2.tar.gz 9136 BLAKE2B e88eec89007deed59df30f3f89111352b8a1ed464141783cb25b0d0a484e8ea4cfd611f1bd80d9420368d7912979eb0536a6aa583d24504d32bac797a898dba5 SHA512 2539e80a45163bb3e76f7b41f6fd6a1d73d194b7e466f63178b5087d05470fceafba38a26d592a534a01b992a2c0cf0f8fb83805cdf41ee956fea5136cc8fe89
diff --git a/gui-apps/swayidle/metadata.xml b/gui-apps/swayidle/metadata.xml
new file mode 100644
index 000000000000..880f87d424ec
--- /dev/null
+++ b/gui-apps/swayidle/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>speedjack95@gmail.com</email>
+ <name>Niccolò Scatena</name>
+ </maintainer>
+ <longdescription lang="en">
+ Sway's idle management daemon, compatible with any Wayland compositor
+ which implements the KDE idle protocol.
+ </longdescription>
+ <use>
+ <flag name="elogind">Enable support for rootless session via elogind</flag>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">swaywm/swayidle</remote-id>
+ <maintainer status="active">
+ <email>sir@cmpwn.com</email>
+ <name>Drew DeVault</name>
+ </maintainer>
+ <bugs-to>https://github.com/swaywm/swayidle/issues</bugs-to>
+ <changelog>https://github.com/swaywm/swayidle/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/swayidle/swayidle-1.2.ebuild b/gui-apps/swayidle/swayidle-1.2.ebuild
new file mode 100644
index 000000000000..774758c9815e
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man systemd zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/sway-1.0_beta1
+ !~dev-libs/sway-1.0_beta2[swayidle]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
diff --git a/gui-apps/swayidle/swayidle-9999.ebuild b/gui-apps/swayidle/swayidle-9999.ebuild
new file mode 100644
index 000000000000..774758c9815e
--- /dev/null
+++ b/gui-apps/swayidle/swayidle-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Idle management daemon for Wayland"
+HOMEPAGE="https://github.com/swaywm/swayidle"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="elogind fish-completion +man systemd zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ dev-libs/wayland
+ elogind? ( >=sys-auth/elogind-237[policykit] )
+ systemd? ( >=sys-apps/systemd-237[policykit] )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/sway-1.0_beta1
+ !~dev-libs/sway-1.0_beta2[swayidle]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if use systemd; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
+ elif use elogind; then
+ emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=elogind")
+ else
+ emesonargs+=("-Dlogind=disabled")
+ fi
+
+ meson_src_configure
+}
diff --git a/gui-apps/swaylock/Manifest b/gui-apps/swaylock/Manifest
new file mode 100644
index 000000000000..ee04cb54cdea
--- /dev/null
+++ b/gui-apps/swaylock/Manifest
@@ -0,0 +1 @@
+DIST swaylock-1.3.tar.gz 32848 BLAKE2B 81ed50839bcb0139e7fc2081bd37e738f3e6ef23e96a5108d1acf56cc3425285f7382576a54201f1bf188883b1da06492074c091877af13832c0140e4e6099fd SHA512 723d758d76f076f3f1539ea0d651f6ad2562659c72eef7e895d7827a0be21db663652fe4ce2609065aff45ff20230879599868cff327ab52b896330ca04d78c4
diff --git a/gui-apps/swaylock/metadata.xml b/gui-apps/swaylock/metadata.xml
new file mode 100644
index 000000000000..26cfed9c82aa
--- /dev/null
+++ b/gui-apps/swaylock/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>speedjack95@gmail.com</email>
+ <name>Niccolò Scatena</name>
+ </maintainer>
+ <longdescription lang="en">
+ Swaylock is a screen locking utility for Wayland compositors. It is
+ compatible with any Wayland compositor which implements the following
+ Wayland protocols: wlr-layer-shell, wlr-input-inhibitor, xdg-output,
+ xdg-shell.
+
+ Swaylock is the official screen locker for <pkg>dev-libs/sway</pkg>.
+ </longdescription>
+ <use>
+ <flag name="fish-completion">Enable fish completion support</flag>
+ <flag name="gdk-pixbuf">Enable additional image format support via the <pkg>x11-libs/gdk-pixbuf</pkg> library</flag>
+ <flag name="man">Build and install man pages</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">swaywm/swaylock</remote-id>
+ <maintainer status="active">
+ <email>sir@cmpwn.com</email>
+ <name>Drew DeVault</name>
+ </maintainer>
+ <bugs-to>https://github.com/swaywm/swaylock/issues</bugs-to>
+ <changelog>https://github.com/swaywm/swaylock/releases</changelog>
+ </upstream>
+</pkgmetadata>
diff --git a/gui-apps/swaylock/swaylock-1.3.ebuild b/gui-apps/swaylock/swaylock-1.3.ebuild
new file mode 100644
index 000000000000..85539fb9095e
--- /dev/null
+++ b/gui-apps/swaylock/swaylock-1.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Screen locker for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaylock"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="fish-completion +gdk-pixbuf +man +pam zsh-completion"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf:2 )
+ pam? ( virtual/pam )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/sway-1.0_beta2[swaylock]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dpam=$(usex pam enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if [[ ${PV} != 9999 ]]; then
+ emesonargs+=("-Dswaylock-version=${PV}")
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if ! use pam; then
+ fcaps cap_sys_admin usr/bin/swaylock
+ fi
+}
diff --git a/gui-apps/swaylock/swaylock-9999.ebuild b/gui-apps/swaylock/swaylock-9999.ebuild
new file mode 100644
index 000000000000..85539fb9095e
--- /dev/null
+++ b/gui-apps/swaylock/swaylock-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Screen locker for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaylock"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="fish-completion +gdk-pixbuf +man +pam zsh-completion"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf:2 )
+ pam? ( virtual/pam )
+"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/sway-1.0_beta2[swaylock]
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dpam=$(usex pam enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ $(meson_use fish-completion fish-completions)
+ $(meson_use zsh-completion zsh-completions)
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+ if [[ ${PV} != 9999 ]]; then
+ emesonargs+=("-Dswaylock-version=${PV}")
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if ! use pam; then
+ fcaps cap_sys_admin usr/bin/swaylock
+ fi
+}