summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-10 05:09:51 +0100
committerSam James <sam@gentoo.org>2023-04-10 05:09:51 +0100
commit2e4cff0f61c3b37cfd629d668c15cd1859fee4f5 (patch)
tree9a8a564a90b526d900aa0436a47ef2e0f771376d /gui-apps
parentdev-util/bitcoin-tx: fix build w/ gcc 13 (diff)
downloadgentoo-2e4cff0f61c3b37cfd629d668c15cd1859fee4f5.tar.gz
gentoo-2e4cff0f61c3b37cfd629d668c15cd1859fee4f5.tar.bz2
gentoo-2e4cff0f61c3b37cfd629d668c15cd1859fee4f5.zip
gui-apps/waybar: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/900729 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/files/waybar-0.9.17-gcc13.patch31
-rw-r--r--gui-apps/waybar/waybar-0.9.17.ebuild1
2 files changed, 32 insertions, 0 deletions
diff --git a/gui-apps/waybar/files/waybar-0.9.17-gcc13.patch b/gui-apps/waybar/files/waybar-0.9.17-gcc13.patch
new file mode 100644
index 000000000000..831435f50cac
--- /dev/null
+++ b/gui-apps/waybar/files/waybar-0.9.17-gcc13.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/900729
+https://github.com/Alexays/Waybar/commit/ca9d237b00b4d01f341b0d7bc938afb10a4f8cad
+
+From ca9d237b00b4d01f341b0d7bc938afb10a4f8cad Mon Sep 17 00:00:00 2001
+From: Aleksei Bavshin <alebastr89@gmail.com>
+Date: Mon, 16 Jan 2023 10:27:21 -0800
+Subject: [PATCH] fix(sway): add missing includes for GCC 13
+
+See also: https://gcc.gnu.org/gcc-13/porting_to.html
+--- a/include/modules/sway/ipc/client.hpp
++++ b/include/modules/sway/ipc/client.hpp
+@@ -8,6 +8,7 @@
+ #include <cstring>
+ #include <memory>
+ #include <mutex>
++#include <string>
+
+ #include "ipc.hpp"
+ #include "util/sleeper_thread.hpp"
+--- a/src/modules/sway/ipc/client.cpp
++++ b/src/modules/sway/ipc/client.cpp
+@@ -2,6 +2,8 @@
+
+ #include <fcntl.h>
+
++#include <stdexcept>
++
+ namespace waybar::modules::sway {
+
+ Ipc::Ipc() {
+
diff --git a/gui-apps/waybar/waybar-0.9.17.ebuild b/gui-apps/waybar/waybar-0.9.17.ebuild
index 9d2f830e6558..cd71fa673ed4 100644
--- a/gui-apps/waybar/waybar-0.9.17.ebuild
+++ b/gui-apps/waybar/waybar-0.9.17.ebuild
@@ -59,6 +59,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/waybar-0.9.17-wireplumber.patch"
+ "${FILESDIR}/waybar-0.9.17-gcc13.patch"
)
src_configure() {