summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-07-03 21:42:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-07-03 21:42:45 +0300
commit87ac2d381abb2d897622f8ccfb97cc321091cc62 (patch)
tree63be03ae689d6d3930dda922818fd132256fd57a /gui-apps/grim
parentapp-editors/vscodium: drop 1.77.3.23102, 1.78.2.23132-r1 (diff)
downloadgentoo-87ac2d381abb2d897622f8ccfb97cc321091cc62.tar.gz
gentoo-87ac2d381abb2d897622f8ccfb97cc321091cc62.tar.bz2
gentoo-87ac2d381abb2d897622f8ccfb97cc321091cc62.zip
gui-apps/grim: add 1.4.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps/grim')
-rw-r--r--gui-apps/grim/Manifest1
-rw-r--r--gui-apps/grim/grim-1.4.1.ebuild51
-rw-r--r--gui-apps/grim/grim-9999.ebuild4
3 files changed, 54 insertions, 2 deletions
diff --git a/gui-apps/grim/Manifest b/gui-apps/grim/Manifest
index f6c8d088facd..42e0a0a8f197 100644
--- a/gui-apps/grim/Manifest
+++ b/gui-apps/grim/Manifest
@@ -1 +1,2 @@
DIST grim-1.4.0.tar.gz 18287 BLAKE2B 72606de01624c98876fe1018877a3cf0b25b44ac4bd6a053f82c40ad1ea2c6c0e510cbb6a0bce988f14607ea162dda1d8350b9f30b0f2b9acd8f8e20ba50bc99 SHA512 d0b33528a00528b3ef7488a0984cde5034de4f5a211eb5c8d3299aea356d9348c5d02d08171802bc0315afb19d2446f5f132ea9dca0579ace803b7d5d90a89cc
+DIST grim-1.4.1.tar.gz 18372 BLAKE2B cfb432205c9ef47bc292e995c0095f2df492bf0eae63556baa3c1f8a845171f71c5b632c78394b7fad02ac6508d266ea43f912f9cbb75bb786df91c4d38df1e9 SHA512 e6f5e540a4e70467971b932c4a36bda88742de360925cf1bb1908823f76ac295c8ef5ec953fcdeb083c39b13a8cd24a01d4739ae4cc37e106b60956266eeef22
diff --git a/gui-apps/grim/grim-1.4.1.ebuild b/gui-apps/grim/grim-1.4.1.ebuild
new file mode 100644
index 000000000000..87345a10a247
--- /dev/null
+++ b/gui-apps/grim/grim-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 meson
+
+DESCRIPTION="Grab images from a Wayland compositor"
+HOMEPAGE="https://sr.ht/~emersion/grim"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~emersion/${PN}"
+else
+ SRC_URI="https://git.sr.ht/~emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+man jpeg"
+
+RDEPEND="
+ dev-libs/wayland
+ media-libs/libpng
+ x11-libs/pixman
+ jpeg? ( media-libs/libjpeg-turbo )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/wayland-protocols-1.14
+"
+BDEPEND="man? ( app-text/scdoc )"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature jpeg)
+ $(meson_feature man man-pages)
+ "-Dbash-completions=false"
+ "-Dfish-completions=false"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ newbashcomp contrib/completions/bash/grim.bash grim
+ insinto /usr/share/fish/vendor_completions.d/
+ doins contrib/completions/fish/grim.fish
+}
diff --git a/gui-apps/grim/grim-9999.ebuild b/gui-apps/grim/grim-9999.ebuild
index 654a78d5cc27..87345a10a247 100644
--- a/gui-apps/grim/grim-9999.ebuild
+++ b/gui-apps/grim/grim-9999.ebuild
@@ -12,9 +12,9 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~emersion/${PN}"
else
- SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SRC_URI="https://git.sr.ht/~emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-v${PV}"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
fi
LICENSE="MIT"