summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/addresses
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/addresses')
-rw-r--r--gnustep-apps/addresses/Manifest2
-rw-r--r--gnustep-apps/addresses/addresses-0.4.7.ebuild22
-rw-r--r--gnustep-apps/addresses/addresses-0.4.8.ebuild21
-rw-r--r--gnustep-apps/addresses/files/addresses-0.4.7-as-needed.patch25
-rw-r--r--gnustep-apps/addresses/metadata.xml12
5 files changed, 82 insertions, 0 deletions
diff --git a/gnustep-apps/addresses/Manifest b/gnustep-apps/addresses/Manifest
new file mode 100644
index 000000000000..fd395f564e41
--- /dev/null
+++ b/gnustep-apps/addresses/Manifest
@@ -0,0 +1,2 @@
+DIST Addresses-0.4.7.tar.gz 263811 SHA256 ac2fe8cfe2e7cabcb51c74ecaba596bc399211f1560a7c45262af110ae365d73 SHA512 130358308c3bb0af5d1374ef9750dccaaa04ac985cc2e135890a5277fbaad0b327ecbb31f3711384619df1a29db2105b2230fe639a508166c7a43e54790825f0 WHIRLPOOL c4b5c5c71bb140c879060fe6289984bbfae58db4aa0717be5d654ad3d8297f9174724cf06f7a6ed616a6612a552c23aef0520411c105a55ad30d07e50eecfd6e
+DIST Addresses-0.4.8.tar.gz 287207 SHA256 329531bfd31db1845f3af385c1c2448f308b1bf28af5ee7d4f50f403dbb6ac0a SHA512 2cd6bd16620d3fa4136242dd89c3281800bba0caeb99e986d3d6beacf31ae19b3dd7f563da2fe52038781cca639815dfc740c15b0e5273facf8cc2400d90fc0f WHIRLPOOL 9dad61b0b8a6a84ca6183e4a38d6b63c00d8e12879ccf68b3dd6d9b513fadc1c12d90ba14a433c2749464a80102b5dc6fca5fa3bad733278b9a687c79fbe0c81
diff --git a/gnustep-apps/addresses/addresses-0.4.7.ebuild b/gnustep-apps/addresses/addresses-0.4.7.ebuild
new file mode 100644
index 000000000000..2797366cfbfc
--- /dev/null
+++ b/gnustep-apps/addresses/addresses-0.4.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/a/A}
+
+DESCRIPTION="Addresses is a Apple Addressbook work alike (standalone and for GNUMail)"
+HOMEPAGE="http://giesler.biz/bjoern/en/sw_addr.html"
+SRC_URI="http://savannah.nongnu.org/download/gap/${P/a/A}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
diff --git a/gnustep-apps/addresses/addresses-0.4.8.ebuild b/gnustep-apps/addresses/addresses-0.4.8.ebuild
new file mode 100644
index 000000000000..5d43f4f69638
--- /dev/null
+++ b/gnustep-apps/addresses/addresses-0.4.8.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnustep-2
+
+DESCRIPTION="Addresses is a Apple Addressbook work alike (standalone and for GNUMail)"
+HOMEPAGE="http://gap.nongnu.org/addresses/"
+SRC_URI="http://savannah.nongnu.org/download/gap/${P/a/A}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${P/a/A}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4.7-as-needed.patch
+}
diff --git a/gnustep-apps/addresses/files/addresses-0.4.7-as-needed.patch b/gnustep-apps/addresses/files/addresses-0.4.7-as-needed.patch
new file mode 100644
index 000000000000..cdb7a84755e3
--- /dev/null
+++ b/gnustep-apps/addresses/files/addresses-0.4.7-as-needed.patch
@@ -0,0 +1,25 @@
+diff -Naur AddressManager.orig/GNUmakefile AddressManager/GNUmakefile
+--- AddressManager.orig/GNUmakefile 2008-12-08 17:19:03.000000000 +0100
++++ AddressManager/GNUmakefile 2008-12-08 17:19:28.000000000 +0100
+@@ -24,8 +24,7 @@
+ AddressManager_OBJCFLAGS=-I../Frameworks -Wall
+ AddressManager_LDFLAGS=\
+ -L../Frameworks/AddressView/AddressView.framework/$(GNUSTEP_TARGET_LDIR) \
+- -L../Frameworks/Addresses/Addresses.framework/$(GNUSTEP_TARGET_LDIR) \
+- -lAddressView -lAddresses
++ -L../Frameworks/Addresses/Addresses.framework/$(GNUSTEP_TARGET_LDIR)
+
+ -include GNUmakefile.preamble
+ -include GNUmakefile.local
+diff -Naur AddressManager.orig/GNUmakefile.preamble AddressManager/GNUmakefile.preamble
+--- AddressManager.orig/GNUmakefile.preamble 2008-12-08 17:19:03.000000000 +0100
++++ AddressManager/GNUmakefile.preamble 2008-12-08 17:19:24.000000000 +0100
+@@ -27,7 +27,7 @@
+ # ObjC stuff
+ ADDITIONAL_OBJC_LIBS +=
+ # Tools
+-ADDITIONAL_TOOL_LIBS +=
++ADDITIONAL_TOOL_LIBS += -lAddressView -lAddresses
+ # WebObjects
+ ADDITIONAL_WO_LIBS +=
+
diff --git a/gnustep-apps/addresses/metadata.xml b/gnustep-apps/addresses/metadata.xml
new file mode 100644
index 000000000000..6afea6705913
--- /dev/null
+++ b/gnustep-apps/addresses/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnustep</herd>
+<longdescription>
+This package constitutes a personal address manager for the GNUstep
+software system. It allows archiving complete personal contact
+information, organizing contacts in groups, integration with other
+software such as mail clients and sharing address information with
+other users over the network.
+</longdescription>
+</pkgmetadata>